Go to main content

man pages section 7: Device and Network Interfaces

Exit Print View

Updated: July 2017
 
 

jconvrs (7M)

Name

jconvrs - code conversion STREAMS module (Japanese EUC/PC kanji)

Synopsis

#include <sys/types.h>
#include <sys/stropt.h>
#include <sys/conf.h>
ioctl(fd, I_PUSH, "jconvrs");

Description

jconvrs is a STREAMS module that is available to be pushed onto a stream. Usually, this module has to be pushed onto a stream between terminal circuit module such as ldterm (7M) and STREAMS compatible module such as ttcompat(7M) .

jconvrs has to be pushed when you operate PC kanji data. It converts up stream for Japanese EUC into PC kanji code and passes high module. It also converts down stream for PC kanji code into Japanese EUC and passes low module. jconvrs controls terminal circuit under PCK environment by using with jconvs(7M) .

Ioctls

jconvrs processes the following ioctls:

EUC_OXLON

Start performing code conversion between Japanese EUC and PC kanji for I/O stream.

EUC_OXLOFF

Stop performing code conversion between Japanese EUC and PC kanji for I/O stream.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/locale/extra

See Also

setterm(1), stty(1), PCK(5), streamio(7I), jconv7 (7M), jconv8 (7M), jconvru (7M), jconvs (7M), jconvu (7M), ldterm (7M), ptem (7M)

Notes

When you use jconvrs with jconvs (7M), jconvu (7M), jconv7 (7M), or jconv8 (7M) at a time and `raw' is specified by stty(1), code convert function automatically become off without specification by EUC_OXLON / EUC_OXLOFF .

jconvrs supports PC kanji/Japanese EUC code conversion under TOG Japanese Vendors Council (TOG/JVC) Recommended Code Set Conversion Specification between Japanese EUC and Shift–JIS.