Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

audio_engine_rate(9E)

Name

audio_engine_rate - return the sample rate of an audio engine

Synopsis

#include <sys/audio/audio_driver.h>

int prefix_rate(void *state);

Parameters

state

pointer to driver supplied soft state

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_engine_rate() function is called by the framework to determine the sample rate of the engine, represented in Hz.

Return Values

The audio_engine_rate() function returns the sample rate of the engine expressed in Hz.

Context

This function may be called from user or interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

audio(4D), attributes(7), audio_engine_ops(9S)