JavaFX 2.0.2 System Requirements

Use the following information to ensure that your operating system, browser, and Java platform meet the requirements for running the JavaFX technology. Also included are the hardware requirements for accelerated rendering of graphics and the supported NetBeans IDE version.

Operating Systems and Browsers

You must run an operating system and browser that are compatible with JavaFX, as shown in Table 1.

Table 1 JavaFX Compatible Operating Systems and Browsers

Operating System (32-Bit and 64-Bit) Browsers (32-Bit and 64-Bit)

Windows XP Home and Professional with Service Pack 3Foot 1 

Internet Explorer 7 and 8


Windows Vista Home Basic, Home Premium, Business, and Ultimate with Service Pack 2

Internet Explorer 7, 8, and 9

Firefox 3.5, 3.6, and 4


Windows 7 Home Premium, Professional, and Ultimate

Internet Explorer 8 and 9

Firefox 3.5, 3.6, and 4


Footnote 1 For 64-bit Windows XP, only the 32-bit JDK and 32-bit JavaFX runtime are supported.

A JavaFX Developer Preview is available for Mac OS X.

Java Platform

You must have a minimum of Java SE 6 Update 29 or Java SE 7 Update 1 installed on your system.

Graphics Support

You will notice an accelerated rendering of graphics in your JavaFX applications if your system has support for the new Prism hardware pipeline. Prism supports a wide range of GPUs currently available in the market. Table 2 lists the graphics cards that have been tested with Prism. If your system does not support Prism, then JavaFX uses the Java2D software pipeline under Prism.

Table 2 Graphics Cards Supported by Prism

Graphics Card Supported Graphics Processing Units (GPUs)


Mobile GPUs: GeForce 8M and 100M series or higher, NVS 2100M series or higher, and Mobility Quadro FX 300M series or higher

Desktop GPUs: GeForce 8 and 100 series or higher

Workstation GPUs: Quadro FX 300 series or higher


Mobile GPUs: Mobility Radeon HD 3000, 4000, and 5000 series

Desktop GPUs: Radeon HD 2400, 3000, 4000, 5000, and 6000 series


Mobile GPUs: GMA 4500MHD and GMA HD

Desktop GPUs: GMA 4500 and GMA HD

NetBeans IDE Support

You must use NetBeans IDE 7.1 (at least a prerelease version) to create JavaFX 2.0.2 applications.