In addition to this section, review the Oracle Fusion Middleware Error Messages guide for information about the encountered error messages.
This section contains the following topics:
This section describes how to use the log files and how to recover from provisioning failures. It contains the following topics:
To monitor provisioning using the wizard, click the icon under the Log field from any phase screen to see the logs for the current phase. The logs are searchable using the search box at the top of this new window. The log window does not refresh on its own, so click Refresh besides the search box at the top of this window to refresh the logs.
To check why a phase failed when the wizard is not running, check the corresponding logs files present under the logs directory using the following commands.
On Linux: INSTALL_APPCONFIG_DIR
/provisioning/logs/
hostname
.
Oracle Identity Management Provisioning does not have any backup or recovery mechanism, so it is necessary to start from the beginning in case of a failure.
If a workaround that requires to rerun Oracle Identity Management Provisioning is performed, clean up the environment before rerunning it. Do the following:
This section describes common problems and solutions. It contains the following topics:
Problem
Provisioning fails.
Solution
Check the provisioning logs located in the directory:
INSTALL_APPCONFIG_DIR/provisioning/logs/
hostname
where hostname
is the host where the provisioning step failed.
Problem
Investigation into the OID logs shows that the OID account is locked.
This is generally caused by the load balancer. The load balancer is continually polling OID to see if it is available using the given credentials. During setup, this can cause the account to become locked.
Solution
Disable the OID load balancer monitor during preconfiguration. Then enable it when provisioning is complete. Another alternative is to reduce the check frequency.
Problem
After running the Oracle Identity Management Provisioning Wizard, only one instance directory for Oracle Directory Services Manager is installed.
Solution
The absence of the ODSM instance directory on the second node does not result in any loss of function.
Problem
During Oracle Identity Management Provisioning, patches are applied to all products provisioned, including WebLogic. This entails running the Smart Update bsu
command. This command may fail without producing a detailed error message.
Cause
In this case, the failure is likely caused by directory paths that are longer than what the bsu
command supports. Verify this by running the bsu
command manually, passing it the -log
option, and looking for a stack trace containing a message such as the following:
java.lang.IllegalArgumentException: Node name?a?very?long?path?which?may?cause?problems?leading?to?an?IDMTOP?products?dir?utils?bsu?cache_dir too long
See Using the Command Line Interface in the Oracle Smart Update Applying Patches to OracleWebLogic Server guide.
Solution
When planning the Oracle Identity Management deployment, ensure that the IDM_TOP
path is 45 characters or fewer in length.
Problem
If the Oracle Identity Management Patch Manager progress
command is run after Oracle Identity Management Provisioning completes, the output shows an active session specific to Oracle Identity Management Provisioning, which is listed as ACTIVE, and contains a set of PLANNED steps.
Solution
Safely ignore this output. The provisioning-driven patch session is complete, and all steps which needed to run have run. Creating a new patch session silently replaces this special session without error.
Problem
During the install phase of provisioning, a message Starting binary patching for all-binary-patch components ...
might be displayed, followed by a series of OPatch failure messages prefaced with the string prepatch
within the provisioning log. These errors contain the string Failed to load the patch object
.
Solution
These messages are harmless and can be safely ignored.
Problem
The Oracle Identity Management Provisioning Wizard hangs. Neither the Next nor the Back button is active.
Cause
This problem is due to stale Network File System (NFS) file handles.
Solution
On Linux or UNIX, issue the following command:
df –k
Record the output of the df
command, even if it is successful, in case further analysis is necessary. For example, take a screenshot.
If the df
command hangs or is unsuccessful, work with the system administrator fix the NFS problem.
After the NFS problem has been resolved and the df
command finishes successfully, run provisioning again.
Problem
Provisioning fails during the Install phase.
Cause
Some 32-bit libraries such as crt1.o
are missing.
Solution
There are two ways to fix this. Do one of the following:
Copy the 32-bit libraries gcrt1.o
, crtn.o
, crti.o,
crt1.o
, Scrt1.o
, and Mcrt1.o
from /usr/lib/
on another machine running the same version.
Install the missing package glibc-devel.i686
Use My Oracle Support (formerly MetaLink) to help resolve Oracle Fusion Middleware problems. My Oracle Support contains several useful troubleshooting resources, such as:
Knowledge base articles
Community forums and discussions
Patches and upgrades
Certification information
Use My Oracle Support to log a service request. Access My Oracle Support at https://support.oracle.com
.
Go to Create a Response File which describes the process of creating a response file for a new Oracle Fusion Applications environment using the Provisioning Wizard interview process.