#include <ddm/ddm.h>KnError svDdmClose(void);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The svDdmClose() call closes a previously made connection to the device driver manager.
This means that the handler provided in the svDdmOpen() call will no longer be called if an event occurs on one of the manageable device nodes. In addition all resources allocated by the DDM to keep a list of manageable devices, are released.
Upon successful completion K_OK is returned. When svDdmClose() is invoked more than once subsequently it always returns K_OK. Otherwise a negative error code is returned.
The child_init driver management entry point detects that the driver property is set to PROP_ACTIVE
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
svDdmOpen(2K), svDdmGetState(2K), svDdmEnable(2K), svDdmDisable(2K), svDdmShutdown(2K), svDdmOffline(2K), svDdmOnline(2K), svDdmGetStats(2K), svDdmAudit(2K), svDdmDiag(2K), svDdmGetInfo(2K), DDM(5FEA)