#include <ddm/ddm.h>KnError svDdmEnable(DevNode node);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The svDdmEnable() call enables a client to set the availability state of the specified device node to DDM_AVSTATE_ENABLED. Once the device is enabled, it is no longer locked and a driver may be started for it.
Upon completion K_OK is returned provided the device was successfully enabled. Otherwise, a negative error code is returned which indicates why the call was not successful.
The specified node is not recognized as a manageable device
The system is out of resources. This indicates a severe system error.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|
svDdmOpen(2K), svDdmClose(2K), svDdmGetState(2K), , svDdmDisable(2K), svDdmShutdown(2K), svDdmOffline(2K), svDdmOnline(2K), svDdmGetStats(2K), svDdmAudit(2K), svDdmDiag(2K), svDdmGetInfo(2K), DDM(5FEA)