#include <ipc/chId.h>int uiLocalSite(int *site);
The function or functions documented here may not be used safely in all application contexts with all APIs provided in the ChorusOS 5.0 product.
See API(5FEA) for details.
The uiLocalSite system call returns the local site number to the value pointed to by site.
A site number is a 32 bit unsigned integer, but uiLocalSite returns the value of the local site number as a signed integer.
Upon successful completion K_OK is returned. Otherwise, a negative error code is returned.
See attributes(5) for descriptions of the following attributes:
|ATTRIBUTE TYPE||ATTRIBUTE VALUE|