Sun Update Connection - Enterprise Troubleshooting Guide

Troubleshooting Non-Certified Objects (NCOs)

Non-certified objects (NCOs) are components or software from a local environment, a third party, or Solaris that have not passed certification and is not permitted to be distributed without a specific license. NCO software is not in the knowledge base of the universal server (such as private, proprietary, and third-party software packages), but is installed on a local machine or for which you have a source, such as a third-party CD.

For more information about NCOs and local inventory management, see the Sun Update Connection – Enterprise 1.0 User's Guide.

Cannot Attach NCO

Situation

Upload of the Attach procedure failed with the following error:


Package-Name mismatch. Use Add button.
Cause

The selected component and the RPM you selected to attach have different names.

Solution

Use the Add feature instead of Attach.

Attached NCO is Marked With an Exclamation Point in a Red Circle

Situation

Upload succeeded, but the package icon is marked with an exclamation point in a red circle.

The rules of this RPM show that dependent components are missing from the local knowledge base.

Solution

See To Fix Local Software Missing Dependencies in Sun Update Connection – Enterprise 1.0 User’s Guide in the Sun Update Connection – Enterprise 1.0 User’s Guide.

Cannot Find NCO

Situation

Upload of the Attach procedure succeeded, but the NCO is not listed under Local RPMs or under Local PKGs.

A CO (under Software, rather than under Local) has the same name, version, and release. Your NCO was added to the package group of the appropriate name under Software.

Solution

Run the Local Software Review predefined test. To get information about predefined profiles, see Chapter 7, System Management Profiles, in Sun Update Connection – Enterprise 1.0 User’s Guide in the Sun Update Connection – Enterprise 1.0 User’s Guide, or use the Find feature to find this software component and to check that the listing is correct for your component.

Cannot Delete an NCO Component

Situation

When you try to delete a selected Local component, you receive the following error message:


Cannot be deleted.

If an NCO is installed on any managed host within the selected distributions, it will be detected and uploaded again. To prevent Sun Update Connection – Enterprise from undoing your delete command, the message reminds you to uninstall the software component from all hosts before deleting it from the knowledge base.

Solution

Do the following:

  1. Open the Inventory panel (View -> Inventory).

  2. From the Components list, right-click the software component and choose Component Properties. The Component Information window opens. In the Installed tab, see the list of all managed hosts that have this component installed.

  3. Create and deploy a job to uninstall this component from the listed hosts.

  4. Return to the main window and delete the component.