Sun Update Connection - Enterprise Troubleshooting Guide

Troubleshooting

This book provides some of the more common issues in Sun Update Connection – Enterprise and resolutions.

Restarting Applications

The system dependency server starts automatically after installation. If you need to restart it, you must restart both the server application, which includes the knowledge base, and the dependency manager application.

ProcedureTo Restart the System Dependency Server

The system dependency server starts automatically after installation. If you need to restart it, you must restart both the server application, which includes the knowledge base, and the dependency manager application.

  1. Log in to the system dependency server as superuser.

  2. Restart the server.


    # /etc/init.d/uce_server restart
    
  3. Restart the DM:


    # /etc/init.d/uce_engine restart
    
  4. (Optional) If you have a proxy SDS, restart the proxy.

    1. Log in to the system dependency server proxy system as superuser.

    2. Restart the main server.

    3. Restart the proxy:


      # /etc/init.d/uce_proxy restart
      
  5. Restart the DM of both the server and the proxy server.

ProcedureTo Restart the Agent

The agent starts automatically after installation.

  1. Log in to the managed host as superuser.

  2. Restart the agent.


    # /etc/init.d/uce_agent restart
    

Agent Not Connecting To The SDS

    If an agent is not connecting to the SDS, perform the following steps to troubleshoot the problem:

  1. Verify that the server is listening on port 8002.

  2. Verify that the agent is sending data out on port 8002.

    # netstat -an | grep 8002

  3. Verify that other agents can connect to the SDS.

  4. Reload the agent or restart the agent.

ProcedureTo Reload the Agent

  1. Log in to the managed host as superuser.

  2. Restart the agent.


    # /etc/init.d/uce_agent reload
    

Clone Inventory Jobs Errors

For more information about cloning inventories, see Cloning Inventories in Sun Update Connection – Enterprise 1.0 User’s Guide in the Sun Update Connection – Enterprise 1.0 User's Guide.

The following errors might be the result of clone inventory job:

Local Inventory Management Failure

Local inventory includes your software, scripts, binaries, executables, and configuration files that are stored on your universal server in your local environment. For more information about local inventory management, see the Sun Update Connection – Enterprise 1.0 User's Guide.

Situation

An Sun Update Connection – Enterprise command fails with the following error:


Cannot process command. Reason: another command running.
Cause

Sun Update Connection – Enterprise is busy handling back-end processes and your new command timed out. This error is most commonly seen while you manage local inventories.

Solution

Execute the command again, or wait a few minutes before running the command again.

Troubleshooting Non-Certified Objects (NCOs)

Non-certified objects (NCOs) are components or software from a local environment, a third party, or Solaris that have not passed certification and is not permitted to be distributed without a specific license. NCO software is not in the knowledge base of the universal server (such as private, proprietary, and third-party software packages), but is installed on a local machine or for which you have a source, such as a third-party CD.

For more information about NCOs and local inventory management, see the Sun Update Connection – Enterprise 1.0 User's Guide.

Cannot Attach NCO

Situation

Upload of the Attach procedure failed with the following error:


Package-Name mismatch. Use Add button.
Cause

The selected component and the RPM you selected to attach have different names.

Solution

Use the Add feature instead of Attach.

Attached NCO is Marked With an Exclamation Point in a Red Circle

Situation

Upload succeeded, but the package icon is marked with an exclamation point in a red circle.

The rules of this RPM show that dependent components are missing from the local knowledge base.

Solution

See To Fix Local Software Missing Dependencies in Sun Update Connection – Enterprise 1.0 User’s Guide in the Sun Update Connection – Enterprise 1.0 User’s Guide.

Cannot Find NCO

Situation

Upload of the Attach procedure succeeded, but the NCO is not listed under Local RPMs or under Local PKGs.

A CO (under Software, rather than under Local) has the same name, version, and release. Your NCO was added to the package group of the appropriate name under Software.

Solution

Run the Local Software Review predefined test. To get information about predefined profiles, see Chapter 7, System Management Profiles, in Sun Update Connection – Enterprise 1.0 User’s Guide in the Sun Update Connection – Enterprise 1.0 User’s Guide, or use the Find feature to find this software component and to check that the listing is correct for your component.

Cannot Delete an NCO Component

Situation

When you try to delete a selected Local component, you receive the following error message:


Cannot be deleted.

If an NCO is installed on any managed host within the selected distributions, it will be detected and uploaded again. To prevent Sun Update Connection – Enterprise from undoing your delete command, the message reminds you to uninstall the software component from all hosts before deleting it from the knowledge base.

Solution

Do the following:

  1. Open the Inventory panel (View -> Inventory).

  2. From the Components list, right-click the software component and choose Component Properties. The Component Information window opens. In the Installed tab, see the list of all managed hosts that have this component installed.

  3. Create and deploy a job to uninstall this component from the listed hosts.

  4. Return to the main window and delete the component.

Disaster Recovery

The following situations might occur during backup or restore: