| Sun ONE Messaging and Collaboration 6.0 スキーマリファレンス |
第 3 章
属性この章では、SunTM Open Net Environment (ONE) Messaging and Collaboration 製品の LDAP オブジェクトクラスで使用する属性について説明します。属性は、アルファベット順に並べてあります。
Sun ONE Identity Server だけで使用される属性については、第 4 章「Sun ONE Identity Server のクラスと属性」で説明します。一方、iPlanet Delegated Administrator for Messaging だけで使用される属性については、第 5 章「iPlanet Delegated Administrator for Messaging のクラスと属性」で説明します。
属性のリストこの章では、次の属性について説明します。
属性の定義
adminRole初出
iPlanet Messaging Server 5.0
構文
cis
オブジェクトクラス
定義
この管理者エントリについての管理者のロールを指定します。
例
OID
2.16.840.1.113730.3.1.601
aliasedObjectName初出
iPlanet Messaging Server 5.0
構文
dn
オブジェクトクラス
定義
DC ツリーが存在する Sun ONE LDAP Schema v.2 の互換モードでのみ使用され、DC ツリーが存在しないネイティブモードでは使用されません。
ディレクトリのエイリアスエントリを特定するために、ディレクトリサーバーで使用されます。エントリの識別名を含みます。ドメイン属性値は、参照ドメインからのみ取得されます。そのため、これらのドメイン間でのルーティングは同じになります。
例
aliasedObjectName:cn=jdoe,o=sesta.com
OID
2.5.4.1
businessCategory初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
groupOfUniqueNames, organization, organizationalUnit
定義
このエントリが関わるビジネスのタイプを識別します。これは、会社の部レベルのように大まかな一般化された値にする必要があります。
例
businessCategory:Engineering
OID
2.5.4.15
calCalURI初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーのデフォルトカレンダー全体への URI を含みます。詳細は、「RFC 2739」を参照してください。
例
実装された iPlanet Calendar Server のバージョンに応じて変化します。詳細は、「RFC 2739」を参照してください。
OID
1.2.840.113556.1.4.478
calFBURL初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーのデフォルトのビジータイムデータへの URL。詳細は、「RFC 2739」を参照してください。
例
実装された iPlanet Calendar Server のバージョンに応じて変化します。詳細は、「RFC 2739」を参照してください。
OID
1.2.840.113556.1.4.479
cn初出
iPlanet Calendar Server 5.1
構文
cis、single-valued
オブジェクトクラス
icsCalendarResource, icsCalendarUser, inetResource
定義
ユーザーの場合、その人の氏名。リソースの場合、一意の識別子。どちらの場合も、スペースと特殊文字を含んでいてもかまいません。これは、commonName の省略形です。
例
ユーザーの場合 : cn:John Doe
ユーザーの場合 : cn:Conference Room #3
または
commonName:John Doe
commonName:Conference Room #3
OID
2.5.4.3
co初出
LDAP
構文
cis
オブジェクトクラス
定義
2 文字のコードを使用した国名を含みます。これは、countryName の省略形です。
friendlyCountryName 属性は、実際の国名を略さずに書くために使用されます。
例
co:IE
または
countryName:IE
friendlyCountryName:Ireland
OID
2.5.4.4
commonName (「cn」を参照)
countryName (「co」を参照)
dataSource初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
タグまたは識別子を格納するためのテキストフィールド。この値が操作に影響を与えることはありません。
例
dataSource:1.0
OID
2.16.840.1.113730.3.1.779
dateOfBirth初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
pabPerson の誕生日。フォーマット : YYYYMMDD.
例
dateOfBirth 19740404
(1974 年 4 月 6 日の誕生日)OID
2.16.840.1.113730.3.1.779
dc初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ドメインエイリアスエントリのドメインコンポーネント
例
dc=sesta
たとえば、ドメインエイリアスエントリ DN は次のようになります。
dn:dc=sesta, dc=fr, o=internet.OID
0.9.2342.19200300.100.1.25
description初出
LDAP
構文
cis、multi-valued
オブジェクトクラス
icsCalendarDWPHost, icsCalendarResource, groupOfUniqueNames, inetOrgPerson, organization, organizationalUnit, pab, pabGroup, sunServiceComponent
定義
人が読むことが可能なオブジェクト記述。対象が人または組織で、役割や仕事の割り当てが含まれることがよくあります。
例
description:Quality control inspector
OID
2.5.4.13
domainUidSeparator初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
この属性は、Sun ONE LDAP Schema v.1 でのみ使用されます。
この属性は、デフォルトのメールボックス (MB) のホームをオーバライドするために、メッセージングサーバーによって使用されます。この属性が存在する場合は、複合したユーザー ID (UID) がこのドメイン内で使用されることを示します。また、この属性で区切り文字を指定します。たとえば、+ が区切り文字の場合、このドメインのメールボックス名は、uid の右端の + を @ で置き換えて取得されます。内部メールボックス名を UID とマップする場合は、メールボックス名の右端の @ を + で置き換えます。
UID 区切り文字の @ の置換はメールボックス名を生成するには十分ですが、これはユーザーの実際の電子メールアドレスと同じでない場合があります。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_UID_SEPARATOR です。
例
domainUIDSeparator: #
OID
2.16.840.1.113730.3.1.702
domOrgMaxUsers初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
この属性は、Sun ONE LDAP Schema v.1 でのみ使用されます。
ドメイン組織内のユーザーエントリの最大数
例
domOrgMaxUser: 500
OID
2.16.840.1.113730.3.1.697
domOrgNumUsers初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ドメイン組織内の現在のユーザーエントリ数
例
domOrgNumUsers: 345
OID
2.16.840.1.113730.3.1.698
facsimileTelephoneNumber初出
iPlanet Calendar Server 5.1
構文
tel、single-valued
オブジェクトクラス
icsCalendarResource, inetResource, organization, organizationalUnit
定義
リソースのファックス番号
例
facsimileTelephoneNumber 1-800-555-1212
OID
2.5.4.23
givenName初出
LDAP
構文
cis
オブジェクトクラス
定義
エントリの名 (通常はファーストネーム) を指定します。
例
givenName:John
OID
2.5.4.42
icsAdminRole初出
iPlanet Calendar Server 5.1
構文
cis
オブジェクトクラス
定義
グループに割り当てる管理カレンダーのロール。
例
OID
2.16.840.1.113730.3.1.724
icsAlias初出
iPlanet Calendar Server 5.1
構文
cis、UTF8 エンコード
オブジェクトクラス
定義
リソースに関連付けられたエイリアス。エイリアスによりエンドユーザーが簡単にリソース名を扱うことができます。
例
「halleyscomet」という名前のリソースのエイリアスは、「Halley's Comet」です。
icsAliasHalley's Comet
OID
2.16.840.1.113730.3.1.725
icsAllowedServiceAccess初出
Sun ONE Calendar Server 5.1.1
構文
cis、single-valued
オブジェクトクラス
icsCalendarDomain, icsCalendarUser
定義
この属性は、icsStatus 属性が設定されていない場合に限り、使用が可能です。つまり icsStatus が設定されている場合、この属性は無視されます。
この属性を使用すると、ユーザーのカレンダーサービスを無効にできます。デフォルトではすべてのユーザーが http でアクセスできます。しかし、この属性を例で示したように指定すると、ユーザーはカレンダーアクセスを取得できなくなります (ユーザーが無効になる)。
その他の設定、または属性全体が存在しない場合では、ユーザーは http サービスへアクセスできます (ユーザーは有効)。
例
icsAllowedServiceAccess:http
OID
2.16.840.1.113730.3.1.726
icsAllowRights初出
iPlanet Calendar Server 5.1
構文
int、single-valued
オブジェクトクラス
定義
数値文字列を使用してビットフィールドを保持します。各ビットフィールドは権限セットに対応します。各ビットフィールドは、ics.conf ファイルの設定に対応します。必要なビットの文字列設定を検出したら、ビットを整数に変換します。
プロパティが設定されている (1) 場合、権限は付与されません。プロパティが設定されていない (0) 場合、権限は付与されます。
この属性が存在しない場合、対応する ics.conf のデフォルト設定が使用されます。
表 3-1 ではビット 0 から 15 の各ビットポジションの意味を定義します。
例
次のビットを拒否する場合 :
ビットパターンは次のようになっています。
'00000000000000000000101000000100'
このパターンを整数値 2564 に変換します。
icsAllowRights: 2564
OID
2.16.840.1.113730.3.1.727
icsAnonymousAllowWrite初出
iPlanet Calendar Server 5.1
構文
論理値 (yes、no)
オブジェクトクラス
定義
匿名ユーザーが公開カレンダーにイベントを書き込めるかを指定します。値は ics.conf 設定の service.wcap.anonymousallowpubliccalendarwrite から取得します。
例
icsAnonymousAllowWrite:yes
OID
2.16.840.1.113730.3.1.728
icsAnonymousCalendar初出
iPlanet Calendar Server 5.1
構文
ces
オブジェクトクラス
定義
匿名ユーザーのカレンダー ID。値は ics.conf 設定の calstore.anonymous.calid から取得します。
例
icsAnonymousCalendar:guest1
OID
2.16.840.1.113730.3.1.729
icsAnonymousDefaultSet初出
実装されていません。
構文
cis、UTF8 エンコード
オブジェクトクラス
定義
匿名ユーザーのデフォルトのカレンダーセット。
例
OID
2.16.840.1.113730.3.1.730
icsAnonymousLogin初出
iPlanet Calendar Server 5.1
構文
論理値 (yes、no)
オブジェクトクラス
定義
匿名のログインを許可するかを指定します。値は ics.conf ファイル設定の service.http.allowanonymousLogin から取得します。
例
icsAnonymousLogin:yes
OID
2.16.840.1.113730.3.1.798
icsAnonymousSet初出
実装されていません。
構文
cis、UTF8 エンコード
オブジェクトクラス
定義
予約済実装されていません。
匿名ユーザーのデフォルトのカレンダーセット。
例
OID
2.16.840.1.113730.3.1.732
icsCalendar初出
iPlanet Calendar Server 5.1
構文
ces、single-valued
オブジェクトクラス
icsCalendarResource, icsCalendarUser
定義
ユーザーまたはリソースのデフォルトのカレンダー。必須の属性。固有のユーザー ID に基づいたカレンダー ID を構築するための Calendar Server のポリシー。
例
icsCalendarjdoe
OID
2.16.840.1.113730.3.1.731
icsCalendarOwned初出
iPlanet Calendar Server 5.1
構文
ces、multi-valued
オブジェクトクラス
定義
指定したユーザーが所有するカレンダー。必須の属性。ユーザーのデフォルトカレンダー値を設定します。
例
icsCalendarjdoe
OID
1.3.6.1.4.1.42.2.27.9.1.6
icsCapacity初出
実装されていません。
構文
int、single-valued
オブジェクトクラス
定義
予約済、実装されていません。
例
OID
2.16.840.1.113730.3.1.800
icsContact初出
実装されていません。
構文
cis、UTF8 エンコード
オブジェクトクラス
定義
予約済、実装されていません。
リソースの管理者名。
例
icsContactJohn Doe jdoe@sesta.com
OID
2.16.840.1.113730.3.1.733
icsDefaultAccess初出
iPlanet Calendar Server 5.1
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーのデフォルトカレンダーに適応するデフォルトのアクセス制御の文字列。アクセス制御に関する詳細は、『Sun ONE Calendar Server Programmer's Manual』の「Access Control Entries」を参照してください。この属性が存在しない場合、値は ics.conf ファイル設定の calstore.calendar.default.acl から取得します。
例
カレンダーコンポーネントに対する「空き / 予定あり」と「スケジュールする」の両方の権限をユーザーに付与します。
icsDefaultAccess@sesta.com^c^sf^g
OID
2.16.840.1.113730.3.1.734
icsDefaultSet初出
iPlanet Calendar Server 5.1
構文
ces、single-valued
オブジェクトクラス
定義
ログイン時にどのカレンダーを表示するかについてのユーザー設定。ユーザーは、ログイン時に表示されるカレンダーを、単一のカレンダーでなく任意のカレンダーセット (作成したカレンダーのグループ) で指定することができます。
例
icsDefaultSetMyCalendarGroup
OID
2.16.840.1.113730.3.1.735
icsDomainAllowed初出
実装されていません。
構文
cis、single-valued (mgrpAllowedDomain を参照)
オブジェクトクラス
定義
許可するドメインを指定します。この値の形式は、次のとおりです。
service-list:client-list
service-list は、空白あるいはカンマで区切られた 1 つ以上のサービス名あるいはワイルドカードのリストです。client-list は空白あるいはカンマで区切られた 1 つ以上のホスト名かアドレスと、パターンかワイルドカードのリストです。
システムで認識される明示的なワイルドカードを次に示します。
ALL
常に一致する
LOCAL
すべてのホスト (ドット文字を含まない名前を持つホスト) に一致する
UNKNOWN
名前とアドレスを認識できないホストに一致する。注意して使用する
KNOWN
名前とアドレスを認識できるホストに一致する。注意して使用する
DNSSPOOFER
IP アドレスと DNS 名が一致しないすべてのホストに一致する
service-list と client-list で使用できる演算子が 1 つあります。
EXCEPT
list 2 に一致しない場合、list 1 に一致するものが、すべて一致する。
通常、形式は次のとおりです。list1 EXCEPT list2list1 と list2 はカンマ区切りのリストです。
パターンを使用して、接続可能なネットワークアドレスごとにクライアントを識別できます。例 : service@host_pattern:client-list
デフォルト値は、ics.conf ファイルの service.http.domainallowed から取得します。
例
sesta.com ドメインで、すべてのユーザーにローカルアクセスを許可します。
icsDomainAllowed:ALL:sesta.com
OID
2.16.840.1.113730.3.1.736
icsDomainNames初出
iPlanet Calendar Server 5.1.1
構文
cis、multi-valued、ASCII
オブジェクトクラス
定義
クロスドメイン検索を実行するには、この属性を使用して検索対象ドメインをリストに載せる必要があります。
例
icsDomainNamessesta.com
icsDomainNamessiroe.comOID
1.3.6.1.4.1.42.2.27.9.1.3
icsDomainNotAllowed初出
iPlanet Calendar Server 5.1
構文
cis、single-valued (mgrpDisallowedDomain を参照)
オブジェクトクラス
定義
拒否するドメインを指定します。この値の形式は、次のとおりです。
service-list:client-list
service-list は、空白あるいはカンマで区切られた 1 つ以上のサービス名あるいはワイルドカードのリストです。client-list は空白あるいはカンマで区切られた 1 つ以上のホスト名かアドレスと、パターンかワイルドカードのリストです。
システムで認識される明示的なワイルドカードを次に示します。
ALL
常に一致する
LOCAL
すべてのホスト (ドット文字を含まない名前を持つホスト) に一致する
UNKNOWN
名前とアドレスを認識できないホストに一致する。注意して使用する
KNOWN
名前とアドレスを認識できるホストに一致する。注意して使用する
DNSSPOOFER
IP アドレスと DNS 名が一致しないすべてのホストに一致する
service-list と client-list で使用できる演算子が 1 つあります。
EXCEPT
list 2 に一致しない場合、list 1 に一致するものが、すべて一致する。
通常、形式は次のとおりです。list1 EXCEPT list2list1 と list2 はカンマ区切りのリストです。
値は、ics.conf 設定の service.http.domainnotallowed から取得します。
例 1
選択したホスト以外のすべてのホストにアクセスを許可する場合、次の例に示すようにアクセスを拒否することができます。
company22.com ドメインですべてのユーザーにアクセスを拒否します。
icsDomainNotAllowed:ALL:company22.com
このインスタンスでは、特定の icsDomainAllowed 属性は必要ありません。
例 2
アクセスのデフォルトを実装しない場合、属性の 1 つのインスタンスで実行できます。icsDomainAllowed 属性でアクセスを許可されていない場合、すべてのホストに対してすべてのサービスへのアクセスを拒否します。
icsDomainNotAllowed:ALL:ALL
例 3
次の例では、不明なユーザーのアクセスを拒否します。
icsDomainNotAllowed:ALL:UNKNOWN@ALL
OID
2.16.840.1.113730.3.1.737
icsDWPBackEndHosts初出
Sun ONE Calendar Server 5.1.1
構文
cis、multi-valued
オブジェクトクラス
定義
このドメインに存在するカレンダーで使用可能なバックエンドホストのリスト。Calendar Server が Database Wire Protocol (DWP) を使用している場合、この属性は必須です。
例
icsDWPBackEndHosts:machine1
icsDWPBackEndHosts:machine2OID
1.3.6.1.4.1.42.2.27.9.1.5
icsDWPHost初出
iPlanet Calendar Server 5.1.1
構文
cis、single-valued、ASCII
オブジェクトクラス
icsCalendarDWPHost, icsCalendarResource, icsCalendarUser
定義
DWP ホスト名を格納します。すると、カレンダー ID が、カレンダーとそのデータを格納する Database Wire Protocol (DWP) サーバーで解決されます。カレンダーデータベースを複数のバックエンドサーバーに分散すると、属性値はユーザーのバックエンドホストの DNS 名になります。各ユーザーのすべてのカレンダーは、1 つのバックエンドサーバー上に存在します。Calendar Lookup Database (CLD) を使用する場合は必須です。
Calendar をインストールする際、DWP を使用して、複数のバックエンドカレンダーデータサーバーにカレンダーデータを分散する場合、この属性は必須です。DWP が使用されていない場合、各ユーザーのカレンダーはカレンダーサーバーと同じホスト上に存在します。DWP を使用するように後で設定する場合、Calendar Server はドメインエントリに存在するデフォルトの DWP ホスト名に基づいて値を設定します。値あるいはエントリが存在しない (Calendar Server がホストドメインモードではない) 場合、値は ics.conf 設定ファイルから取得します。
例
icsDWPHost:calserv1
OID
1.3.6.1.4.1.42.2.27.9.1.1
icsExtended初出
Sun ONE Calendar Server 5.1.1
構文
cis、multi-valued
オブジェクトクラス
定義
カレンダーの拡張。予約済
例
OID
2.16.840.1.113730.3.1.738
icsExtendedDomainPrefs初出
iPlanet Calendar Server 5.1
構文
cis、multi-valued
オブジェクトクラス
定義
表 3-2 で示すプロパティを使用して、カレンダードメインを設定します。各属性値はプロパティと値のペアです。プロパティのデフォルト設定は、ドメインサーバーの ics.conf ファイルに存在します。この属性が存在しない場合、ics.conf 設定が使用されます。
例
icsExtendedDomainPrefs:createLowerCase=yes
icsExtendedDomainPrefs:domainAccess=@@d^a^slfrwd^g;anonymous^a^r^g;@^a^s^g
OID
2.16.840.1.113730.3.1.739
icsExtendedGroupPrefs初出
iPlanet Calendar Server 5.1
構文
cis
オブジェクトクラス
定義
カレンダーグループ設定の拡張。予約済み
例
OID
2.16.840.1.113730.3.1.740
icsExtendedResourcePrefs初出
実装されていません。
構文
cis
オブジェクトクラス
定義
予約済、実装されていません。
例
OID
2.16.840.1.113730.3.1.741
icsExtendedUserPrefs初出
iPlanet Calendar Server 5.1
構文
cis、multi-valued
オブジェクトクラス
定義
カレンダーのユーザー設定についての拡張。各属性値はプロパティと値のペアです。次に示すのは、プロパティとその値です。
表 3-3 拡張済みユーザー設定
プロパティ
値
説明
ceAllCalendarTZIDS
標準のタイムゾーン
カレンダーのタイムゾーン TZID
ceClock
12, 24
12 時間形式または 24 時間形式のどちらを使用するかを定義する
ceColorSet
pref_group1
pref_group2
pref_group3
pref_group4
pref_group75 つの UI カラースキーマのどれを使用するかを定義する
ceDateOrder
M/D/Y
D/M/Y
Y/M/D日付の 3 つの要素 (月 (M)、日 (D)、年 (Y)) が表示される順序を指定する
ceDateSeparator
印刷可能な単一の文字。例 :/ または -
表示される日付の要素 (M、D、Y) を区切るために使用される単一の文字
たとえば、日付は次のように表示できる : 12/22/2002
ceDayHead
023
カレンダー情報の表示の開始時刻 (1 日 24 時間のうちの 1 つで表示)
ceDayTail
023
カレンダー情報の表示の終了時刻 (1 日 24 時間のうちの 1 つで表示)
cdDefaultAgenda
使用されていない
現在実装されていない
cdDefaultAlarmEmail
空白スペースで区切られた電子メールアドレス
イベントアラームの送信先の電子メールアドレス
ceDefaultAlarmStart
P[unit count][unit type]
イベントアラームが送信されるまでの時間。unit count は任意の数値で、unit type は「M (分)」、「H (時)」、または「D (日)」のどれかにする
例 : P10M
ceDefaultTZID
標準のタイムゾーンの 1 つ
タイムゾーンの一覧は、「標準タイムゾーン」を参照
カレンダーにタイムゾーンが割り当てられない場合に使用するタイムゾーン
ceDefaultView
dayview
weekview
monthview
yearview
groupviewログイン時に表示されるビュー
このパラメータが存在しないと、デフォルトとして overview が使用される
(「groupview」は、ユーザーインタフェースの「比較ビュー」)
ceExludeSatSun
論理値 (0、1)
値が 1 の場合は表示されない。デフォルト値は 0
ceFontFace
次の値のうちの 1 つ
1) Times New Roman、Times、serif
2) Courier New、Courier、noon
3) PrimaSans BT、Verdana、sans-serifユーザーインタフェースで使用するフォントの種類を 3 つの中から選択できる
ceFontSizeDelta
pref_font_size_
group_2 (標準)pref_font_size_
group_1 (大)pref_font_size_
group_3 (小)ユーザーインタフェースに 3 つのフォントサイズを定義する。インタフェース内では次のように定義される
normal、larger、smallerceGroupInviteAll
論理値 (0、1)
グループを表示しながら、出席依頼を作成する際、値を 1 に設定すると、グループ内のすべてのカレンダーに対して出席依頼が作成される。デフォルト値は 1
ceInterval
PT0H15M
PT0H30M
PT1H0M
PT2H0M
PT4H0Mカレンダー情報の表示に使用される時間間隔を定義する
時間間隔は次のとおり : 15 分、30 分、1 時間、2 時間、4 時間ceNotifyEmail
RFC 822 の有効な電子メールアドレス
カレンダーがイベントへの出席依頼を受信したときに通知がメールされる電子メースアドレス。
ceNotifyEnable
0, 1
カレンダーがイベントへの出席依頼を受信したときに、電子メールで通知を送信、または送信しない
0 = 通知を送信しない
1 = 通知を送信するceSingleCalendarTZID
有効なタイムゾーン
有効なタイムゾーンの一覧は、「標準タイムゾーン」を参照
このカレンダーに割り当てるタイムゾーンのリスト
このパラメータが指定されないと、デフォルトのタイムゾーンが使用される例 : America/Los_Angeles
ceToolImage
0, 1
ユーザーインタフェースで、ツールバー上にアイコンを表示するかどうかを切り替える
0 = アイコンを表示しない
1 = アイコンを表示する (デフォルト)ceToolText
0, 1
ユーザーインタフェースで、ツールバー上にアイコンテキストを表示するかどうかを切り替える
0 = アイコンにテキストを表示しない
1 = アイコンにテキストを表示する (デフォルト)
例
icsextendeduserprefs:ceClock=12
icsextendeduserprefs:ceColorSet=pref_group_1
icsextendeduserprefs:ceDateOrder=D/M/Y
icsextendeduserprefs:ceDateSeparator=/
icsextendeduserprefs:ceDayHead=10
icsextendeduserprefs:ceDayTail=17
icsextendeduserprefs:ceDefaultAlarmEmail=jdoe@sesta.com
icsextendeduserprefs:ceDefaultAlarmStart=P30H
icsextendeduserprefs:ceDefaultTZID=America/New_York
icsextendeduserprefs:ceDefaultView=groupview
icsextendeduserprefs:ceFontFace=PrimaSans BT,Verdana,sans-serif
icsextendeduserprefs:ceFontSizeDelta=pref_font_size_group_3
icsextendeduserprefs:ceInterval=PT2H0M
icsextendeduserprefs:ceNotifyEmail=jdoe@sesta.com
icsextendeduserprefs:ceNotifyEnable=0
icsextendeduserprefs:ceSingleCalendarTZID=America/Los_Angeles
icsextendeduserprefs:ceToolText=1
icsextendeduserprefs:ceToolImage=1
OID
2.16.840.1.113730.3.1.742
icsFirstDay初出
iPlanet Calendar Server 5.1
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーのカレンダーに表示される週の最初の日
値の範囲 : 17、1 = 日曜日、2 = 月曜日、3= 火曜日、4 = 水曜日、
5 = 木曜日、6 = 金曜日、7 = 土曜日例
icsFirstDay 1
OID
2.16.840.1.113730.3.1.743
icsFreeBusy初出
実装されていません。
構文
ces、single-valued
オブジェクトクラス
定義
予約済、実装されていません。
例
OID
2.16.840.1.113730.3.1.744
icsGeo初出
実装されていません。
構文
cis、single-valued
緯度、経度
オブジェクトクラス
定義
予約済、実装されていません。
ユーザーあるいはリソースの地理的な位置
例
このクラスは RFC 仕様に準拠するためにだけ存在し、使用されていません。
OID
2.16.840.1.113730.3.1.745
icsMandatorySubscribed初出
iPlanet Calendar Server 5.1
構文
ces
オブジェクトクラス
定義
ドメインのユーザーすべてに必須の購読 (subscribe) カレンダー用の有効なカレンダー ID
例
icsMandatorySubscribed:ConfRm1@sesta.com:meetings
OID
2.16.840.1.113730.3.1.746
icsMandatoryView初出
iPlanet Calendar Server 5.1
構文
cis
オブジェクトクラス
定義
ドメインのユーザーすべてに必須のデフォルト表示。次の表示があります。overview (概要)、day (日別)、week (週別)、month (月別)、year (年別)、comparison (比較)
例
icsMandatoryView:overview
OID
2.16.840.1.113730.3.1.747
icsPartition初出
実装されていません。
構文
cis、single-valued、ASCII
オブジェクトクラス
icsCalendarResource, icsCalendarUser
定義
予約済、実装されていません。
カレンダーデータベースを保持するパーティション名。デフォルト値はありません。
例
icsPartitionpartition1
OID
1.3.6.1.4.1.42.2.27.9.1.4
icsPreferredHost初出
実装されていません。
構文
cis、single-valued
オブジェクトクラス
定義
予約済、実装されていません。
カレンダーの優先ホストを指定します。クライアントがフロントエンドホストサーバー名を検索するのに使用します。
例
OID
2.16.840.1.113730.3.1.749
icsQuota初出
実装されていません。
構文
int、single-valued
オブジェクトクラス
定義
予約済、実装されていません。
例
OID
2.16.840.1.113730.3.1.748
icsRecurrenceBound初出
iPlanet Calendar Server 5.1
構文
int、single-valued
オブジェクトクラス
定義
無限に反復するイベントおよび仕事 (todo) 用に作成できるインスタンスの最大数。値は ics.conf 設定の calstore.recurrence.bound から取得します。
例
icsRecurrenceBound: 60
OID
2.16.840.1.113730.3.1.750
icsRecurrenceDate初出
iPlanet Calendar Server 5.1
構文
cis、single-valued
オブジェクトクラス
定義
無限に反復するイベントおよび仕事 (todo) の最大日数を指定する ISO8601 date/time 文字列。
例
icsRecurrenceDate:20300365T115959Z
OID
2.16.840.1.113730.3.1.751
icsRegularExpressions初出
iPlanet Calendar Server 5.1.1
構文
ces、multi-valued、UTF8
オブジェクトクラス
定義
正規表現を格納して、サーバー間で LDAP データベースを分割します。
例
icsRegularExpressions:AF,GL,MT,UZ
AF、GL、MT、UZ は属性のインスタンスで使用可能な値で、4 つのサーバー間にアルファベット順で分割されているデータベースを記述します。
OID
1.3.6.1.4.1.42.2.27.9.1.2
icsSessionTimeout初出
iPlanet Calendar Server 5.1
構文
int、single-valued
オブジェクトクラス
定義
ユーザーセッションがタイムアウトするまでのアイドル状態を保持する秒数。ics.conf 設定の service.http.idletimeout から値を読み込みます。
例
icsSessionTimeout 600
OID
2.16.840.1.113730.3.1.752
icsSet初出
iPlanet Calendar Server 5.1
構文
cis、multi-valued
オブジェクトクラス
icsAnonymousSet、icsCalendarUser,icsDefaultAnonymousSet
定義
カレンダーの 1 グループを定義します。さまざまな作業用にエンドユーザーがこのようなグループを作成します。各グループは 1 つの icsSet 属性で表されます。つまり、ユーザーが作成するグループごとに、1 つの icsSet 属性があります。たとえば、ユーザーが 3 つのグループを定義すると、3 つの icsSet 属性ができます。
この属性の値は 6 つの部分に分かれた文字列で、各部分はドル記号 ($) で区切ります。
次の表に、属性値の 6 つの部分を示します。
表 3-4 属性値の 6 つの部分
部分
必須 / オプション
説明
name
必須
このグループの表示名
calendars
必須
このグループを形成するカレンダーのカレンダー ID (calid) をセミコロンで区切ったリスト
tzmode
必須
3 つの可能な値 : default、inherit、specifyこの値で、このグループのタイムゾーンが何に由来しているかを示します。
default ユーザーのデフォルトタイムゾーンを取得
inherit グループ内の最初のカレンダーのタイムゾーンを取得
specify 次の tz 値からタイムゾーンを取得tz
オプション。ただし、tzmode = specify の場合は除く
グループに対して有効なタイムゾーンタイムゾーンの一覧は、「標準タイムゾーン」を参照。tzmode = specify の場合は必須ですが、それ以外のときはオプション
mergeInDayView
必須
論理値 (TRUE/FALSE)。この値で、このグループを「日別」に表示するか (TRUE)、「比較ビュー」に表示するか (FALSE) を示す
description
オプション
文字列。カレンダーの説明で、オプション
例
この属性の値は 1 行に収まるはずですが、複数行にわたる場合は、1 個のスペースまたはタブで次の行を始めます。
icsSetname=GroupName$calendars=calid1;calid2;calid3$
tzmode=specify$tz=America/Los_Angeles$mergeInDayView=FALSE$
description=Example group of calendars.OID
2.16.840.1.113730.3.1.753
icsSourceHtml初出
iPlanet Calendar Server 5.1
構文
ces、single-valued
オブジェクトクラス
定義
クライアントのすべての HTML ファイルの代替場所。インストールされたクライアントの HTML ファイルを基準にしたディレクトリパス。デフォルト値は、ics.conf 設定の service.http.uidir.path から取得します。
表 3-5 に属性値を示します。
例
icsSourceHtml:calHostname=calhost1
OID
2.16.840.1.113730.3.1.754
icsStatus初出
iPlanet Calendar Server 5.1
構文
cis、single-valued
オブジェクトクラス
定義
この属性を設定して、カレンダーサービスをドメインに割り当てます。この属性は、このドメインのカレンダーサービスのステータスを表します。カレンダーステータスは、表 3-6 に示す値のどれかになります。
この属性が設定されていない場合、icsAllowedServiceAccess の値が確認されます。icsAllowedServiceAccess 属性が存在し、その値が http である場合は、ユーザーのカレンダーサービスは無効になります (ユーザーステータスは inactive)。icsAllowedServiceAccess が別の値の場合、または両方の属性が存在しない場合、デフォルトのユーザーステータスは active です。
カレンダーサービスは、次のステータス属性を次の順序で評価します。inetDomainStatus、icsStatus (icsCalendarDomain 用)、inetResourceStatus または inetUserStatus、および icsStatus (icsCalendarResource あるいは icsCalendarUser 用)。
次の規則を使用します。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。
例
icsStatus:active
OID
2.16.840.1.113730.3.1.755
icsSubscribed初出
iPlanet Calendar Server 5.1
構文
ces、multi-valued
オブジェクトクラス
定義
このユーザーが購読しているカレンダーのリスト。リストには、ユーザーが購読しているカレンダーのほかに、ユーザー自身が所有しているカレンダーも含まれます。
この属性の値はカレンダー ID であり、オプションで、ドル記号 ($) で区切られてカレンダー名が続きます。
例
icsSubscribed:jdoe$MyHomeCalendar
icsSubscribed:jsmithOID
2.16.840.1.113730.3.1.756
icsTimezone初出
iPlanet Calendar Server 5.1
構文
cis
オブジェクトクラス
icsCalendarResource, icsCalendarUser
定義
ユーザー設定で指定しなかった場合に、ユーザーやリソースカレンダーで使用されるデフォルトのタイムゾーン (icsExtendedUserPrefs を参照)。詳細は、「標準タイムゾーン」にあるリストの有効なタイムゾーンを参照してください。値は ics.conf 設定の calstore.default.timezoneID から取得します。
例
icsTimezoneAmerica/Chicago
OID
2.16.840.1.113730.3.1.757
inetCanonicalDomainName初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
Sun ONE LDAP Schema v.1 と Sun ONE LDAP Schema v.2 の互換モード (DC ツリーを使用) の両方で使用されます。この属性は完全指定のドメイン名です。ネイティブモードおよび互換モードの LDAP 構造についての説明は、『Sun JavaTM Enterprise System インストールガイド』を参照してください。
互換モードの場合、DC ツリーの複数の DC ノードが、組織ツリーの同じ組織ノードを参照する場合、この属性を使用して、メール処理でユーザーのメールボックスを開くための標準ドメイン名を指定します。(各組織ノードには 1 つの標準ドメイン名しかありませんが、同じ組織ノードを参照する複数の DC ノードが存在します。)
組織ノードを参照する DC ノードが 1 つしか存在しない場合、この属性は必要ありません。この属性を指定しない場合、DC ノードエントリは標準ドメイン名になります。
この属性が指定されていないで、同じ組織ノードを参照する DC ノードが複数存在する場合、メール処理でユーザーのメールボックスを開く際に、不正なドメイン名が使用される可能性があります。
同じ組織ノードを指す複数のドメインノードを使用する場合、各ドメインノードに異なる属性を設定できます。異なる属性を設定することで、異なるルーティングが設定されます。2 つのドメインに同じ属性 (同じルーティング) を設定する場合は、重複するノードに aliasedObjectName を使用してください。
Sun ONE LDAP Schema v.2 ネイティブモード LDAP データモデルで、この属性を使用することはできません。
例
sesta.com という企業に、同じ組織ノード o=sesta を参照する 2 つの DC ノード dc=sesta と dc=sesta2 が存在する場合、この属性を使用して 1 つのノードを次のように指定します。
inetCanonicalDomainNamesesta.com
次に
dn:dc=sesta,dc=com,o=internet
inetDomainBaseDN:o=sesta.com
inetCanonicalDomainNamesesta.comdn:dc=sesta2,dc=com,o=internet
inetDomainBaseDN:o=sesta.comOID
2.16.840.1.113730.3.1.701
inetCOS初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
(組織ツリードメイン) ユーザーエントリ内の属性に値を与える CoS (サービスクラス) テンプレートの名前を指定します。CoS テンプレートの RDN が、この属性の値です。テンプレートから与えられる属性値とそれらをオーバライドするルールは、CoS 定義内に指定されています。CoS 定義は、オブジェクトクラスの cosDefinition を使用して作成されます。CoS 定義のエントリ内にある cosSpecifier 属性の値が inetCoS に設定されます。そのドメインのサブツリー内にある ou=CoS コンテナに、CoS 定義とテンプレートを作成します。詳細は、『iPlanet Messaging Server 5.2 Provisioning Guide』を参照してください。
例
inetCoS:HallofFame
OID
2.16.840.1.113730.3.1.706
inetDomainBaseDN初出
iPlanet Messaging Server 5.0
構文
dn、single-valued
オブジェクトクラス
定義
互換モードでは、DC ツリーのドメインノードを修飾します。Sun ONE LDAP Schema v.2 のネイティブモードでは使用されません。
2 つのドメイン (エイリアスおよび参照ドメイン) に異なる属性値を設定して、ドメイン間で異なるルーティングを実行できます。ルーティングを同じにする場合は、両方のドメインの属性値を同じにします。
すべてのユーザーおよびグループのエントリが格納される組織サブツリーの DN。この属性は、有効な組織サブツリーの DN を指します。互換モードで RFC 2247 検索を使用する Messaging Server のコンポーネントは、ホスト組織に対応するユーザーエントリおよびグループエントリを検索するために、この DN を解決する必要があります。
例
inetDomainBaseDN:o=sesta.com,o=siroe-isp.com
OID
2.16.840.1.113730.3.1.690
inetDomainCertMap初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
予約済
例
TBD
OID
2.16.840.1.113730.3.1.700
inetDomainSearchFilter初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ネイティブモード検索を実行する際、検索テンプレートで使用する LDAP 検索フィルタ。互換モードの RFC 2247 アルゴリズム検索を実行する際、この属性は必須ですが、値は無視されます。
ドメイン内のログイン名を LDAP エントリにマップするために、認証中に使用されます。
フィルタの作成に次の変数を使用することができます。
この属性を指定しない場合は、次の値と等価になります。
(&(objectclass=inetOrgPerson)(uid=%U))
uid=john_siroe.com などの複合 uid でユーザーが規定されるネームスペースでは、uid=%U_%V の検索フィルタが使用されます。ここで、john はユーザー ID、siroe.com はドメインです。これによって、ログイン文字列の john@siroe.com (@ はサービスのログイン区切り文字) が、siroe.com のエントリのネームスペースのサービスによって、検索要求にマップされます。ここでは、uid=john_siroe.com となります。
この属性を使用する別の例として、社員を社員ID に基づいてログインするサイトが挙げられます。ユーザーエントリ内の empID 属性に社員 ID が格納されていると想定すると、検索フィルタは次のようになります。
(&(objectclass=inetOrgPerson)(empID=%U)).
この属性によって、inetDomainBaseDN サブツリー内で完全に一致した有効ユーザーが返されます。この属性が設定されていない場合は、uid 属性が inetDomainBaseDN サブツリー内で一意である必要があります。
例
inetDomainSearchFilter:uid=%U
OID
2.16.840.1.113730.3.1.699
inetDomainStatus初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
エントリーポイントとして DC ツリーを使用するアプリケーション (RFC 2247 に準拠した互換モードの LDAP データモデル) は、アプリケーション固有のステータス属性を選択できますが、関連する物理的なノード (組織ツリー) ではこの属性を使用する必要があります。つまり、互換モードではこの属性が DC ツリーと組織ツリーの両方に存在し、2 つの属性値が異なる場合は、組織ツリー上の属性が優先されます。
すべてのサービスに対応するドメインのグローバルステータスを指定します。この属性の目的は、管理者が、ドメインとドメインで有効なすべてのサービスに、ドメイン内のすべてのユーザーが一時的にアクセスできないようにして、後に再びアクセスできるようにすることです。または、アクセスを永久に削除することです。
この属性は、3 つの値のうちの 1 つをとります。サポートされる値は、次のとおりです。
値がないと、ステータスは active とみなされます。不正な値はすべて、inactive として扱われます。
次の 4 つの属性は示す順にメールサービスで評価されます。inetDomainStatus、mailDomainStatus、inetUserStatus、およびmailUserStatus。次の規則を使用します。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。
同様に、この属性はステータスを評価するときのカレンダーサービスにも使用されます。使用されるステータス属性は次のとおりです。inetDomainStatus、(icsCalendarDomain の) icsStatus、inetResourceStatus または inetUserStatus のどちらか、および (icsCalendarResource または icsCalendarUser の) icsStatus
さらに、この属性が互換モードで DC ツリーと組織ツリーの両方を修飾した場合、両方の属性は一致するはずです。管理者は、この 2 つの属性が同期を保持するように管理する必要があります。2 つの属性が同じ値を保持していない場合、Messaging Server は組織ツリーの値を使用します。ほかの古いアプリケーションでは、DC ツリーの属性だけが使用される場合があります。このため、予測できない結果が発生する可能性があります。
ネイティブモードおよび互換モードの LDAP スキーマについての詳細は、『Sun JavaTM Enterprise System インストールガイド』を参照してください。
例
inetDomainStatus:active
OID
2.16.840.1.113730.3.1.691
inetMailGroupStatus初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
メールグループの現在のステータス。
次の表に、使用可能なステータス値とその説明を示します。
active
メッセージはメーリングリストのメンバーに配信される
inactive
メーリングリストのメンバーへのメール配信は失敗する
deleted
メーリングリストはディレクトリから削除される。このグループにメッセージが送信されると、永続的に失敗が返される
値がないと、ステータスは active とみなされます。不正な値はすべて、inactive として扱われます。
相互に作用する 4 つの属性が存在します。inetDomainStatus、mailDomainStatus、inetGroupStatus、およびinetMailGroupStatus。これらの属性は、ここに挙げた順に評価されます。最初に active であるステータスが、ほかのステータスの設定に優先します。
MTA オプション LDAP_GROUP_STATUS を使用して、グループステータスの異なる属性を指定します。
例
inetMailGroupStatus:active
OID
2.16.840.1.113730.3.1.786
inetResourceStatus初出
iPlanet Calendar Server 5.1
構文
cis、single-valued
オブジェクトクラス
定義
リソースのグローバルステータス。リソースの現在のステータスを保持します。ステータスは次のとおりです。active、inactive、あるいは deleted (すべてのサービスに対して)。Sun ONE Identity Server はこの属性を使用して、リソースを管理します。ステータスの変更は、commcli インターフェイスを使用してリソースのステータスで行います。グループの LDAP エントリを直接変更することもできます。
次の表に、属性値とその説明を示します。
ステータスを決定するために評価されるいくつかのステータス属性があります。次の順に評価されます。inetDomainStatus, icsStatus (icsCalendarDomain 用)、inetResourceStatus, icsStatus (icsCalendarResource 用)。これらの属性は、ここに挙げた順に評価されます。最初に active であるステータスが、ほかのステータスの設定に優先します。
例
inetResourceStatus:active
OID
2.16.840.1.113730.3.1.758
inetSubscriberAccountId初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
課金の目的で使用される一意のアカウント ID
例
inetSubscriberAccountId:A3560B0
OID
2.16.840.1.113730.3.1.694
inetSubscriberChallenge初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
サブスクライバを識別するために使用されるチャレンジフレーズを格納するための属性。inetSubscriberResponse とともに使用されます。
例
inetSubscriberChallenge=Mother's Maiden Name
OID
2.16.840.1.113730.3.1.695
inetSubscriberResponse初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
チャレンジフレーズへの応答を格納するための属性。
例
inetSubscriberResponse=Mamasita
OID
2.16.840.1.113730.3.1.696
inetUserHttpURL初出
iPlanet Messaging Server 5.0 (Sun ONE Messaging Server 6.0 では削除予定)
構文
cis、single-valued
オブジェクトクラス
定義
この属性は、Sun ONE Messaging Server 6.0 で開始されたユーザークラス inetUser で使用することはできますが、Sun ONE スキーマの以降のバージョンに含まれるオブジェクトクラスからは、削除される見込みです。
Web コンテンツを公開するための、ユーザーのプライマリ URL。これは情報を示す属性であり、電話帳タイプのアプリケーションで使用することができます。操作に影響を与えるものではありません。
例
inetUserHttpURL: http://www.siroe.com/theotis
OID
2.16.840.1.113730.3.1.693
inetUserStatus初出
iPlanet Messaging Server 5.0, Sun ONE Calendar Server 5.1.1
構文
cis、single-valued
オブジェクトクラス
定義
グローバルサーバーアクセスに関するユーザーアカウントのステータスを指定します。この属性を使用して、管理者は、サーバーへのアクセスの一時的な中断および再開、あるいはアクセス権の削除をユーザーアカウントに対して設定できます。
次の表に属性値を示します。
値がないと、ステータスは active とみなされます。不正な値はすべて、inactive として扱われます。
次の 4 つの属性は示す順にメールサービスで評価されます。inetDomainStatus、mailDomainStatus、inetUserStatus、およびmailUserStatus。次の規則を使用します。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。
カレンダーサービスでは、次の属性が評価されます。inetDomainStatus、icsStatus (icsCalendarDomain 用)、inetUserStatus、icsStatus (icsCalendarUser 用)。
この属性を inetUser オブジェクトクラスでアクティブでない (無効) と定義したスタティックグループに適応すると、グループにのみ適用されて、グループ内のユーザーには適用されません。
グループのユーザーを無効にするには、ユーザーにロールを割り当ててダイナミックグループを作成し、そのロールを無効にします。そうすると、ロールを割り当てられたすべてのユーザーを無効にできます。ロールに関する詳細は、 『Sun ONE Directory Server 管理者ガイド』を参照してください。
MTA オプション LDAP_USER_STATUS を使用して、ユーザーステータスの異なる属性を指定します。
例
inetUserStatus=inactive
OID
2.16.840.1.113730.3.1.692
初出
iPlanet Messaging Server 5.0
構文
cis、single-valued (RFC 822 アドレス)
オブジェクトクラス
inetLocalMailRecipient, icsCalendarResource, icsCalendarUser
定義
ユーザーのプライマリ電子メールアドレスを識別します (ホワイトページ検索アプリケーションによって取り出され、表示される電子メールアドレス)。
この属性とmailAlternateAddress は、リバース検索で使用されるデフォルトの属性です。
例
mail=jdoe@sesta.com
OID
0.9.2342.19200300.100.1.3
mailAccessProxyPreAuth初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
このドメイン内のユーザーを事前に認証しなければならない場合、この属性によってMMP に伝えます。指定できる値は、yes または no です。
例
mailAccessProxyPreAuth=yes
OID
2.16.840.1.113730.3.1.769
mailAccessProxyReplay初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
この属性によって、バックエンドのメールサーバーを使用してログインシーケンスに応答する際の、ログイン文字列の再構成方法を Messaging Multiplexor (MMP) に伝えます。この属性を指定しないと、メッセージアクセスプロキシは、クライアントに使用されるログイン名、クライアントのドメイン、およびこのサービスで使用されるログイン区切り文字に基づいて、応答文字列を構成します。メッセージアクセスプロキシが Messaging and Collaboration 以外の異なるバックエンドサーバーを使用している場合は、このデフォルトの動作を、mailAccessProxyReplay 属性でオーバライドします。
構文はログイン文字列の構文であり、次のように置き換えられます。
例
- クライアントが hugo としてログインし、使用されるサーバーの IP アドレスに関連するドメインが yoyo.com で、しかも mailAccessProxyReplay=%U@%V が指定されている場合、応答されるログイン文字列は hugo@yoyo.com になります。
- クライアントが hugo としてログインし、使用されるサーバーの IP アドレスに関連するドメインが yoyo.com で、さらに mailAccessProxyReplay=%[surname]@%V が指定されている場合、応答されるログイン文字列は、クライアントの surname 属性の値になります。
- クライアントが hugo+yoyo.com としてログインし、使用されるサービス用のログイン区切り文字が + で、さらに mailAccessProxyReplay=%U@%V が指定されている場合、応答されるログイン文字列は hugo@yoyo.com になります。
- クライアントが hugo としてログインし、使用されるサーバーの IP アドレスに関連するドメインが yoyo.com のときに mailAccessProxyReplay が指定されておらず、しかも使用されるサービス用のログイン区切り文字が + の場合、応答されるログイン文字列は hugo+yoyo.com になります。
OID
2.16.840.1.113730.3.1.763
mailAdminRole初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
グループのメンバーに割り当てられる管理ロールを指定します。この属性のための唯一の有効な値は、storeAdmin です。この属性 (inetMailAdministrator) を含むオブジェクトクラスは、グループのメンバーにメールサーバー部分への管理権限を与えるために、グループエントリでオーバーレイされます。現在のところ、グループのメンバーが継承する唯一の権限は、ドメイン内のどのユーザーに対してもプロキシ認証を実行する権限です。このような権限は、グループが定義されているドメインと同じドメイン内のユーザーに拡張されます。このような権限を許可するには、mailAdminRole 属性に storeAdmin 値を設定する必要があります。
例
mailAdminRole:storeAdmin
OID
2.16.840.1.113730.3.1.780
mailAllowedServiceAccess初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
アクセスフィルタ (ルール) を格納します。ルールを指定しない場合、ユーザーはすべてのクライアントからすべてのサービスにアクセスできます。ルールはドルマーク ($) で区切ります。ルールは次の方法で評価されます。
アクセスフィルタに関する詳細、および管理コンソールや config ユーティリティを使用してアクセスを制御する方法については、『Sun ONE Messaging Server 管理者ガイド」』の「POP、IMAP、および HTTP サービスへのクライアントアクセスの設定」を参照してください。
ルール構文
"+" または "-"service_list":"client_list
+ (許可フィルタ) は、サービスリストのサービスがクライアントリストに提供されることを意味します。
- (拒否フィルタ) は、サービスがクライアントリストに拒否されることを意味します。
daemon_list は、アクセスが許可または拒否されるサービスを、カンマで区切って列挙します。
有効なサービス名 : imap、imaps、pop、pops、smtp、smtps、 および httpMMP は、imap、imaps、pop、pops、および smtp をサポートしています。バックエンドは、imap、pop、smtp、およびhttp をサポートしています。
client_list は、アクセスが許可または拒否されるクライアント (ドメイン) を、カンマで区切って列挙します。
ワイルドカードはクライアントリスト (ドメイン) と置き換えられます。次の表に、有効なワイルドカードとその説明を示します。
サービスリストでは、次のワイルドカードを使用できます。*, ALL.
EXCEPT 演算子
アクセス制御システムでは、1 つの演算子 EXCEPT がサポートされています。EXCEPT を使用して、ルールサービスリストとクライアントリストに存在するパターンの例外を作成します。EXCEPT 句は入れ子にすることができます。ルールに複数の EXCEPT 句が存在する場合、右から左方向に評価されます。
EXCEPT 形式は次のとおりです。
list1 EXCEPT list2
list1 はカンマで区切ったサービスのリスト、list2 はカンマで区切ったクライアントのリストです。
例
この例では、複数のサービスを使用する単一のルールとクライアントリストで使用する単一のワイルドカードを示しています。
mailAllowedServiceAccess:+imap,pop,http:*
この例では、複数のルールを単純化して各ルールが単一のサーバー名を所有し、クライアントリスト用のワイルドカードを使用するようにします。これは、LDIF ファイルでアクセス制御を指定するためのもっとも一般的なメソッドです。
mailAllowedServiceAccess:+imap:ALL$+pop:ALL$+http:ALL
この例では、あるユーザーに対してすべてのサービスを許可しない方法を示します。
mailAllowedServiceAccess:-imap:*$-pop:*$-http:*
この例では、EXCEPT 演算子を使用するルールを示します。
mailAllowedServiceAccess:-ALL:ALL EXCEPT server1.sesta.com
この例では、 server1.sesta.com. というホストマシーン以外のマシーンで、すべてのユーザーに対して、すべてのサーバーへのアクセスを拒否するように設定しました。
OID
2.16.840.1.113730.3.1.777
mailAlternateAddress初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
inetLocalMailRecipient, pabPerson
定義
この受取人のその他の RFC 822 電子メールアドレス。この電子メールアドレスが「from」ヘッダーに入力されたメールを MTA が受信した場合、MTA はヘッダーを mail 属性値に書き換えて、メールを該当する受信箱にルートします。mailEquivalentAddress 属性もメールをルートしますが、ヘッダーの書き換えは行いません。
キャッチオールアドレスとしてユーザーおよびグループを示すため、アドレスのローカル部分を省略することができます。キャッチオールドメインアドレスは、MTA が指定されたドメインで正確に一致するユーザーアドレスを検出できない場合に、そのドメインに対してメールを受信するアドレスです。
mail と同様に、この属性は、リバース検索で使用されるデフォルトの属性です。
例
mailAlternateAddress:jdoe@sesta.com
mailAlternateAddress:@sesta.com (catchall domain address)
OID
2.16.840.1.113730.3.1.13
mailAntiUBEService初出
iPlanet Messaging Server 5.2
構文
cis、multi-valued
オブジェクトクラス
定義
この属性やほかのオプトイン属性で指定される文字列の値が集められて、使用中のフィルタリングエージェント (Brightmail など) に渡されます。
Brightmail のスパムおよびウィルスチェックでは、これらの文字列の解釈が Brightmail 設定ファイルで指定されます。Brightmail では処理にこの属性からの情報を使用します。
Brightmail の値は次の 2 つがあります。
別のフィルタリングエージェントである SpamAssasin では、この属性の実際の値を使用しないため、任意の値を設定できます。
ほかの属性は LDAP_OPTIN の option.dat 設定で指定できますが、この方法は推奨されません。(Brightmail の詳細については、『Sun ONE Messaging Server 6.0 管理者ガイド』を参照してください。)
この属性を使用して、ユーザーごとのオプトイン値を指定する場合は、option.dat ファイルで次のように設定してください。
LDAP_OPTIN=mailAntiUBEService
この属性を使用して、ドメインレベルのオプトイン値を指定する場合は、option.dat ファイルで次のように設定してください。
LDAP_DOMAIN_ATTR_OPTIN=mailAntiUBEService
例
mailAntiUBEService: virus
mailAntiUBEService:spam
OID
mailAutoReplyMode初出
iPlanet Messaging Server 5.0 (返信モード)、 iPlanet Messaging Server 5.2 patch 1 (エコーモード)
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーのメールアカウントに自動返信モードを指定します。自動返信がアクティブなメール配信オプションの場合、これは自動返信属性のうちの 1 つです。次の 2 つのモードがあります。
例
mailAutoReplyMode:reply
OID
2.16.840.1.113730.3.1.14
mailAutoReplySubject初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
自動返信の件名のテキスト。$SUBJECT を使用して、元のメッセージの件名を応答に挿入することができます。
例
mailAutoreplySubject:I am on vacation
OID
2.16.840.1.113730.3.1.772
mailAutoReplyText初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
受信者と同じドメインにはいない送信者に対して送付される、自動返信用のテキスト。指定しないと、外部ユーザーは自動応答を受信しません。
例
mailAutoreplyText:Please contact me later.
OID
2.16.840.1.113730.3.1.15
mailAutoReplyTextInternal初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
受信者と同じドメインにいる送信者に対して送付される、自動返信用のテキスト。これを指定しない場合、ドメイン内の送信者も、外部のユーザーと同様の返信メッセージを受け取ることになります。
例
mailAutoreplyTextInternal:Please contact me later.
OID
2.16.840.1.113730.3.1.773
mailAutoReplyTimeOut初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
任意の差出人への自動返信の応答に成功するまでの時間間隔 (時間単位)。次の場合のみ使用されます。mailAutoReplyMode:replymailAutoReplyMode: echo に値 0 が設定されている場合、メッセージ受信のたびに応答が送り返されます。自動返信の応答は、元のメッセージの「to」または「cc:」に受取人が存在する場合のみ送信されます。
例
mailAutoreplyTimeout: 48
OID
2.16.840.1.113730.3.1.771
mailClientAttachmentQuota初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
このドメイン内で Messenger Express ユーザーが 1 メッセージにつき送信できる添付ファイルの数を示す、正の整数値。値が -1 の場合、添付ファイルの数に制限はありません。
例
mailClientAttachmentQuota: 12
OID
2.16.840.1.113730.3.1.768
mailConversionTag初出
iPlanet Messaging Server 5.2
構文
cis、multi-valued (ASCII 文字列)
オブジェクトクラス
inetMailGroup, inetMailUser
定義
このユーザーまたはグループへのメッセージに添付される変換タグ。タグ特有の変換動作は、MTA 構成内で指定されます。
この属性値を無効化するのに使用する MTA オプションは、LDAP_CONVERSION_TAG です。
例
OID
mailDeferProcessing初出
iPlanet Messaging Server 5.2
構文
cis、single-valued (ASCII 文字列)
オブジェクトクラス
inetMailGroup, inetMailUser
定義
現在のユーザーエントリまたはグループエントリのアドレス拡張がただちに実行されるか (値は「No」)、またはあとで実行するか (値は「Yes」) を制御します。
値が「Yes」で、しかも現在のソースチャネルが再処理チャネルでない場合は、延期されます。延期は、ユーザーまたはグループのアドレスを再処理チャネルに指定することで実行されます。つまり、エイリアスの拡張は中止され、元のアドレス (user@domain) が再処理チャネルのキューに入れられます。
この属性が設定されていない場合、送信オプション処理に関連のある延期処理フラグの設定を確認します。フラグが設定されている場合、処理は延期されます。
フラグが設定されていない場合、属性が「No」に設定されている場合と同じように、ユーザーのデフォルトで直ちに処理が実行されます。
メーリングリストなどのグループのデフォルトは、1 (yes) です。DEFER_GROUP_PROCESSING MTA オプションによって制御されています。
重複メッセージの最善の対処方法
メッセージの重複コピーが発生する場合があります。たとえば、addresseeA および addresseeA を含む groupA の両方にメールを送信し、DEFER_GROUP_PROCESSING=1 でこの属性に No が設定されている場合、メッセージは重複します。つまり、addresseeA はメッセージのコピーを 2 つ受け取ります。1 つは直接送信され、もう 1 つは再処理チャネルで遅延拡張ホップを取得して groupA を展開します。
遅延グループの展開を無効にすると重複をなくすことができますが、大きいグループを複数所有している場合は、適切ではありません。expandlimit 1 を使用すると、一時的にグループではない複数の受信者がいるメッセージで不必要なオーバーヘッドが発生します。
この状況を最小限にとどめるには、次の 2 つの解決方法が最善です。
例
メールユーザーに対するデフォルト :
mailDeferProcessing:No
メーリングリストに対するデフォルト :
mailDeferProcessing:Yes
OID
TBD
mailDeliveryFileURL初出
iPlanet Messaging Server 5.0
構文
ces、single-valued
オブジェクトクラス
定義
メーリングリストに送信されたすべてのメッセージに付加される、ファイルの完全指定ローカルパス。次の値と一緒に使用します。mailDeliveryOption:file
この属性値を無効化するのに使用する MTA オプションは、LDAP_PROGRAM_FILE です。
例
mailDeliveryFileURL:/home/dreamteam/mail_archive
OID
2.16.840.1.113730.3.1.787
mailDeliveryOption初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
メール受取人の配信オプションを指定します。インバウンドメッセージの複数の配信経路をサポートするために、ユーザーエントリ、およびグループエントリに、複数の値を指定できます。この属性が使用されるオブジェクトクラスが inetMailGroup か、または inetMailUser かによって、値の適用が異なります。
mailUserStatus 属性は、この属性より先に処理されるので注意してください。mailUserStatus にhold を設定した場合、内部フラグが設定されます。そのため、mailDeliveryOption が処理されると、mailUserStatus hold は mailDeliveryOption で指定した配信オプションを書き換えます。
ユーザーに対する配信アドレスは、有効な配信オプションの値で生成されます。
有効な値は、次のとおりです。
ユーザー (inetMailUser) に対してのみ有効
- autoreply - autoreply の指定は、ユーザーにより定まります。受信者が「To:」あるいは「Cc:」ヘッダーフィールドに表示されているメッセージは自動返信チャネルに送信されます。自動返信チャネルでは、自動返信メッセージを作成し、そのメッセージを送信者に配信します。
- hold - 受取人は、メッセージの受信を一時的に中止します。mailUserStatus, hold とは異なり、この属性は POP、IMAP、および WebMail のアクセスを許可するので、注意してください。この属性にhold を設定した場合、受信者のメールボックスへの配信が一時的に中止されるだけであり、アクセスは許可されたままです。
- mailbox - ユーザーの IMA/POP ストアにメッセージを配信します。
- native または unix - ユーザーの /var/mail ストアである INBOX にメッセージを配信します。このストアは、バークレー版のメールボックスのフォーマットになっています。Messaging Server は /var/mail のアクセスをサポートしていません。ユーザーが /var/mail ストアのメールにアクセスするには、UNIX ツールを使う必要があります。
グループ (inetMailGroup) に対してのみ有効
ユーザーとグループに対して有効
次の値は、ユーザーとグループの両方で同じように使用されます。
msg_svr_base/config/option.dat ファイルに存在する MTA オプション DELIVERY_OPTIONS は、以前に表示された各値の処理方法を定義します。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DELIVERY_OPTION です。
例
mailDeliveryOption:mailbox
OID
2.16.840.1.113730.3.1.16
mailDomainAllowedServiceAccess初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
アクセスフィルタ (ルール) を格納します。ルールを指定しないと、ドメインのすべてのクライアントからすべてのサービスにアクセスできます。ルールはドルマーク ($) で区切ります。ルールは次の方法で評価されます。
アクセスフィルタに関する詳細、および管理コンソールや config ユーティリティを使用してアクセスを制御する方法については、『Sun ONE Messaging Server 管理者ガイド』の「POP、IMAP、および HTTP サービスへのクライアントアクセスの設定」を参照してください。
ルール構文
"+" または "-" <service_list>":"<client_list>
+(許可フィルタ) は、サービスリストのサービスがクライアントリストに提供されることを意味します。
- (拒否フィルタ) は、サービスがクライアントリストに拒否されることを意味します。
daemon_list は、アクセスが許可または拒否されるサービスを、カンマで区切って列挙します。
有効なサービス名 : imap、imaps、pop、pops、smtp、smtps、 および httpMMP は、imap、imaps、pop、pops、および smtp をサポートしています。バックエンドは、imap、pop、smtp、およびhttp をサポートしています。
client_list は、アクセスが許可または拒否されるクライアント (ドメイン) を、カンマで区切って列挙します。
ワイルドカードはクライアントリスト (ドメイン) と置き換えられます。次の表に、許可されているワイルドカードとその説明を示します。
サービスリストでは、次のワイルドカードを使用できます。*, ALL.
EXCEPT 演算子
アクセス制御システムでは、1 つの演算子 EXCEPT がサポートされています。EXCEPT を使用して、ルールサービスリストとクライアントリストに存在するパターンの例外を作成します。EXCEPT 句は入れ子にすることができます。ルールに複数の EXCEPT 句が存在する場合、右から左方向に評価されます。
EXCEPT 形式は次のとおりです。
list 1 EXCEPT list 2
リストは、カンマで区切られたサービスあるいはクライアントのリストです。
例
この例では、複数のサービスを使用する単一のルールとクライアントリストで使用する単一のワイルドカードを示しています。
mailDomainAllowedServiceAccess:+imap,pop,http:*
この例では、複数のルールを単純化して各ルールが単一のサーバー名を所有し、クライアントリスト用のワイルドカードを使用するようにします。
mailDomainAllowedServiceAccess: +imap:ALL$+pop:ALL$+http:ALL
この例では、Messaging Server LDIF フィールドでもっとも一般的に使用されているルールを示します。
この例では、EXCEPT 演算子を使用するルールを示します。
mailDomainAllowedServiceAccess:-ALL:ALL EXCEPT server1.sesta.com
この例では、 server1.sesta.com. というホストマシーン以外のマシーンで、すべてのユーザーに対して、すべてのサーバーへのアクセスを拒否するように設定しました。
OID
2.16.840.1.113730.3.1.764
mailDomainCatchallAddress初出
iPlanet Messaging Server 5.2
構文
cis、single-valued (RFC 822 メールボックス)
オブジェクトクラス
定義
ドメイン内のすべてのアドレスのうち、どのユーザーやグループにも一致しないものの代わりに使用されるアドレスを指定します。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_CATCHALL_ADDRESS です。
例
OID
TBD
mailDomainConversionTag初出
iPlanet Messaging Server 5.2
構文
cis、multi-valued (ASCII 文字列)
オブジェクトクラス
定義
ドメイン内の任意のユーザーへのメッセージに添付する 1 つ以上の変換タグ。タグ特有の変換動作は、MTA 構成内で指定されます。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_CONVERSION_TAG です。
例
OID
TBD
mailDomainDiskQuota初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
内部モニタにのみ使用されます。このドメイン内のすべてのユーザーに許可されているメッセージの割当量 (バイト単位)。これは割り当て容量レポートツールで使用されるもので、ドメイン全体の割り当ての制限を強制するものではありません。
例
mailDomainDiskQuota: 50000000000
OID
2.16.840.1.113730.3.1.766
mailDomainMsgMaxBlocks初出
iPlanet Messaging Server 5.2
構文
int、single-valued
オブジェクトクラス
mailDomain
定義
このドメイン内のアドレスに送信されるすべてのメッセージのサイズを、MTA ブロック単位で制限します。この制限は、このドメインからユーザーが送信するメッセージには適用されません。
この属性の値は、mailMsgMaxBlocks の値が設定されている場合はその値でオーバライドされます。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_BLOCKLIMIT です。
例
OID
TBD
mailDomainMsgQuota初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
このドメイン内のすべてのユーザーに許可されるメッセージの割り当て数。これは割り当て容量レポートツールで使用されるもので、ドメイン全体の割り当ての制限を強制するものではありません。
例
mailDomainMsgQuota: 2000000
OID
2.16.840.1.113730.3.1.767
mailDomainReportAddress初出
iPlanet Messaging Server 5.2
構文
cis、single-valued (RFC 822 メールボックス)
オブジェクトクラス
定義
この値は、ドメイン内の受信者のアドレスに関する問題を報告する DSN の「From: アドレス」として使用されます。また、ローカル以外のアドレスに関連するエラーについて、ドメイン内のユーザーに問題を報告するときにも使用されます。
この属性が設定されない場合、報告アドレスは、デフォルトの「postmaster@domain」になります。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_REPORT_ADDRESS です。
例
OID
TBD
mailDomainSieveRuleSource初出
iPlanet Messaging Server 5.2
構文
cis、single-valued (RFC 3028 sieve フィルタ)
オブジェクトクラス
定義
SIEVE フィルタは、iPlanet Delegated Administrator でサポートされていません。
ドメイン内のすべてのユーザーの SIEVE フィルタ。この属性の値には、2 つの可能な形式があります。1 つは、RFC 3028 に準拠した完全な sieve スクリプトを含んだ単一の値であり、もう 1 つは、それぞれが sieve スクリプトの断片を含んだ (RFC 3028 に準拠していない) 複数の値です。
スクリプトの形式は、次のとおりです。
require ["fileinto", "reject"];
# $Rule Info:Order=(1-infinity, or 0 for disabled) Template=(template-name) Name=(rule name)
if header :is "Sender" "owner-ietf-mta-filters@imc.org"
{ fileinto "filter"; # move to "filter" folder }
if header :is "Subject" "SPAM!"
{ delete }複数の値 (multi-valued) がある形式
ユーザーごとに複数の SIEVE スクリプトを LDAP に格納することができます。ドメインのすべてのルールを含む 1 つの大きなスクリプトでなく、いくつかのより小さなルールスクリプトをユーザーインタフェースが取り扱えるようにするために、この属性は複数の値 (つまり、複数のルール) をとります 。サーバーは、mailSieveRuleSource 内のすべてのルールを調べます。
順序の指定と情報の編集が可能なユーザーインタフェースを提供するために、各ルール内にオプションの SIEVE コメント行があります。この行の形式は、次のとおりです。
# $Rule Info:Order=(1-infinity, or 0 for disabled)
Rule Info 行のあるすべてのルールは、メッセージングサーバーに最初に処理されます。Order=0 の場合、SIEVE の評価にこのルールは使用されません。それ以外の場合、ルールは提供された順に処理されます (1 が最優先)。Rule Info の拡張機能を使用して入力されなかった可能性のある SIEVE ルールを適用するために、対応する順序の値ですべてのルールが処理された後に、検出されたほかのルールが LDAP から受け取った順にサーバーによって実行されます。
MTA 優先指定オプション
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_FILTER です。
例
次の例は正しい形式ですが、Messaging Server は、破棄を無視してテキストを拒否します。さらに拒否または破棄の応答メッセージは送信されません。
mailSieveRuleSource:
require ["fileinto", "reject", "redirect", "discard"]
if header :contains "Subject" "New Rules Suggestion
{redirect "rules@sesta.com" # Forward message }
if header :contains "Sender" "porn.com"
{discard text:
Your message has been rejected.Please remove this address from your mailing list.# メッセージを拒否し、返信メッセージを送信します}
if size :over 1M
{ reject text:
Please do not send me large attachments.
Put your file on a server and send the URL.
Thank you.# メッセージを破棄し、返信メッセージを送信します}
if header :contains "Sender" "domainadminstrator@sesta.com
{ fileinto complaints.refs # File message}OID
TBD
mailDomainStatus初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
メールドメインの現在のステータス。次のいずれかの値になります。active、inactive、deleted、hold。この属性は、メールサービスドメインのステータスです。値がないと、ステータスは active として扱われます。不正な値はすべて、inactive として扱われます。
次の表に、ステータスの値を示します。
次の 4 つの属性は示す順にメールサービスで評価されます。inetDomainStatus、mailDomainStatus、inetUserStatus、およびmailUserStatus。次の規則を使用します。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。
この属性値を無効化するのに使用する MTA オプションは、LDAP_DOMAIN_ATTR_STATUS です。
例
mailDomainStatus:active
OID
2.16.840.1.113730.3.1.770
mailDomainWelcomeMessage初出
Sun ONE Messaging Server 6.0
構文
cis、single-valued
オブジェクトクラス
定義
このドメインに追加された新規ユーザーに送信されるようこそメッセージ。「$$」は、キャリッジリターンを示す記号です。この属性の BNF 構文は、次のとおりです。
value::<subjectline>��票<opt_headers>]��$��lt;body>
subjectline::百ubject:票<TEXT>]
opt_headers::<header_line>��票<opt_headers>]
header_line::<header_name>����lt;TEXT>
header_name::<TEXT>
body::[<lines>]
lines::<line>��票<lines>]
line::<TEXT>例
mailDomainWelcomeMessage:Subject:Welcome!!$X-Endorsement:We're good.$$Welcome to the mail system.
OID
2.16.840.1.113730.3.1.765
mailEquivalentAddress初出
iPlanet Messaging Server 5.2
構文
cis、multi-valued (RFC 822 アドレス仕様)
オブジェクトクラス
inetMailGroup, inetMailUser
定義
mailAlternateAddress と同様にメールをルートしますが、ヘッダーは書き換えません。
mailEquivalentAddress は、システムがメッセージの送信先を決定する時に検索されますが、REVERSE_URL でアドレスのリバースを実行する時に検索される属性ではありません。
この属性は、imsimta dirsync オプション (削除予定) ではなく、直接 LDAP モードにだけ作用します。
例
mailEquivalentAddress:jdoe@sesta.com
mailEquvalentAddress:@sesta.com (catchall domain address)
OID
TBD
mailFolderName初出
Sun ONE Messaging Server 6.0
構文
cis、single-valued
オブジェクトクラス
定義
パブリックフォルダ名を指定します。
例
mailFolderName:Announcements
OID
mailForwardingAddress初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
この属性には、インバウンドメッセージのための 1 つ以上の転送アドレスが格納されます。アドレスは、RFC822 のフォーマットで指定します。次のように設定されている場合、メッセージは表示されたアドレスに転送されます。mailDeliveryOption:forward
mailDeiveryOption とこの属性の両方を設定してメールシステムを sync に保持する必要があるので、注意してください。
例
mailForwardingAddress:kokomo@sesta.com
OID
2.16.840.1.113730.3.1.17
mailHost初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
この受取人に送信されたメッセージの最終的な宛先を示す、MTA の完全指定ホスト名。ユーザーあるいはグループエントリに対して使用されます。ローカルとみなすためには、ユーザーエントリに local.hostname configutil 属性、または local.imta.hostnamealiases configutil 属性で指定されている名前のいずれか 1 つと一致するこの属性が存在する必要があります。あるいは、新しいソースルートアドレスを次の形式で作成します。@mailhost:user@domain 。この形式で作成すると、リライトルールを使用して処理されます。
ユーザーエントリにこの属性がない場合、生成されるアドレスはドメイン @smarthost:user@domain と関連する mailRoutingSmartHost hostname を使用します。ドメインに mailRoutingSmartHost 属性がない場合、アドレスが破棄されて、5xx エラーが報告されます。
グループエントリにこの属性がない場合、グループはローカルで処理されます。
この属性値を無効化するのに使用する MTA オプションは、LDAP_MAILHOST です。
例
mailHost:mail.siroe.com
OID
2.16.840.1.113730.3.1.18
mailMessageStore初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーのメッセージストアパーティション名を指定します。パーティション名と、ストアのファイルシステムの位置とのマッピングは、メッセージストア構成に保存されます。指定しないと、サーバー構成に指定されたデフォルトのストアパーティションが使用されます。
例
mailMessageStore:secondary
OID
2.16.840.1.113730.3.1.19
mailMsgMaxBlocks初出
iPlanet Messaging Server 5.2
構文
int、single-valued
オブジェクトクラス
inetMailGroup, inetMailUser
定義
このユーザーまたはグループに送信可能なメッセージの最大サイズを MTA ブロック単位で示します。この制限は、ユーザーが送信するメッセージには適用されません。
この属性が設定されている場合、mailDomainMsgMaxBlocks の値はオーバライドされます。
この属性値を無効化するのに使用する MTA オプションは、LDAP_BLOCKLIMIT です。
例
OID
TBD
mailMsgQuota初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
ユーザーに許可される最大メッセージ数は、mailMsgQuota で設定されます。ストア内にあるすべてのフォルダの累積値です。表 3-13 に固有な値とその意味を示します。
表 3-13 mailMsgQuota に固有の値
値
意味
0
メールメッセージを許可しない
-1
許可するメッセージ数を制限しない
-2
システムのデフォルトの容量を使用 (この値の使用は削除予定)
この値を指定しない場合、システムのデフォルトの容量が使用されます。
mailMsgQuota を有効にするには、サーバーを構成する際に割り当ての制限を設ける必要があります。ソフトとハード両方の割り当てを設定することができます。詳細は、『Sun ONE Message Server Administrator不 Guide』を参照してください。
MTA オプションを無効にするには、 LDAP_MESSAGE_QUOTA を使用します。
例
mailMsgQuota: 2000
OID
2.16.840.1.113730.3.1.774
mailProgramDeliveryInfo初出
iPlanet Messaging Server 5.0
構文
ces、multi-valued
オブジェクトクラス
定義
プログラムの配信に使用される 1 つ以上のプログラムを指定します。指定されるプログラムは、メッセージングサーバーが該当ドメインで実行することを許可した承認リストに入っている必要があります。属性の値で、プログラムへの参照を指定します。その参照は、プログラムの承認リストから解釈されます。解釈された参照から、プログラムのパラメータと実行権も提供されます。mailDeliveryOption:program と一緒に使用します。
imsimta program の実行時に、この属性の値はメソッド名 (-m 値) として使用されます。
プログラムの承認プロセスの詳細は、『Sun ONE Messaging Server 管理者ガイド』を参照してください。
この機能を実行するほかの属性を指定するには、MTA オプションの LDAP_PROGRAM_INFO を使用します。
例
mailProgramDeliveryInfo:procmail
OID
2.16.840.1.113730.3.1.20
mailPublicFolderDefaultRights初出
Sun ONE Messaging Server 6.0
構文
cis、multi-valued
オブジェクトクラス
定義
パブリックフォルダに付与するアクセス制御権限を指定します。この属性の各値は、スペースで区切られた 2 つの部分で構成されます。2 つの部分は次のとおりです。RFC 2086 に準拠した識別子と、次の表 3-14 に従ったアクセス権のリスト。
Sun ONE Messaging Serve の IMAP ACL 実装も次に示す新しい識別子を定義します。
anyone@domain
domain は、有効なドメインです。
属性が設定されていない場合、mailDomain オブジェクトクラスの mailPublicFolderDefaultRights 属性で指定されるデフォルトの権限が適用されます。mailDomain にこの属性が含まれていないと、パブリックフォルダが初めて作成される際に、次のデフォルト ACL が設定されます。
anyone@domain lrs
domain は、有効なドメインです。
グループの識別子はプレフィックス "group=" で始まります。グループ識別子のプレフィックスをユーザー ID に使用しないでください。メッセージストアのユーザー作成コードはこれをチェックします。
例
mailPublicFolderDefaultRights:anyone@sesta.com lrs
mailPublicFolderDefaultRights:group:sales@sesta.com lrs
mailPublicFolderDefaultRights:john@sesta.com lrswid
OID
mailQuota初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
ユーザーのメールボックスに割り当てられたディスク領域の容量をバイト単位で指定します。数値部分は 4294966272 に制限されています。4G バイトを超える値を設定するには、すべて数字で指定するのではなく、サフィックス G を使用します。ほかの有効なサフィックスは次のとおりです。K バイトを示す K、M バイトを示す M、G バイトを示す G。
表 3-15 にこの属性に固有の値を示します。
表 3-15 mailQuota 固有の値
値
意味
0
ユーザーのメールボックスに領域を割り当てない
-1
領域の容量を制限しない
-2
システムのデフォルトの容量を使用 (この値の使用は削除予定)
メッセージストアは、容量の値を格納するために 32 ビットの符号のない整数値を必要とするので、容量の値は 4096G に制限されています。
属性が指定されていない場合、システムのデフォルト容量が使用されます。システムのデフォルトは、サーバーの設定パラメータ store.defaultmailboxquota に設定されています。設定パラメータ store.quotaenforcement に「on」を設定すると、メッセージストアで容量の増強が実行されます。
例
mailQuota:4G
システムのデフォルト容量の場合 :
mailQuota:
OID
2.16.840.1.113730.3.1.21
mailRejectText初出
Sun ONE Messaging Server 5.2
構文
ces、multi-valued
オブジェクトクラス
定義
この属性の最初の値に格納された最初の行が保存されます。任意の認証属性が原因でメッセージが拒否された場合、このテキストが返されます。このテキストは SMTP の応答に現われる可能性があるので、メッセージング標準に準拠するために、指定する値は US-ASCII 文字に限定されます。
例
OID
TBD
mailRoutingAddress初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
mailHost と一緒に使用して、現在アドレスを使用するか、ほかのシステムに転送するかを決定します。
例
OID
2.16.840.1.113730.3.1.24
mailRoutingHosts初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
このドメイン内のユーザー、および他のドメイン内に含まれているすべてのユーザーのルーティングを決定する MTA の完全指定ホスト名。この属性を指定しないと、すべての MTA がこのドメイン内や他のドメイン内に含まれるユーザー、およびグループのメッセージのルーティングを決定するものとみなされます。
ドメインがローカルに存在しない場合、MTA オプション ROUTE_TO_ROUTING_HOST の値に基づいてこの属性は使用されます。
この属性は複数値を持つ属性で、オプションに 1 が設定されていると、MTA が参照する最初の値が使用されます。そのため、使用するメールホストの順番をユーザーが設定することができ、属性値の順番を指定して負荷分散を行うことができるように思われがちです。しかし、LDAP は属性値を待機している順番に関係なく処理するので、MTA が最初に参照する値は、必ずしも LADP エントリ内の最初の属性値とは限りません。
各ルーティングホスト名に適した MX レコードセットを使用して、負荷分散機能を実装できます。属性値の順番を指定して、負荷分散を行わないでください。
この機能を実行するほかの属性を指定するには、MTA オプションの LDAP_DOMAIN_AATR_ROUTING_HOSTS を使用します。
例
mailRoutingHosts:mail.siroe.com
OID
2.16.840.1.113730.3.1.759
mailRoutingSmartHost初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ローカルディレクトリ内で検出されないユーザーのメール処理を実行する、メールサーバーの完全指定ホスト名あるいはドメインリテラル IP アドレス。メッセージングサーバーのディレクトリ内にないユーザーへ送信されたメッセージは、この属性で指定されたメールサーバーへ転送されます。この属性は、あるメールシステムから別のメールシステムへの移行処理が行われ、すべてのユーザーがまだメッセージングサーバーのディレクトリに移動していないときに便利です。属性が指定されていない場合や値が空だった場合は、ドメイン内のユーザーへのすべてのメッセージのルーティングと配信を、ローカルの MTA が実行します。
使用するドメインが属性に表示されている場合のみ、この属性はシステムで使用されます。それ以外の場合、この属性は無視されます。
例
mailRoutingSmartHost:mail.siroe.com
mailRoutingSmartHost: 129.148.12.141
OID
2.16.840.1.113730.3.1.760
mailSieveRuleSource初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
SIEVE フィルタは、iPlanet Delegated Administrator for Messaging でサポートされていません。Sun ONE LDAP Schema v. 2 および Sun ONE Identity Server で使用してください。
ユーザーエントリに対するメッセージフィルタスクリプトを作成するための SIEVE (RFC 3028 に準拠) ルールが含まれています。この属性は、単一の値の属性 (SIEVE スクリプト全体を含むルール) あるいは複数値の属性 (SIEVE スクリプトの単独で有効な部分をそれぞれに含む複数のルール) です。複数の値が存在する場合、#Rule Info: コメント内の順序指定のパラメータ Order を使用して、Web フィルタ作成インタフェースはルールを単一の SIEVE スクリプトにまとめます。
メッセージが配布チャネルを待機する状態になると、スクリプトが適用されます。つまり、MTA がエイリアスを展開している間に SIEVE スクリプトが作成されても、結果として生成される配信アドレスが展開されて、ims-ms、native、autoreply、またはpipe チャネルに送信されるまで、SIEVE スクリプトは使用されません。
スクリプトの形式は、次のとおりです。
require ["fileinto", "reject"];
# $Rule Info:Order=(1-infinity, or 0 for disabled) Template=(template-name) Name=(rule name)
if header :is "Sender" "owner-ietf-mta-filters@imc.org"
{ fileinto "filter"; # move to "filter" folder }
if header :is "Subject" "SPAM!"
{ delete }MTA オプション
この機能を実行するほかの属性を指定するには、MTA オプションの LDAP_FILTER を使用します。
例
mailSieveRuleSource:
require ["fileinto", "reject", "redirect", "discard]
if header :contains "Subject" "New Rules Suggestion
{redirect "rules@sesta.com" # Forward message }
if header :contains "Sender" "porn.com"
{discard text:
Your message has been rejected.Please remove this address from your mailing list.# メッセージを拒否し、返信メッセージを送信します}
if size :over 1M
{ reject text:
Please do not send me large attachments.
Put your file on a server and send me the URL.
Thank you.# メッセージを破棄し、返信メッセージを送信します}
if header :contains "Sender" "barkley@sesta.com
{ fileinto complaints.refs # File message}OID
2.16.840.1.113730.3.1.775
mailSMTPSubmitChannel初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
通常、この属性は、保証付きメッセージ配信の設定、またはその他の特別なサービスクラスの設定に関連する要因となります。定義する際に、SMTP の AUTH が成功した場合、この属性によって名前が付けられたチャネルを有効な送信チャネルとみなすように MTA に知らせることです。
例
mailSMTPSubmitChannel:tcp_tas
OID
2.16.840.1.113730.3.1.776
mailUserStatus初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
次のメールユーザーステータスのいずれか 1 つを格納します。値がないと、ステータスは inactive とみなされます。
表 3-16 メールユーザーステータス
ステータス値
説明
active
正常な状態。inetUserStatus もアクティブな場合、メールは、mailDeliveryOption や mailSieveRuleSource などのほかのユーザー属性に格納された値どおりに処理される。active に設定されていない場合は、inetUserStatus のステータスが優先する。考慮すべきほかのステータス属性は、inetDomainStatus および mailDomainStatus。inetDomainStatus と mailDomainStatus の組み合わせでメール配信とドメインへのアクセスが許可されている場合は、inetUserStatus および mailUserStatus からユーザーのステータスが決定される
inactive
ユーザーのメールアカウントはアクティブではない。送信側の MTA へ一時的な失敗が返される
deleted
ユーザーのメールアカウントが「deleted」とマークされる。送信側の MTA へ永続的な失敗が返され、ユーザーメールアカウントがパージユーティリティによるクリーンアップの候補になる。メールボックスへのユーザーのアクセスは拒否される
hold
ユーザーのメールは保留キューに送信され、IMAP、POP、および HTTP 経由のメールボックスへのアクセスが許可されなくなる。ストアサーバー上の MTA と Message Access Server は、この要件に従う必要がある。この設定は、ほかの mailDeliveryOption 設定を無効にする
overquota
このステータスの場合、MTA はメールをメールボックスに配信しない
値がないと、ステータスは active として扱われます。不正な値はすべて、inactive として扱われます。
次の 4 つの属性は示す順にメールサービスで評価されます。inetDomainStatus、mailDomainStatus、inetUserStatus、およびmailUserStatus。次の規則を使用します。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。
例
mailUserStatus:active
OID
2.16.840.1.113730.3.1.778
maxPabEntries初出
iPlanet Messaging Server 5.0
構文
int、single-valued
オブジェクトクラス
定義
ユーザーが個人アドレスブックのストア内に入れることのできるエントリの最大数を指定します。値が -1 の場合は、エントリ数に制限はありません。この属性が存在しない場合は、個人アドレスブックの構成で指定されたシステムのデフォルトが使用されます。
例
maxPabEntries: 1000
OID
2.16.840.1.113730.3.1.705
memberOf初出
iPlanet Messaging Server 5.0 (Sun ONE Messaging Server 6.0 の inetUser では削除予定)。Sun ONE Identity Server
構文
dn, multi-valued
オブジェクトクラス
定義
Sun ONE LDAP Schema v.2 では、この属性は inetAdmin を修飾して、ユーザーが所属する割り当て可能なダイナミックグループの DN を指定します。これは、既知のデフォルトのフィルタ属性として mgrpDeliverTo と一緒に使用され、割り当て可能なダイナミックグループのメンバーを検索します。
この属性は Sun ONE Messaging Server 6.0 の inetUser では使用できません。また、今後発表される Sun ONE スキーマの inetUser オブジェクトクラスでも削除される予定です。
Sun ONE LDAP Schema v.1 では、この属性は、スタティックグループのメンバーシップをバックポインタとして指定して、ユーザーが所属するメーリングリストの DN を指定します。
例
memberOf:cn=Administrators,ou=groups o=sesta.com,o=basedn
OID
1.2.840.113556.1.2.102
memberOfPAB初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
このエントリが属する個人アドレスブックの一意名 (un)。
例
memberOfPAB:addressbook122FA7
OID
2.16.840.1.113730.3.1.718
memberOfPABGroup初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
このユーザーが属する個人グループの一意名。
例
memberOfPabGroup:testgroup15577F2D
OID
2.16.840.1.113730.3.1.719
memberURL初出
iPlanet Messaging Server 5.2
構文
ces、multi-valued
オブジェクトクラス
定義
URL のリストであり、拡張すると、メーリングリストのメンバーのアドレスが一覧表示されます。
動的なメーリングリストを指定する方法としてお勧めします。別の方法として、mgrpDeliverTo を使うこともできます。
この属性値を無効化するのに使用する MTA オプションは、LDAP_GROUP_URL2 です。
例
memberURL:ldap://cn=jdoes, o=sesta.com
OID
2.16.840.1.113730.3.1.198
mgrpAddHeader初出
Netscape Messaging Server
構文
ces、multi-valued
オブジェクトクラス
定義
各属性値で、メッセージヘッダーが存在する場合にヘッダーに追加するヘッダーフィールドを指定します。
MTA では、属性値はヘッダーで、ヘッダートリミングの ADD オプションを設定するために使用されます。
例
mgrpAddHeader:Reply-To:thisgroup@sesta.com
OID
2.16.840.1.113730.3.1.781
mgrpAllowedBroadcaster初出
iPlanet Messaging Server 5.0
構文
ces、multi-valued
オブジェクトクラス
定義
メッセージをメールグループに送信することを許可されたメールユーザーを識別します。Messaging Server では、この属性に識別名、あるいは LDAP URI または mailto アドレスを使用する RFC822address のどちらかが入っていることを想定しています (例を参照)。識別名が使用される場合は、group または groupOfUniqueNames タイプのメール可能なエントリ (複数も可) を表している必要があります。つまり、グループエントリは次に示す属性のうちの 1 つをメールアドレスに含む必要があります。mail、mailAlternateAddress、mailEquivalentAddress。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedDomain および mgrpDisallowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザーの制限はありません。
複数の値を使用する場合は、各 URL がアドレスのリストに拡張され、各アドレスは、現在のエンベロープの送信元のアドレスに対照してチェックされます。一致した場合は、そのメッセージが許可されます。
このグループのメンバーだけがグループに送信できるように指定するには、グループ名を属性値として使用します。
属性値が無効な URL の場合や、属性値にグループのメンバーが指定されていない場合、メッセージは戻されます。
例
mgrpAllowedBroadcaster:ldap:///uid=bjensen,o=siroe.com
mgrpAllowedBroadcaster:mailto:group1@siroe.com
OID
2.16.840.1.113730.3.1.22
mgrpAllowedDomain初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
ユーザーがそこからメッセージをメールグループに送信することを許可されるドメイン (サブドメインも含む) を識別します。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedBroadcaster、mgrpDisallowedBroadcaster、および mgrpDisallowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザーの制限はありません。
例
mgrpAllowedDomain:siroe.com
この例では、*.siroe.com から送信するすべてのユーザーに一致します。
OID
2.16.840.1.113730.3.1.23
mgrpAuthPassword初出
iPlanet Messaging Server 5.0
構文
ces、single-valued
オブジェクトクラス
定義
リストに投稿するために必要なパスワードを指定します。
パスを再処理します。メッセージがチャネルの再処理を待機する状態になると、ヘッダーからパスワードを取得して、エンベロープに保存します。そして、再処理の実行中にパスワードをエンベロープから取得して、この属性と照合します。実際に使用されているパスワードだけをヘッダーフィールドから削除します。
こうすることで、不正なパスワードをモデレータにルートできます。
例
OID
2.16.840.1.113730.3.1.783
mgrpBroadcasterPolicy初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
許可されるブロードキャスタを決定するためのポリシー。ブロードキャスタのアドレスのリストにアクセスするために必要な認証のレベルを指定します。指定できる値は、次のとおりです。
例
mgrpBroadcasterPolicy:AUTH_REQ
OID
2.16.840.1.113730.3.1.3
mgrpDeliverTo初出
iPlanet Messaging Server 5.0
構文
ces、multi-valued
オブジェクトクラス
定義
メールグループのメンバーシップを指定する代替方法として使用されます。これは、ダイナミックなメーリングリストを作成するために使用されます。
ダイナミックなメールグループを指定する場合は、memberURL 属性を使用することをお勧めします。
この属性の値は URL のリストであり、拡張すると、メーリングリストのメンバーのアドレスが一覧表示されます。
Messaging Server は、この属性に RFC 1959 に説明されているフォーマットを使用した LDAP URL が入っていることを想定します。LDAP 検索の結果返されるエントリは、メーリンググループのメンバーです。サーチフィルタの長さは、1024 バイトに制限されています。
例
この例では、Sesta という企業に所属し米国内に勤務する、経理部門の全ユーザーが返されます。
mgrpDeliverToldap:///ou=Accounting,o=Sesta,c=US??sub?
(&(objectClass=inetMailUser)(objectClass=inetOrgPerson))OID
2.16.840.1.113730.3.1.25
mgrpDisallowedBroadcaster初出
iPlanet Messaging Server 5.0
構文
ces、multi-valued
オブジェクトクラス
定義
メッセージをメールグループに送信することを許可されていないメールユーザーを識別します。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedDomain および mgrpDisallowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザーの制限はありません。
Messaging Server は、この属性に識別名または RFC822address のどちらかが入っていることを想定します。識別名が使用される場合は、グループタイプまたは groupOfUniqueNames のメール可能なエントリ (複数も可) を表している必要があります。つまり、グループエントリは次に示す属性のうちの 1 つをメールアドレスに含む必要があります。mail、mailAlternateAddress、mailEquivalentAddress。識別名は、RFC 1959 に説明されているとおりの、LDAP URL の形式で表されている必要があります。
複数の値を使用する場合は、各 URL がアドレスのリストに拡張され、各アドレスは、現在のエンベロープの送信元のアドレスに対照してチェックされます。一致した場合、そのメッセージは許可されません。
例
mgrpDisallowedBroadcaster:ldap:///uid=bjensen, o=sesta.com
mgrpDisallowedBroadcaster:mailto:sys50@sesta.com
OID
2.16.840.1.113730.3.1.785
mgrpDisallowedDomain初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
ユーザーがそこからメッセージをメールグループに送信することを許可されないドメインを識別します。この属性は、メーリングリストを管理するために Messaging Server に使用される、非公開のエクステンションです。この属性が存在する場合、リストされたドメインからのメッセージは拒否されます。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedBroadcaster、mgrpDisallowedBroadcaster、および mgrpAllowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザーの制限はありません。
例
mgrpDisallowedDomain:sesta.com
OID
2.16.840.1.113730.3.1.784
mgrpErrorsTo初出
iPlanet Messaging Server 5.0
構文
ces、single-valued
オブジェクトクラス
定義
メッセージがこのリストに送信されたときに生成されるエラーメッセージの受取人。受取人のアドレスは、mailto 構文を使用して指定します。RFC 822 メールアドレスの先頭にキーワード "mailto:" を付けて指定します。あるいは、単純に RFC 822 メールアドレスだけで指定することもできます。また、LDAP URL の構文もサポートします。ただし、LDAP URL を使用する場合は、単一のアドレスを作成する URL であることが必要です。
エンベロープオリジネータ (MAIL FROM) のアドレスは、この属性の値に設定されます。
例
例 1: mgrpErrorsTo:mailto:jordan@siroe.com
例 2: mgrpErrorsTo:ldap:///uid=ofanning,ou=people,o=siroe.com,o=ispOID
2.16.840.1.113730.3.1.26
mgrpModerator初出
iPlanet Messaging Server 5.0
構文
ces、multi-valued
オブジェクトクラス
定義
この (メーリング) リストにメッセージを送信することを許可されたモデレータを識別するための LDAP URI または mailto URL。モデレータによって送信されたメッセージだけが、このリストのメンバーに送信されます。モデレータ以外によって送信されたメッセージは、承認および再送信のためにモデレータに転送されます。
この属性の値として指定された URL が一連のアドレスに拡張され、エンベロープの「送信元」のアドレスと比較されます。アドレスが一致した場合は、グループ処理が続行されます。一致しなかった場合はこの属性の値がグループの URL となり、RFC 822 アドレスの任意のリスト、またはグループに関連付けられた DN がクリアされ、グループの配信オプションが「members」に設定されて、一致しなかった URL に対してそれ以上のグループ処理は行われません。後続のグループ属性は無視されます。
例
mgrpModerator:mailto:jordan@sesta.com
OID
2.16.840.1.113730.3.1.33
mgrpMsgMaxSize初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
グループへ送信できる最大のメッセージサイズ (バイト数)。Messaging Server は、この属性のゼロまたは 1 つのインスタンスが、すべての mailGroup エントリに存在することを想定します。エントリがないと、グループへのメールに対し、サイズは制限されません。
この属性は削除されましたが、後方互換性のため、引き続きサポートされます。この属性の代わりに、mailMsgMaxBlocks を使用してください。
例
mgrpMsgMaxSize:8000
OID
2.16.840.1.113730.3.1.3
mgrpMsgPrefixText初出
実装されていません。
構文
UTF-8 テキスト、single-valued
オブジェクトクラス
定義
メッセージテキストの先頭に追加されるテキストを指定します。書式を指定する必要があります。つまり、テキスト内で書式を指定する場所に CRLF を挿入する必要があります。
例
OID
TBD
mgrpMsgRejectAction初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
メールグループに送信したメールが拒否された場合のアクションを指定します。Messaging Server は、次の理由でメールを拒否します。
この属性には、次の 2 つの値を使用できます。reply および toModerator。
reply - システムが SMTP エラーを作成します。属性が設定されていない場合は、デフォルト値として使用されます。配信不能通知のテキストは、mgrpMsgRejectText 属性に格納されます。
toModerator - メールはモデレータに転送されて、処理されます。モデレータは、mgrpModerator 属性で指定されます。
例
mgrpMsgRejectAction:reply
OID
2.16.840.1.113730.3.1.28
mgrpMsgRejectText初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
グループアクセスの失敗時に int を使用するためのエラーテキストを指定します。このテキストは SMTP の応答に現われる可能性があるので、US-ASCII の単一行のテキストに制限されます。この属性内の最初のテキスト行だけを読み取り、その中に 8 ビット文字が含まれていない場合にだけ、この属性が実装されます。これは、SMTP プロトコルの制限です。
例
OID
2.16.840.1.113730.3.1.29
mgrpMsgSuffixText初出
実装されていません。
構文
UTF-8 テキスト、single-valued
オブジェクトクラス
inetMailGroup
定義
テキストメッセージに付加されるテキストを指定します。書式を指定する必要があります。つまり、テキスト内に CRLF (キャリッジリターン、ラインフィーダ) を挿入する必要があります。
例
OID
TBD
mgrpNoDuplicateChecks初出
iPlanet Messaging Server 5.0。iPlanet Messaging Server 5.2 に移行できるように実装されていない。
構文
cis、single-valued
オブジェクトクラス
定義
この属性は、これ以上サポートされません。重複しているかどうかのチェックは、リスト自体の特徴によって制御されます。結合されるリストもあれば、されないリストもあります。
従来の定義 : Messaging Server に、メールグループのメンバーに重複して配信したかどうかのチェックをさせないようにします。ユーザーが複数のリストに登録されている場合は、重複した配信を防ぎます。No を指定すると、システムによって重複配信のチェックが行われます。Yes を指定すると、システムによる重複配信のチェックは行われません。
例
mgrpNoDuplicateChecks:yes
OID
2.16.840.1.113730.3.1.789
mgrpRemoveHeader初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
各属性値で、メッセージヘッダーが存在する場合にメッセージヘッダーから削除するヘッダーフィールドを指定します。
指定されたヘッダーは、ヘッダートリミングの MAXLINES=-1 オプションに変わります。
例
OID
2.16.840.1.113730.3.1.801
mgrpRequestToこの属性はスキーマから削除されました。このバージョンは、この属性をサポートしていません。dirsync モードでは機能しますが、dirsync モードは iPlanet Messaging Server 5.2 で削除されています。
mgrpRFC822MailMember初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
メールグループへ送信されるメールの受取人を識別します。この属性と uniqueMember 属性の両方で指定されたメールの受取人は、混合される groupOfUniqueNames のメンバーではありません。この属性は、識別名で表すことのできないメールの受取人、または、このグループからメールを送信されることがあっても一意のグループメンバーの特権を持っていないメールの受取人を表します。Messaging Server では、この属性に RFC 822 のメールアドレスが入ることを想定します。通常は、ローカルディレクトリにないグループメンバーのために使用されます。
下位互換のために、rfc822MailMember もサポートされています。任意に指定したグループでどちらかの属性を使用できますが、両方を使用することはできません。
例
mgrpRFC822MailMember:bjensen@siroe.com
OID
2.16.840.1.113730.3.1.30
msgVanityDomain初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
この属性とオブジェクトクラスは、現在のリリースでは使用できますが、以降のリリースではサポートされない可能性があります。この機能をサイトで使用することを中止して、現在のバニティドメインをホストドメインに移行することを考慮してください。
例
OID
2.16.840.1.113730.3.1.799
multiLineDescription初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
配布リストの詳細な説明。ドル記号 ($) を入れると、改行されます。
例
multiLineDescription:People who like cats.$And are ambivalent about people.
OID
1.3.6.1.4.1.250.1.2
nickName初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
pabPerson または pabGroup エントリを検索するために使用する短い名前を識別します。
例
nickname:Nick
OID
2.16.840.1.113730.3.1.720
nswcalDisallowAccess初出
NetscapeTM Calendar Hosting Server
構文
cis、single-valued
オブジェクトクラス
定義
このユーザーに許可されていないカレンダープロトコルを表示します。
例
OID
2.16.840.1.113730.3.1.539
nswmExtendedUserPrefs初出
iPlanet Messaging Server 5.0
構文
cis、multi-valued
オブジェクトクラス
定義
この属性は、「送信元」アドレスの並び順など Messenger Express の設定を定義するペアを保持します。この属性の各インスタンスは、pref_name=pref_value という形式の組み合わせです。これは独自の構文であり、次の例は、この属性の説明のみを目的とします。
例
例 1: nswmExtendedUserPrefs:meColorSet=4
例 2: nswmExtendedUserPrefs:meSort=r
例 3: nswmExtendedUserPrefs:meAutoSign=True
例 4: nswmExtendedUserPrefs:meSignature=Otis
Fanning$ofanning@sesta.com
例 5: nswmExtendedUserPrefs:meDraftFolder=DraftsOID
2.16.840.1.113730.3.1.520
o初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーが所属する会社または組織の名前。これは、「organizationName」の省略形です。
例
organizationName:Company22 Incorporated
または
o:Company22 Incorporated
OID
2.5.4.10
objectClass初出
iPlanet Messaging Server 5.0
構文
cis
オブジェクトクラス
定義
このオブジェクトクラスのオブジェクトを指定します。
例
objectClass:person
OID
2.5.4.0
organizationName (「o」 を参照)
organizationUnitName (「ou」を参照)
ou初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
ユーザーが所属する組織単位の名前。organizationUnitName の省略形。
例
organizationUnitName:docs
または
ou:docs
OID
2.16.840.1.113730.3.1.722
owner初出
iPlanet Messaging Server 5.0
構文
dn、single-valued
オブジェクトクラス
定義
エントリに対して管理権限を持つユーザーまたはグループの識別名 (DN) を識別します。
例
owner:cn=John Smith,o=Sesta,c=US
OID
2.5.4.32
pabURI初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
このユーザー用の個人アドレスブックのエントリのコンテナを指定する LDAP URI。次の形式を使用します。ldap://server:port/container_dn。Server、port、container_dn は、次のとおりです。
例
pabURI:ldap://ldap.siroe.com:389/ou=ed,ou=people,o=sesta.com,o=isp,o=pab
OID
2.16.840.1.113730.3.1.703
parentOrganization初出
Sun ONE Messaging Server 6.0、Sun ONE Calendar Server 6.0
構文
cis、single-valued
オブジェクトクラス
sunManagedSubOrganization
定義
サブ組織の論理的な親を指定します。この値は、親組織あるいは親のサブ組織の DN です。
例
parentOrganization:o=sesta,o=com,o=internet
OID
postalAddress初出
LDAP
構文
cis
オブジェクトクラス
icsCalendarResource, organization, organizationalUnit
定義
エントリのメーリングアドレスを識別します。このフィールドには複数行が含まれます。LDIF フォーマットで表す場合、各行はドル記号 ($) で区切る必要があります。
テキスト内で実際のドル記号 ($) や円記号 (¥) を表す場合は、それぞれ ¥24 と ¥5c の 16 進数値でエスケープしてください。たとえば、次の文字列を表すとします。
The dollar ($) value can be found
in the c:¥cost file.実際に指定する文字列は、次のようになります。
The dollar(¥24) value can be found$in the c:¥5ccost file.
例
postalAddress:123 Oak Street$Anytown, CA$90101
OID
2.5.4.16
preferredLanguage初出
iPlanet Messaging Server 5.0, iPlanet Calendar Server 5.1、Sun ONE Directory Server
構文
RFC 2798、cis、single-valued
オブジェクトクラス
icsCalendarUser, inetMailGroup, inetOrgPerson, iPlanetPreferences, mailDomain
定義
優先されるユーザーの書き言葉または話し言葉。この属性の値は、HTTP Accetpt-Language ヘッダー値の構文に準拠していなければなりません。
Messaging Server はこの属性を使用してロケールを判断します。iPlanetPreferences で指定したロケールは使用しません。
ユーザーの優先言語を格納するユーザー LDAP エントリ内の Sun ONE Identity Server もこの属性を使用します。Sun ONE Identity Server だけが、iPlanetPreferences オブジェクトを使用してこの属性をホストすることに、注意してください。
表 3-17 にサポートされている言語の文字列を示します。
表 3-17 preferredLanguage 属性の言語文字列
言語文字列
言語
de
ドイツ語
en
英語
es
スペイン語
fr
フランス語
ja
日本語
ko
韓国語
zh-CN
中国語 - 中華人民共和国
zh-TW
中国語 - 台湾
例
preferredLanguage:en
OID
2.16.840.1.113730.3.1.39
preferredMailHost初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
Sun ONE Messaging Server Delegated Administrator with Sun ONE LDAP Schema v.1 でのみ使用されます。
このメールドメイン内に新しく作成されたユーザーとグループの mailHost 属性を設定するために使用されます。
例
preferredMailHost:mail.siroe.com
OID
2.16.840.1.113730.3.1.761
preferredMailMessageStore初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
Sun ONE Messaging Server Delegated Administrator for Sun ONE LDAP Schema v.1 でのみ使用されます。
新しく作成されたユーザーの mailMessageStore 属性を設定するために使用されます。値がない場合、Delegate Administrator は mailMessageStore 属性を空のまま残し、アクセスサーバーは、ユーザーのメールボックスがサーバーインスタンスのデフォルトのパーティションにあるとみなします。
例
preferredMailMessageStore:primary
OID
2.16.840.1.113730.3.1.762
seeAlso初出
LDAP
構文
dn
オブジェクトクラス
groupOfUniqueNames, organization, organizationalUnit
定義
このエントリに関連する情報を含んでいる可能性のある別の LDAP エントリを識別します。
例
seeAlso:cn=Quality Control Inspectors,ou=manufacturing,o=Company22, c=US
OID
2.5.4.34
sn初出
LDAP
構文
cis
オブジェクトクラス
定義
姓または家族名とも言われる、エントリの苗字を識別します。
例
surname:jones
OID
2.5.4.4
telephoneNumber初出
LDAP
構文
tel
オブジェクトクラス
domain, organization, organizationalUnit
定義
エントリの電話番号を指定します。
例
telephoneNumber:800-555-1212
OID
2.5.4.20
uid初出
iPlanet Calendar Server 5.0、iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
icsCalendarResource, icsCalendarUser
定義
このユーザーあるいはリソースの一意の識別子を指定します。有効なすべてのユーザーおよびリソースエントリは、uid 属性を保有する必要があります。グループエントリが uid を保有している場合もあります。
Messaging Server では、uid を使用して配布チャネルに送信するためのユーザーアドレスを生成します。ユーザーエントリに uid 属性がない場合、このエントリは無視されます。エントリに複数の uid 属性が存在する場合、最初の属性だけが使用されます。この属性値を無効化するのに使用する MTA オプションは、LDAP_UID です。
例
uid:jdoe
OID
0.9.2342.19200300.100.1.1
un初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
PAB エントリに割り当てられた一意の名前。これもこのオブジェクトクラスによって作成されるエントリのために名前をつける属性であり、エントリのタイプ (pab、pabPerson、または pabGroup) に関係なく、すべての PAB エントリの DN を形成するために使用されます。
例
un:Nick
OID
2.16.840.1.113730.3.1.717
uniqueMember初出
iPlanet Messaging Server 5.0
構文
dn, multi-valued
オブジェクトクラス
定義
スタティックグループのメンバーを指定します。この属性を使用すると、グループの各メンバーはグループの LDAP エントリに表示されます。
例
uniqueMember:uid=jdoe,ou=People,o=sesta.com,o=basedn
uniqueMember:uid=rsmith,ou=People,o=sesta.com,o=basednOID
2.5.4.50
userid (「uid」を参照)
userPassword初出
iPlanet Messaging Server 5.0
構文
bin、single-valued
RFC 2256 でこの属性が複数値の属性として定義されていても、Sun ONE 製品では 1 つの値しか許可されていません。
オブジェクトクラス
inetUser, domain, organization, organizationalUnit
定義
この属性で、エントリのパスワードと次の形式の暗号化方法を識別します。
{encryption method}encrypted password
基盤とするトランスポートサービスが機密性を保証できないならば、クリアテキストのパスワードを送信することはお勧めできません。クリアテキストを送信すると、承認されていないパーティーにパスワードが公開されてしまう可能性があります。
例
userPassword:{sha}FTSLQhxXpA05
OID
2.5.4.35
vacationEndDate初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
休暇終了日時。日付の形式は次のとおりです。YYYYMMDDHHMMSSZ。YYYY は 4 桁の西暦年、MM は 2 桁の月、DD は 2 桁の日、HH は 2 桁の時間、SS は 2 桁の秒です。時間は GMT を標準にしています。Z は、文字 Z です。
現在の日付が、vacationStartDate および vacationEndDate 属性で指定した範囲を超えた場合、プレフィックス "^" が付いた DELIVERY_OPTIONS リストの配信オプションが、オプションのアクティブセットから削除されます。たとえば、DELIVERY_OPTIONS の 1 つが "^*autoreply" で、今日の日付が休暇期間を超えている場合、このオプションは、アクティブなオプションリストから削除されます。削除されない場合は、自動返信の配信オプションがアクティブになります。
例
vacationEndDate:20000220000000Z
OID
2.16.840.1.113730.3.1.708
vacationStartDate初出
iPlanet Messaging Server 5.0
構文
cis、single-valued
オブジェクトクラス
定義
休暇開始日時。日付の形式は次のとおりです。YYYYMMDDHHMMSSZ。YYYY は 4 桁の西暦年、MM は 2 桁の月、DD は 2 桁の日、HH は 2 桁の時間、SS は 2 桁の秒です。時間は GMT を標準にしています。Z は、文字 Z です。
例
vacationStartDate:20000215000000Z
OID
2.16.840.1.113730.3.1.707