System Administration Guide: Naming and Directory Services (NIS+)

NIS+ User Problems

This section describes NIS+ problems that a typical user might encounter.

NIS+ User Problem Symptoms

NIS+ User Cannot Log In

There are many possible reasons for a user being unable to log in:

(See nsswitch.conf File Requirements for Passwords for further details.)

NIS+ User Cannot Log In Using New Password

Symptoms:

Users who recently changed their password are unable to log in at all, or are able to log in on some machines but not on others.

Possible Causes:

NIS+ User Cannot Remote Log In to Remote Domain

Symptoms:

User tries to rlogin to a machine in some other domain and is refused with a “Permission denied” type error message.

Possible Cause:

To rlogin to a machine in another domain, a user must have LOCAL credentials in that domain.

Diagnosis:

Run nismatch username.domainname. cred.org_dir in the other domain to see if the user has a LOCAL credential in that domain.

Solution:

Go to the remote domain and use nisaddcred to create a LOCAL credential for the user in the that domain.

NIS+ User Cannot Change Password

The most common cause of a user being unable to change passwords is that the user is mistyping (or has forgotten) the old password.

Other possible causes: