/usr/sbin/lufslist [-l error_log] [-o outfile] BE_name [-X]
The lufslist command is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The lufslist command lists the configuration of a boot environment (BE). The output contains the disk slice (file system), file system type, and file system size for each BE mount point. The output also notes any separate file systems that belong to a non-global zone inside the BE being displayed.
The following is an example of lufslist output, which shows a separate filesystem for the zone, zone1, within the BE being displayed.
# lufslist BE_name Filesystem fstype size(Mb) Mounted on ------------------------------------------------------------------ /dev/dsk/c0t0d0s1 swap 512.11 - /dev/dsk/c0t4d0s3 ufs 3738.29 / /dev/dsk/c0t4d0s4 ufs 510.24 /opt zone zone1 within boot environment BE_name /dev/dsk/c0t4d0s7 ufs 7000.48 /export
File system type can be ufs, swap, or vxfs, for a Veritas file system. Under the Filesystem heading can be a disk slice or a logical device, such as a disk metadevice used by volume management software.
The lufslist command requires root privileges or the Primary Administrator role.
The lufslist command has the following options:
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
Name of the BE for which file systems are to be reported. You cannot specify a BE that is involved in another Live Upgrade operation.
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludelete(1M), ludesc(1M), lumake(1M), lumount(1M), lurename(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5), zones(5)