Sun Microsystems Logo
Products and Services
 
Support and Training
 
 

A  B  C  D  E  F  G  H  I  J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z  
 
Application Server Utilityasadmin(1m)


NAME

 asadmin - utility for performing administrative tasks for the Sun Java System Application Server

SYNOPSIS

 asadmin subcommand[ -short_option[ short_option_argument ] ]* [ --long_option[ long_option_argument ] ]* [ operand ]*

DESCRIPTION

Use the asadmin utility to perform any administrative task for the Sun Java System Application Server. You can use this utility in place of using the Administrator interface.

The subcommand identifies the operation or task you wish to perform. Subcommands are case-sensitive. Short option arguments have a single dash (--); while long option arguments have two dashes (--). Options modify how the utility performs a subcommand. Options are also case-sensitive. Most options require argument values except boolean options which toggle to switch a feature ON or OFF. Operands appear after the argument values, and are set off by a space, a tab, or double dashes (). The asadmin utility treats anything that comes after the options and their values as an operand.

asadmin can be used in command shell invocation or multi command mode (known as multimode). In command shell invocation you invoke the asadmin utility from your command shell. asadmin executes the command, then exits. In multiple command mode, you invoke asadmin once, it then accepts multiple commands until you exit asadmin and return to the normal command shell invocation. Environment variables set while in multiple command mode are used for all subsequent commands until you exit multimode. You may provide commands by passing a previously prepared list of commands from a file or standard input (pipe). Additionally, you can invoke multimode from within a multimode session; once you exit the second multimode environment, you return to your original multimode environment.

You can also run the asadmin utility in interactive or non-interactive options. By default, the interactive option is enabled. It prompts you for the required arguments. You can use the interactive option in command shell invocation under all circumstances. You can use the interactive option in multimode when you run one subcommand at a time from the command prompt; and when you run in multimode from a file. Subcommands in multimode, when piped from an input stream, and subcommands invoked from another program, cannot run in the interactive option.

Local subcommands can be executed without the presence of an administration server. However, it is required that the user be logged into the machine hosting the domain in order to execute the subcommand and have access (permissions) for the installation and domain directories.

Remote subcommands are always executed by connecting to an administration server and executing the subcommand there. A running administration server is required. A user, however, can be on a local machine and execute a remote subcommand by connecting to a local administration server instance running on the machine. All remote subcommands require the --host, --port, --user, and --password options to be set, either on the command line or in the environment.

For subcommands that can be executed locally or remotely, if any one of the options --host, --port, --user, or --password are set, either in the environment or in the command line, the subcommand will run in remote mode.

Additionally, for subcommands that can be executed locally or remotely, if the --local option is set to true, the subcommand will run locally. Also, if none of the options --host, --port, --user, or --password are set, either on the command line or in the environment, the subcommand is executed locally by default.

Setting the --local option to true overrides the --host, --port, --user, and --password settings, even if specified. The subcommand will run in local mode.

Subcommands that can be executed locally accept the --domain option to specify the domain of interest which assumes the domain as the default domain if there is only one. If there is more than one domain, the --domain option is a required option.

For subcommands that can be run locally or remotely, when run remotely with the --host, --port, --user, and --password options specified, the --domain option is ignored. The --domain option is ignored if the subcommand will be run in remote mode. Note that there is one administration instance per domain, so on a single machine with multiple domains, local execution must specify the domain, and remote execution must specify the --host, --port, --user, and --password options for the administration instance for that domain.

For security purposes, you can set the password for a subcommand from a file instead of entering the password at the command line. The --passwordfile option takes the file containing the passwords. The valid contents for the file are:

AS_ADMIN_PASSWORD=value
AS_ADMIN_ADMINPASSWORD=value
AS_ADMIN_USERPASSWORD=value

Given the --passwordfile option and its value, the password options in the passwordfile are exported to the global environment; subsequent subcommands without the password options take this value. However, if both the --password and --passwordfile options are specified on the command line, the password value in the passwordfile is exported to the global environment and subsequent subcommands without the --password option would take this value. However, for the current subcommand, the --password option value specified on the command line is taken since the --password option takes precedence over the --passwordfile option.

To access the manpages for the Sun Java System Application Server Command-line interface subcommands, add $AS_INSTALL/man to your MANPATH environment variable.

You can obtain overall usage information for any of the asadmin utility subcommands by invoking the --help option. If you specify a subcommand, the usage information for that subcommand is displayed. Using the help option without a subcommand displays a listing of all the available subcommands.

See the Sun Java System Application Server Administration Guide for a listing of all the options in their short form.

Environment Subcommands

The environment variables are name/value pairs that can be set at any time and are in effect for the duration of the asadmin invocation. The asadmin utility will only read environment variables that have been exported using the export subcommand. Of course, environment subcommands are relevant only for the multiple subcommand mode (multimode).

 
export[ name=value[ name=value ]* ]
  • Marks a variable name for automatic export to the environment of subsequent subcommands. All subsequent subcommands use the variable name values as specified; unless you unset them or exit multimode. If no arguments are specified, a list of all the exported variables and their values is displayed.

  • Exported shell environment variables set prior to invoking the asadmin utility are imported automatically and set as exported variables within asadmin. Unexported environment variables cannot be read by the asadmin utility.

 
unset env_var[ env_var ]*
  • Removes one or more variables from the environment. The variables and their associated values no longer exist.

  • This subcommand can be run remotely only.

 
multimode[ --file filename ][ --encoding encode ][ --passwordfile filename ][ --interactive ]
  • Runs multiple commands without exiting the asadmin utility.

  • All variables are retained between subcommand invocations. Subcommand invocation is faster because asadmin does not need to start up each time.

  • Subcommands will be executed in multimode until the exit or quit command is given; at which point the multimode subcommand will exit.

  • You can provide subcommands by passing a previously prepared list of subcommands from a file or standard input (pipe).

  • You can invoke multimode from within a multimode session; once you exit the second multimode environment, you return to your original multimode environment.

Domain Administration Subcommands

The domain subcommands enable the configuration and management of a single administration server, and one or more associated J2EE server instances it controls. The domain encompasses all the data in the configuration repository for the administered instances, as well as all the deployed application data pertaining to the instances. Each administrative domain contains a unique administration server instance with its own unique set of port numbers.

A domain is constrained to a single machine; and domain names must be unique within the machine they are hosted on.

 
create-domain[ --path domain_path ][ --sysuser sys_user ][ --passwordfile filename ]
--adminport port_number--adminuser admin --adminpassword password 
domain_name
  • This subcommand can be run locally only.

  • The sys_user must be a valid user on the system (Solaris only).

  • The port_number cannot be currently active.

  • The domain_name must be unique.

  • The directory domain_path/domain_name must not already exist. The default domain will be created under $AS_DOMAINS_PATH directory.

 
delete-domain domain_name
  • This subcommand can be run locally only.

  • The domain must already exist, but the instances within the domain must not be executing.

 
start-domain[ --domain domain_name ]
  • This subcommand can be run locally only.

  • The domain must currently exist on the local machine.

 
stop-domain[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --local=false ][ --domain domain_name ][ --adminserv=true ]
[ --passwordfile filename ][ --secure|-s ]
  • This subcommand can be run both locally and remotely. The domain must exist on the local machine to run this subcommand locally.

 
list-domains[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --local=false ][ --passwordfile filename ][ --secure|-s ]
  • This subcommand can be run both locally and remotely.

  • Set the option --local to true to execute this subcommand locally. If running remotely, the administrative server must be running on the hostname specified.

  • One or more domain must already exist.

Instance Subcommands

These subcommands configure the instances that the clients may control or manage.

 
create-instance[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --sysuser sys_user ][ --domain domain_name ][ --local=false ]
[ --passwordfile filename ][ --secure|-s ]--instanceport instance_port
instance_name
  • The named instance must not exist within that domain.

 
start-instance[ --user admin_user ][ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --local=false ][ --domain domain_name ][ --debug=false ]
[ --passwordfile filename ][ --secure|-s ]instance_name
  • This subcommand can be run both locally and remotely.

  • To start locally, with a domain name identified, the named instance must already exist within that domain.

  • To start remotely, the administration server must be running on the hostname and port number specified. The user authenticates using the password identified for the administration server.

 
delete-instance[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --local=false ][ --domain domain_name ][ --passwordfile filename ]
[ --secure|-s ]instance_name
  • This subcommand can be run both locally and remotely.

  • The server instance must not be running before you can delete it.

  • To delete remotely, the administration server must be running on the hostname and port number specified. The user authenticates using the password identified for the administration server. Additionally, the instance must already exist within the domain served by the administration server.

  • Use with discretion since this subcommand is destructive and there is no undo.

 
stop-instance[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --local=false ][ --domain domain_name ][ --passwordfile filename ]
[ --secure|-s ]instance_name
  • This subcommand can be run both locally and remotely.

  • The named instance must already exist within the given domain; and the instance must be running.

 
restart-instance[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --local=false ][ --domain domain_name ][ --passwordfile filename ]
[ --secure|-s ]instance_name
  • This subcommand is not supported on Windows.

  • This subcommand can be run both locally and remotely.

  • To restart remotely, the administration server must be running on the hostname and port number specified. The user authenticates using the password identified for the administration server. Additionally, the instance must already exist within the domain served by the administration server, and the instance must be running.

 
list-instances[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --domain domain_name ][ --local=false ][ --passwordfile filename ]
[ --secure|-s ]
  • This subcommand can be run both locally and remotely.

  • To list remote instances, the named administration server must be running on the hostname and port number specified. The user authenticates using the password identified for the administration server.

 
start-appserv
  • This subcommand can be run locally only.

  • One or more domain must already exist.

  • Starts all the domains defined for the application server installation; use with caution.

 
stop-appserv
  • Stops all the domains, and its instances, in the application server installation; use with caution.

  • This subcommand can be run locally only.

  • One or more domain must already exist.

List and Status Subcommands

These subcommands display the list of instances/services in the server, the status of the instance, and the service of a deployed application on the server.

 
show-instance-status--user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --local=false ][ --passwordfile filename ][ --secure|-s ]instance_name
  • The instance must already exist. If the instance does not exist, the subcommand fails.

  • The status is a string representation returned by the server; it can be:starting/started, or stopping/stopped.

 
show-component-status --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
component_name
  • Gets the status of the deployed component.

 
list-components --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --type application|ejb|web|connector ]
instance_name
  • Lists all components for the specified instance.

  • If the --type is not specified, then all the deployed applications and standalone modules are listed.

 
list-sub-components --user admin_user [ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --type ejbs|servlets ]
[ --instance instance_name ][ --appname app_name ]module_name
  • Lists your EJBs or Servlets in a deployed module or in a module of the deployed application.

  • If the module is not identified, all modules are listed.

  • The component type defaults to EJBs.

 
enable --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --type application|ejb|web|connector ]
[ --instance instance_name ]component_name
  • If the component is already enabled, then it is re-enabled.

  • The component must have been deployed in order to be enabled. If it has not been deployed, an error message is returned.

  • --type identifies the type of deployed component.

 
disable --user admin_user[ --password admin_password ] [ --host localhost ][ --port 4848 ]
[ --passwordfile filename ][ --secure|-s ][ --type application|ejb|web|connector  ]
[ --instance instance_name ]component_name
  • Immediately stops the named component.

  • The component must have been deployed to the specified instance. If the component has not been deployed, an error message is returned.

  • --type identifies the type of deployed component.

Deployment Subcommands

These subcommands are used for deploying applications and modules to the named instance on the Sun Java System Application Server.

 
deploy --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --virtualservers virtual_servers ]
[ --type application|ejb|web|connector ][ --contextroot context_root ][ --force=true ]
[ --precompilejsp=false ][ --verify=false ][ --name component_name ]
[ --upload=true ][ --retrieve local_dirpath ] [ --instance instance_name ]
filepath
  • Deploys the named component of the specified type. If the component does not exist, the system indicates accordingly. If the component is already deployed or already exists, it is forcefully re-deployed if the force option is set to true.

  • --contextroot is valid only if the archive is a web-module.

  • --name is the name of the deployable component.

  • If upload is set to true, the system uploads the deployable file to the administration server.

  • The deployable file location should be an absolute path on the server machine when the upload option is set to true.

 
deploydir --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --virtualservers virtual_servers ]
[ --type application|ejb|web|connector ][ --contextroot context_root ][ --force=true ]
[ --precompilejsp=false ][ --verify=false ][ --name component_name ]
[ --instance instance_name ]dirpath
  • Deploys the J2EE component that is in the directory located on the server machine.

  • --force option makes sure the component is forcefully (re)deployed even if the specified component has already been deployed or already exists.

  • --contextroot is valid only if the archive is a web-module. Ignored for other archive types; defaults to filename_without_extension.

 
undeploy --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
[ --type application|ejb|web|connector ][ --instance instance_name ]
component_name
  • Removes the component from the named instance.

Configuration Subcommands

These subcommands allow you to access the attributes of the configurable entities in the Sun Java System Application Server.

 
get[ --monitor ]--user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]attributename[ attribute_name ]*
  • When using the wildcard character to get multiple attribute values while in single mode, enclose the attribute in double quotes. In multimode, DO NOT use the double quotes.

  • --monitor defaults to false. If set to false, the configurable attribute values are returned. If set to true, the monitorable attribute values are returned.

  • See the Sun Java System Application Server Administration Guide for a listing of the valid attribute names.

 
set[ --monitor ]--user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]attributename=value[ attribute_name=value ]*
  • Sets the values of one or more configurable attribute. The settings do not take affect until you run the reconfig subcommand.

 
reconfig --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
[ --discardmanualchanges=false ][ --keepmanualchanges=false ]instance_name
  • Applies the changes you have made for a server instance.

  • --discardmanualchanges defaults to false. When set to true, discards the changes made manually to the server.xml file.

  • --keepmanualchanges defaults to false. When set to true, allows the manual changes made to the server.xml file to take affect.

  • --discardmanualchanges=false is NOT equal to --keepmanualchanges=true. --discardmanualchanges=false is actually equal to not specifying the option. An error message is displayed if both options are set to false or not specified and a manual change has been made to the server.xml file.

  • Use this subcommand with discretion since there is no undo, and the changes applied are made directly to your server.xml file.

 
list[ --monitor ]--user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]element_name
  • Lists the configurable or monitorable elements (child nodes).

  • --monitor defaults to false. If set to false, the configurable attribute values are returned. If set to true, the monitorable attribute values are returned.

iMQ Administration Subcommands

These subcommands are used to administer the IMQ server of the Sun Java System Application Server.

 
create-jmsdest --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--desttype type[ --property (name=value)[ :name=value ]* ]dest_name
  • Valid values for the destination type include: topic and queue.

  • Valid values for destination name is the name of the JMS destination. Valid value is any name that can be a Java identifier.

  • The name/value property pairs are used to name JMS specific attributes to further customize the destination being created.

 
delete-jmsdest --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--desttype type dest_name
  • Valid values for the destination type include: topic and queue.

  • Valid values for destination name is the name of the JMS destination. Valid value is any name that can be a Java identifier.

  • Destroys the named destination.

 
list-jmsdest --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --desttype type ]instance_name
  • Valid values for the destination type include: topic and queue.

  • Lists the named JMS destinations.

 
jms-ping --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Checks to see if the JMS provider is up and running for the named instance.

Resource Administration Subcommands

The Resource Administration subcommands allow you to manage the various resources.

 
create-jdbc-connection-pool --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
[ --instance instance_name ]--datasourceclassname classname[ --restype res_type ]
[ --steadypoolsize 8 ][ --maxpoolsize 32 ][ --maxwait 6000 ][ --poolresize 2 ]
[ --idletimeout 300 ][ --isolationlevel isolation_level ][ --isisolationguaranteed=true ]
[ --isconnectvalidatereq=false ][ --validationmethod auto-commit ]
[ --validationtable table_name ][ --failconnection=false ][ --description text ]
[ --property (name=value)[ :name=value ]* ]connection_pool_ID
  • --datasourceclassname is the name of the vendor supplied JDBC datasource resource manager.

  • --restype must be specified to disambiguate when a datasource class implements both interfaces. An error is produced when this option has a legal value and the indicated interface is not implemented by the datasource class. This option does not have a default value.

  • --steadypoolsize is the minimum and initial number of connections maintained in the pool.

  • --maxpoolsize is the maximum number of connections that can be created.

  • --maxwait is the amount of time a caller will wait before a connection timeout is sent. The default is 60 seconds. A value of 0 forces the caller to wait indefinitely.

  • --poolresize is the number of connections to be removed when idletimeout timer expires. Connections that have idled for longer than the timeout are candidates for removal. When the pool size reaches steadypoolsize, the connection removal stops.

  • --idletimeout is the maximum time (in seconds) that a connection can remain idle in the pool. After this time, the implementation can close this connection. It is recommended that this timeout is kept shorter than the server side timeout to prevent the accumulation of unusable connections in the application.

  • --isolationlevel specifies the transaction-isolation-level on the pooled database connections. This option does not have a default value. If not specified, the pool operates with default isolation level provided by the JDBC driver. A desired isolation level can be set using one of the standard transaction isolation levels: read-uncommitted, read-committed, repeatable-read, serializable. Applications that change the isolation level on a pooled connection programmatically risk polluting the pool. This could lead to program errors.

  • --isisolationguaranteed is applicable only when a particular isolation level is specified for transaction-isolation-level. The default value is true. This assures that every time a connection is obtained from the pool, it is guaranteed to have the isolation set to the desired value. This could have some performance impact on some JDBC drivers. Set this option to false if you are certain that the application does not change the isolation level before returning the connection.

  • --isconnectvalidatereq if set to true connections are validated (checked to see if they are usable) before giving out the application. The default is false.

  • --validationmethod is the name of the validation table used to perform a query to validate a connection.

  • --validationtable is the name of the validation table used to perform a query to validate a connection. This parameter is mandatory if connection-validation-type is set to table. Verification by accessing a user specified table may become necessary for connection validation.

  • --failconnection if set to true, all connection in the pool must be closed if a single validation check fails; defaults to false. One attempt is made to re-establish failed connections.

  • --description is the text description of the JDBC connection pool.

  • --property is the optional attribute/value pairs for configuring the connection pool.

 
delete-jdbc-connection-pool --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ]
[ --secure|-s ][ --instance instance_name ]connection_pool_ID
  • Removes the JDBC connection pool from the named instance.

 
list-jdbc-connection-pools --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the JDBC connections pools for the named instance.

 
create-jdbc-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--connectionpoolid ID[ --enabled=true ][ --description text ]jndi_name
  • --connectionpoolid is the name of the JDBC connection pool. If two or more JDBC resource elements point to the same connection pool element, the same pool connections are used at runtime.

  • --enabled determines if the resource is enabled at runtime.

  • --description is the text description of the JDBC connection pool.

 
delete-jdbc-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]jndi_name
  • Removes the JDBC resource with the given JNDI name from the specified instance.

 
list-jdbc-resources --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the JDBC resources from the specified instance.

 
create-jms-resource --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--resourcetype type[ --enabled=true ][ --description text ]
[ --property (name=value)[ :name=value ]* ]jndi_name
  • --resourcetype is the JMS resource type which can be: javax.jms.Topic, javax.jms.Queue, javax.jms.TopicConnectionFactory, javax.jms.QueueConnectionFactory.

  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the JMS resource.

 
delete-jms-resource --user admin_user [ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]jndi_name
  • Removes the JMS resource with the given JNDI name from the specified instance.

 
list-jms-resources --user admin_user [ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --resourcetype type ]instance_name
  • Gets all the JMS resources for the named resource type from the specified instance.

  • --resourcetype is the JMS resource type which can be: javax.jms.Topic, javax.jms.Queue, javax.jms.TopicConnectionFactory, javax.jms.QueueConnectionFactory.

 
create-jndi-resource --user admin_user [ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]--jndilookupname lookup_name 
--resourcetype type--factoryclass class_name[ --enabled=true ][ --description text ]
[ --property (name=value)[ :name=value ]* ] jndi_name
  • --jndilookupname is the lookup name used by the external container.

  • --resourcetype is the JNDI resource type which can be: topic or queue.

  • --factoryclass is the class that creates the JNDI resource.

  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the JNDI resource.

 
delete-jndi-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]jndi_name
  • Removes the JNDI resource with the given JNDI name from the specified instance.

 
list-jndi-resources --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the JNDI resources from the specified instance.

 
create-javamail-resource --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
[ --instance instance_name ]--mailhost hostname--mailuser username
--fromaddress address[ --storeprotocol imap ][ --storeprotocolclass com.sun.mail.imapIMAPStore ]
[ --transprotocol=smtp ][ --transprotocolclass=com.sun.mail.smtp.SMTPTransport ]
[ --debug=false ][ --enabled=true ][ --description text ]
[ --property (name=value)[ :name=value ]* ] jndi_name
  • --debug if set to true, the server starts up in debug mode for this resource.

  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the JNDI resource.

 
delete-javamail-resource --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ]
[ --secure|-s ][ --instance instance_name ]--mailhost hostname--mailuser username
--fromaddress address[ --storeprotocol imap ][ --storeprotocolclass com.sun.mail.imap.IMAPStore ]
[ --transprotocol=smtp ][ --transprotocolclass=com.sun.mail.smtp.SMTPTransport ][ --debug=false ]
[ --enabled=true ] [ --description text ][ --property (name=value)[ :name=value ]* ]jndi_name
  • --debug if set to true, the server starts up in debug mode for this resource.

  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the JNDI resource.

 
list-javamail-resources --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the Javamail resources from the specified instance.

 
create-persistence-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
[ --jdbcjndiname jndi_name ][ --factoryclass classname ][ --enabled=true ]
[ --description text ][ --property (name=value)[ :name=value ]* ]jndi_name
  • --jdbcjndiname is the JDBC resource used to obtain the database connections. This must be the name of one of the pre-created JDBC resources.

  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the resource.

 
delete-persistence-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ] jndi_name
  • Removes the persistence resource with the given JNDI name from the specified instance.

 
list-persistence-resources --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
instance_name
  • Gets all the persistence resources from the specified instance.

 
create-custom-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename  ][ --secure|-s ][ --instance instance_name ]
--resourcetype type--factoryclass classname[ --enabled=true ]
[ --description text ][ --property (name=value)[ :name=value ]* ] jndi_name
  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the resource.

 
delete-custom-resource --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
jndi_name
  • Removes the custom resource with the given JNDI name from the specified instance.

 
list-custom-resources --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the custom resources from the specified instance.

 
add-resources --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
xml_file_path
  • Registers the named resource in the XML file identified.

  • The xml_file_path is the path to the XML file containing the resources to be registered.

IIOP Listeners Subcommands

The IIOP Listeners subcommands allow you to manage the listener resources.

 
create-iiop-listener --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--listeneraddress address[ -iiopport iiop_port ][ --enabled=true ]
[ --property (name=value)[ :name=value ]* ]listener_ID
  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the resource.

 
delete-iiop-listener --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
listener_ID
  • Removes the custom resource with the given IIOP listener from the specified instance.

 
list-iiop-listeners --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the IIOP listeners from the specified instance.

Lifecycle Module Subcommands

Lifecycle module subcommands enable you to run short or long duration Java-based tasks within the Application Server environment.

 
create-lifecycle-module --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--classname class_name[ --classpath classpath ][ --loadorder load_order ][ --failurefatal failure_fatal ]
[ --enabled=true ][ --property (name=value)[ :name=value ]* ]module_name
  • --loadorder is an integer value used to force the order in which deployed lifecycle modules are loaded at server startup. Smaller numbered modules get loaded sooner. The order is unspecified if two or more lifecycle modules have the same load-order value.

  • --failurefatal if true indicates abort server startup if the module does not load properly.

  • --enabled determines if the resource is enabled at runtime.

  • --property is the optional attribute/value pairs for configuring the resource.

 
delete-lifecycle-module --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
module_name
  • Removes the lifecycle module with the given module name from the specified instance.

 
list-lifecycle-modules --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the lifecycle modules from the specified instance.

MIME Subcommands

The server determines the MIME type of a requested resource by invoking the type-by-extension directive.

 
create-mime --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--mimefile filename mime_ID
  • --mimefile is the name of a MIME types file.

  • mime_ID is the internal name for the MIME types listing. It is used in a virtual server element to define the MIME types used by the virtual server.

 
delete-mime --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]mime_ID
  • Removes the MIME with the given MIME ID from the specified instance.

 
list-mimes --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]mime_ID
  • Gets all the MIMEs from the specified instance.

HTTP Listener Subcommands

The HTTP listener subcommands allow you to connect between the server and clients.

 
create-http-listener --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]--address address
[ --instance instance_name ]--listenerport listener_port --defaultvs virtual_server 
--servername server_name [ --family family ][ --acceptorthreads acceptor_threads ]
[ --blockingenabled blocking_enabled ][ --securityenabled security_enabled ]
[ --enabled=enabled ]listener_ID
  • --listenerport is the port number to create the listen socket on. Legal values are 165535. On UNIX, creating sockets that listen on ports 11024 requires superuser privileges. Configuring an SSL listen socket to list on port 443 is recommended.

  • --defaultvs is the ID attribute of the default virtual server for this particular connection group.

  • --servername identifies to the server what to put in the hostname section of any URLs sent to the client. This affects URLs the server automatically generates; it does not affect the URLs for directories and files stored in the server. If your server uses an alias, this name should be the alias name. If a colon and port number is appended, that port is used in URLs that the server sends to the client.

  • --family is the socket family type; defaults to inet. Legal values are: inet, inet6, and nca. Use the value inet6 for IPv6 listen sockets. When using the value of inet6, IPv4 addresses are prefixed with ::ffff: in the log file. Specify nca to make use of the Solaris Network Cache and Accelerator.

  • --acceptorthreads is the number of acceptor threads for the listen socket. The recommended value is the number of processors in the machine.

  • --blockingenabled determines whether the HTTP listener socket and the accepted socket are put into blocking mode. Use of blocking mode may improve benchmark scores.

  • --securityenabled determines whether the HTTP listener runs SSL. You can turn SSL2 or SSL3 ON or OFF and set ciphers using an SSL element. The security setting in the init.conf file globally enables or disables SSL by making certificates available to the server instance. Therefore, security in the init.conf file must be ON or security in the server.xml file does not work.

  • --enabled determines if the resource is enabled at runtime.

 
delete-http-listener --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
httplistener_ID
  • Removes the HTTP listener with the given HTTP listener ID from the specified instance.

 
list-http-listeners --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
httplistener_ID
  • Gets all the HTTP listeners from the specified instance.

HTTP QOS Subcommands

The HTTP quality of service subcommands allow you to define the quality of service parameters on the HTTP path.

 
create-http-qos --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --virtualserver virtual_server_ID ]
[ --bwlimit bwlimit ][ --enforcebwlimit=enforce_bw_limit ][ --connlimit connection_limit ]
[ --enforceconnlimit=enforce_conn_limit ]instance_name
  • --virtualserver is the virtual server ID. It can also be referred to as the variable $id in an obj.conf file. A virtual server ID cannot begin with a number.

  • --bwlimit is the maximum bandwidth limit, for the virtual server class or virtual server, in bytes per second. The default is no limit.

  • --enforcebwlimit determines whether the bandwidth limit should be enforced or not.

  • --connlimit is the maximum number of concurrent connections for the server, virtual server class, or virtual server.

  • --enforceconnlimit determines whether the connection limit should be enforced or not.

 
delete-http-qos --user admin_user[ --password admin_password ]
[ --host localhost ][ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
[ --virtualserver virtual_server_ID ]instance_name
  • Removes the HTTP QOS with the given virtual server ID from the specified instance.

Authorization Database Subcommands

The authorization database subcommands define the user database used by the virtual server.

 
create-authdb --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--database database--virtualserver virtualserver_ID[ --basedn basedn ]
[ --certmaps certmaps ]authdb_ID
  • --database is the user database name in the dbswitch.conf file.

  • --virtualserver is the virtual server ID. It can also be referred to as the variable $id in an obj.conf file. A virtual server ID cannot begin with a number.

  • --basedn overrides the base DN lookup in the dbswitch.conf file. However, the basedn value is still relative to the base DN value from the dbswitch.conf entry.

  • --certmaps is the certificate to LDAP entry mappings as defined in the certm.conf file. If not present, all mappings are used. All lookups are based on mappings in the certmap.conf file and are relative to the final base distinguished name (DN) of the virtual server.

  • authdb_ID is the user database name in the virtual server's ACL file.

 
delete-authdb --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--virtualserver virtualserver_ID authdb_ID
  • --virtualserver is the virtual server ID. It can also be referred to as the variable $id in an obj.conf file. A virtual server ID cannot begin with a number.

  • authdb_ID is the user database name in the virtual server's ACL file.

 
list-authdbs --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--virtualserver virtualserver_ID authdb_ID
  • --virtualserver is the virtual server ID. It can also be referred to as the variable $id in an obj.conf file. A virtual server ID cannot begin with a number.

  • authdb_ID is the user database name in the virtual server's ACL file.

Authorization Realm Subcommands

The authorization realm subcommands define the user realm used by the virtual server.

 
create-auth-realm --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--classname realm_class[ --property (name=value)[ :name=value ]* ]auth_realm_name
  • --classname is the Java class which implements this realm.

  • --property name/value pairs of provider implementation specific attributes.

 
delete-auth-realm --user admin_user[ --password admin_password ][ --host localhost ] 
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
auth_realm_name
  • Removes the authorization realm with the given authorization name from the specified instance.

 
list-auth-realms --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the authorization realms from the specified instance.

ACL Subcommands

The access control list subcommands allow you to manage and define the ACL file used by the virtual server.

 
create-acl --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--aclfile filename acl_ID
  • The ACL_ID is the internal name for the ACL file listing. This ID is used in a virtual server element to define the ACL file used by the virtual server.

 
delete-acl --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
acl_ID
  • Removes the ACL with the given ACL ID from the specified instance.

 
list-acls --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the ACLs from the specified instance.

Virtual Server Subcommands

Virtualization in the Application Server allows multiple URL domains to be served by the same HTTP server process which is listening on multiple host addresses. If the application is available at two virtual servers, they still share the same physical resource pools.

 
create-virtual-server --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--hosts hosts--mime mime_types_file[ --httplisteners http_listeners ]
[ --defaultwebmodule default_web_module ][ --configfile config_file ][ --defaultobj default_object ]
[ --state on ] [ --acls acls ][ --acceptlang=false ][ --logfile log_file ] 
[ --property (name=value)[ :name=value ]* ]virtual_server_ID
  • --hosts is a comma-separated list of values allowed in the host request header to select the current virtual server. Each virtual that is configured to the same connection group must have a unique hosts value for that group.

  • --mime is the ID of the mime element used by the vertual server.

  • --httplisteners is a comma-separated list of HTTP listener IDs. Required only for a virtual server that is not the default virtual server.

  • --defaultwebmodule is the standalone web module associated with the named virtual server.

  • Use the --configfile option to change the default virtual server initialization from $AS_instance_root/config/obj.conf to the named configuration file.

  • --defaultobj names the object loaded from an obj.conf file which is default. The default object is expected to have all the name translation directives for the virtual server. Any server behavior that is configured in the default object affects the entire virtual server class.

  • --state determines whether a virtual server is active (on) or inactive (off or disabled). Default is active (on). When inactive, the virtual server does not service requests.

  • --acls is a comma-separated list of ID attributes of ACL elements. Specifies the ACL files used by the virtual server.

  • --acceptlang when turned on, the server parses the Accept-Language header and sends an appropriate language version based on which language the client can accept. Set this value to ON only if the server supports multiple languages. The default setting is determined from the virtual-server-class.

  • --logfile name of the file where the log has to be written to.

 
delete-virtual-server --user admin_user[ --password admin_password  ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
virtual_server_ID
  • Deletes a virtual server with the given virtual server ID.

 
list-virtual-servers --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Lists all the virtual servers in the named instance.

Profiler Subcommands

 
create-profiler --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
--classpath classpath[ --nativelibpath native_library_path ][ --enabled=true ]
[ --property (name=value)[ :name=value ]* ]profiler_name
  • --classpath is the Java classpath string that specifies the classes needed by the profiler.

  • --nativelibpath is automatically constructed to be a concatenation of the Application Server installation relative path for its native shared libraries, standard JRE native library path, the shell environment setting (LD_LIBRARY_PATH on UNIX) and any path that may be specified in the profile element.

  • --property name/value pairs of provider specific attributes.

 
delete-profiler --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Deletes a profiler for the given instance.

 
list-profilers --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • Gets all the profilers in the given instance.

SSL Subcommands

The SSL subcommand allow you to manage the SSL elements in the HTTP listener or IIOP listener.

 
create-ssl --user admin_user[ --password admin_password ][ --host localhost ][ --port 4848 ]
[ --passwordfile filename ][ --secure|-s ]--type[ http-listener|iiop-listener|iiop-service ]
--certnamecert_name[ --instance instance_name ][ --ssl2enabled=false ]
[ --ssl2ciphers ssl_2_ciphers ][ --ssl3enabled=true ][ --ssl3tlsciphers ssl3_tls_ciphers ]
[ --tlsenabled=true ] [ --tlsrollbackenabled=true ][ --clientauthenabled=false ]
[ listener_id ]
  • --type is the type of service or listener that the SSL is created for. The type can be: http-listener, iiop-listener, and iiop-service.

  • --certname is the nickname of the server certificate in the certificate database or the PKCS#11 token. In the certificate, the name format is tokenname:nickname. Including the tokenname: part in this attribute is optional.

  • --ssl2enabled determines whether SSL2 is enabled.

  • --ssl2ciphers is a comma separated list of the SSL2 ciphers used. Use the prefix + to enable or to disable. Allowed values are: rc4, rc4export, rc2, rc2export, idea, des, desede3. If no value is specified, all supported ciphers are assumed to be enabled.

  • --ssl3enabled determines whether SSL3 is enabled.

  • --ssl3ciphers is a comma separated list of the SSL3 ciphers used. Use the prefix + to enable or to disable. Allowed values are: rsa_rc4_128_md5, rsa3des_sha, rsa_des_sha, rsa_rc4_40_md5, rsa_rc2_40_md5, rsa_null_md5. Allowed TSL values are: rsa_des_56_sha, rsa_rc4_56_sha. If no value is specified, all supported ciphers are assumed to be enabled.

  • --tlsenabled determines whether TLS is enabled.

  • --tlsrollbackenabled determines whether TLS rollback is enabled. TLS rollback should be enabled for Microsoft Internet Explorer 5.0 and 5.5.

  • --clientauthenabled determines whether SSL3 client authentication is performed on every request independent of ACL-based access control.

 
delete-ssl --user admin_user[ --password admin_password ] [ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
--type[ http-listener|iiop-listener|iiop-service ][ --instance instance_name ][ listener_id ]
  • --type is the type of service or listener that the SSL is created for. The type can be: http-listener, iiop-listener, and iiop-service.

JVM Options Subcommands

The JVM Options subcommands allow you to manage the options in the Java configuration or profiler elements of the server.xml file.

 
create-jvm-options --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
[ --profiler=false ](jvm_option_name=jvm_option_value)[:jvm_option_name=jvm_option_value]*
  • jvm_option_name=jvm_option_value is the JVM option name and the JVM option value associated with it. You can enter more than one JVM option separated by a colon (:) . If the JVM option starts with a dash (-) then use two dashes () before the operand to distinguish that JVM option is an operand and not an option.

  • --profiler indicates if the JVM options are for the profiler. The profiler must exist for this option to be true.

  • JVM options are used to record the settings needed to get a particular profiler going.

 
delete-jvm-options --user admin_user [ --password admin_password ][ --host localhost ]
[ --port4848 ][ --secure|-s ][ --instance instance_name ] [ --profiler=false ]
 (jvm_option_name=jvm_option_value)[:jvm_option_name=jvm_option_name]* 
  • Deletes the JVM options from the Java configuration or profiler elements.

  • You can enter more than one JVM option separated by a colon (:). If the JVM option starts with a dash (-) then use two dashes () before the operand to distinguish that JVM option is an operand and not an option.

License Subcommands

 
install-license
  • This subcommand can be run locally only.

  • Displays the license agreement allowing you to accept/reject the license terms.

 
display-license[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
  • This subcommand can be run both locally and remotely.

  • Displays the license terms currently in effect.

File User Subcommands

 
create-file-user --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
[ --userpassword user_password ][ --groups user_groups[ :user_groups ]* ]user_name
  • --userpassword is the password for the file user.

  • --groups is the group that the file user belongs to.

  • user_name is the name of the file user to be created.

  • You can enter more than one user group separated by a colon (:).

 
delete-file-user --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]user_name
  • Deletes the named file user associated with the specified instance.

 
update-file-user --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --instance instance_name ]
[ --userpassword user_password ][ --groups user_groups[ :user_groups ]* ]user_name
  • --userpassword is the password for the file user.

  • --groups is the group that the file user belongs to.

  • user_name is the name of the file user to be updated.

  • You can enter more than one user group separated by a colon (:). If the user group starts with a dash (-) then use two dashes () before the operand to distinguish that group option is an operand and not an option.

 
list-file-users --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]instance_name
  • List all the file users associated with the named instance.

 
list-file-groups --user admin_user[ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ][ --name user_name ]instance_name
  • List all the file groups associated with the named instance.

  • --name is the name of the file user.

System Subcommands

 
shutdown[ --user admin_user ][ --password admin_password ][ --host localhost ]
[ --port 4848 ][ --passwordfile filename ][ --secure|-s ]
  • Gracefully shuts down the administration server, all its domains, and all the running instances.

 
version[ --user admin_user ] [ --password admin_password  ] [ --host localhost ]
[ --port 4848 ][ --local=false ][ --verbose=false ][ --passwordfile filename ][ --secure|-s ]
  • displays the version information for the Sun Java System Application Server and the Command-line interface.

 
help [ subcommand ]
  • displays the syntax for the named subcommand. If the subcommand is not specified displays the syntax of all the Command-line interface subcommands.

ATTRIBUTES

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPEATTRIBUTE VALUE
Interface StabilityUnstable

SEE ALSO

appclient(1as),package-appclient(1as)


Sun Java System Application ServerGo To TopLast Changed 29 Dec 2003