C H A P T E R  21

Configuring Internet Protocol (IPv6)

This chapter describes how to configure Internet Protocol (IPv6).

This chapter contains the following topics:


Understanding PPv6

IPv6 is the next generation of the Internet Protocol. With 128-bit addresses, versus 32-bit addresses for IPv4, IPv6 solves the address depletion issues seen with IPv4 and removes the requirement for Network Address Translation (NATs) which is used in IPv4 networks to reduce the number of globally unique IP addresses required for a given network. Its aggregate addresses can dramatically reduce the size of the global routing table through well known address combinations. Security is more integrated and network configuration is simplified yet more flexible.

There are many conceptual similarities between IPv4 and IPv6 network operation. Addresses still have a network prefix portion (subnet) and a device interface specific portion (host). While the length of the network portion is still variable, most users have standardized on using a network prefix length of 64 bits. This leaves 64 bits for the interface specific portion, called an Interface ID in IPv6. Depending upon the underlying link addressing, the Interface ID can be automatically computed from the link, e.g. MAC address. Such an automatically computed Interface ID is called an EUI64 identifier.

IPv6 packets on the network are of an entirely different format than traditional IPv4 packets and are also encapsulated in a different Ethertype (contained within the L2 header to indicate which L3 protocol is used). In order to route these packets across L3 requires an infrastructure equivalent to and parallel to that provided for IPv4.


Using IPv6 Configurations

In FASTPATH, IPv6 will coexist with IPv4. As with IPv4, IPv6 routing can be enabled on physical and VLAN interfaces. Each L3 routing interface can be used for IPv4, IPv6 or both. Routing protocols, such as OSPF, are capable of computing routes for either IP version or both concurrently.

Neighbor discovery is the IPv6 replacement for Address Resolution Protocol (ARP). Router advertisement is part of the neighbor discovery process and is required for IPv6. Stateless auto configuration is part of router advertisement and FASTPATH can support both stateless and stateful auto configuration of end nodes. FASTPATH supports both EUI-64 interface identifiers and manually configured interface IDs.

While optional in IPv4, router advertisement is mandatory in IPv6. Router advertisements specify the network prefix(es) on a link which can be used by receiving hosts, in conjunction with an EUI64 identifier, to auto configure a host’s address. Routers have their network prefixes configured and may use EUI64 or manually configured interface IDs. In addition to one or more global addresses, each IPv6 interface also has an auto-configured link-local address which is:

Next hop addresses computed by routing protocols are usually link-local.

During a transition period, a global IPv6 Internet backbone may not be available. The solution of this is to tunnel IPv6 packets inside IPv4 to reach remote IPv6 islands. When a packet is sent over such a link, it is encapsulated in IPv4 in order to traverse an IPv4 network and has the IPv4 headers removed at the other end of the tunnel.


Configuring IPv6 via CLI

In IPv6 Example, two devices are connected as shown in the diagram. Interface 0/1 on both devices connects to an IPv4 backbone network where OSPF is used as the dynamic routing protocol to exchange IPv4 routes. OSPF allows device 1 and device 2 to learn routes to each other (from the 20.20.20.x network to the 10.10.10.x network and vice versa). Interface 0/2 on both devices connects to the local IPv6 network. OSPFv3 is used to exchange IPv6 routes between the two devices. The tunnel interface allows data to be transported between the two remote IPv6 networks over the IPv4 network.

FIGURE 21-1 IPv6 Example


 


CODE EXAMPLE 21-1 Device 1
ip routing
ipv6 unicast-routing
router ospf
router-id 1.1.1.1
exit
ipv6 router ospf
router-id 1.1.1.1
exit
interface 0/1
routing
ip address 20.20.20.1 255.255.255.0
ip ospf
exit
interface 0/2
routing
ipv6 enable
ipv6 address 2020:1::1/64
ipv6 ospf
ipv6 ospf network point-to-point
exit
interface tunnel 0
ipv6 address 2001::1/64
tunnel mode ipv6ip
tunnel source 20.20.20.1
tunnel destination 10.10.10.1
ipv6 ospf
ipv6 ospf network point-to-point
exit
interface loopback 0
ip address 1.1.1.1 255.255.255.0
exit
exit


CODE EXAMPLE 21-2 Device 2
ip routing
ipv6 unicast-routing
router ospf
router-id 2.2.2.2
exit
ipv6 router ospf
router-id 2.2.2.2
exit
interface 0/1
routing
ip address 10.10.10.1 255.255.255.0
ip ospf
exit
interface 0/2
routing
ipv6 enable
ipv6 address 2020:2::2/64
ipv6 ospf
ipv6 ospf network point-to-point
exit
interface tunnel 0
ipv6 address 2001::2/64
tunnel mode ipv6ip
tunnel source 10.10.10.1
tunnel destination 20.20.20.1
ipv6 ospf
ipv6 ospf network point-to-point
exit
interface loopback 0
ip address 2.2.2.2 255.255.255.0
exit
exit