前へ     目次     索引     DocHome     次へ     
iPlanet Messaging and Collaboration スキーマリファレンスマニュアル



第 3 章   属性


この章では、iPlanet Messaging and Collaboration 製品の LDAP オブジェクトクラスに必須の、または使用可能な属性について説明します。属性は、アルファベット順に並べてあります。



属性のリスト



この章では、iPlanet Messaging and Collaboration 製品に関連する次の属性について説明します。



属性



adminRole


初出
iPlanet Messaging Server 5.0


構文
cis


オブジェクトクラス
inetAdmin


定義
この管理者エントリについての管理者の役割を指定します。


例


OID
2.16.840.1.113730.3.1.601



businessCategory


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
groupOfUniqueNames


定義
このエントリが関わるビジネスのタイプを識別します。これは、会社の部レベルのように大まかな一般化された値にする必要があります。


例
businessCategory = Engineering


OID
2.5.4.15



calCalURI


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson


定義
ユーザのデフォルトカレンダー全体への URI を含みます。詳細は、RFC 2739 を参照してください。


例
実装された iPlanet Calendar Server のバージョンに応じて変化します。詳細は、RFC 2739 を参照してください。


OID
1.2.840.113556.1.4.478



calFBURL


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson


定義
ユーザのデフォルトのビジータイムデータへの URL。詳細は、RFC 2739 を参照してください。


例
実装された iPlanet Calendar Server のバージョンに応じて変化します。詳細は、RFC 2739 を参照してください。


OID
1.2.840.113556.1.4.479



cn


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued


オブジェクトクラス
icsCalendarResource, icsCalendarUser, inetResource


定義
ユーザの場合、その人の氏名。リソースの場合、一意の識別子。どちらの場合も、スペースと特殊文字を含んでいてもかまいません。これは、commonName の省略形です。


例
ユーザの場合 : cn = John Doeリソースの場合 : cn = Conference Room #3

または

commonName = John Doe、commonName = Conference Room #3


OID
2.5.4.3



co


初出
LDAP


構文
cis


オブジェクトクラス
pabPerson


定義
2 文字のコードを使用した国名を含みます。これは、countryName の省略形です。

friendlyCountryName 属性は、実際の国名を略さずに書くために使用されます。


例
co = IE

または

countryName = IE

friendlyCountryName = Ireland


OID
2.5.4.4



commonName (「cn」を参照)



countryName (「co」を参照)



dataSource


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser, inetMailGroup


定義
タグまたは識別子を格納するためのテキストフィールド。この値が操作に影響を与えることはありません。


例
dataSource=1.0


OID
2.16.840.1.113730.3.1.779



dateOfBirth


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson


定義
pabPerson の誕生日。フォーマットは、YYYYMMDD です。


例
dateOfBirth=19740404
(1974 年 4 月 6 日の誕生日)


OID
2.16.840.1.113730.3.1.779



dc


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomainAlias


定義
ドメインエイリアスエントリのドメインコンポーネント


例
ドメインエイリアスエントリの DN が dc=sesta、dc=fr、o=internet の場合、dc の値は sesta です。


OID
0.9.2342.19200300.100.1.25



description


初出
LDAP


構文
cis


オブジェクトクラス
groupOfUniqueNames, inetManagedGroup, pab, pabGroup


定義
人が読むことが可能なオブジェクト記述。対象が人または組織で、役割や仕事の割り当てが含まれることがよくあります。


例
description = Quality control inspector


OID
2.5.4.13



domainUidSeparator


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomainAuthInfo


定義
この属性は、デフォルトのメールボックス (MB) のホームをオーバライドするために、メッセージングサーバによって使用されます。この属性が存在する場合は、複合したユーザ ID (UID) がこのドメイン内で使用されることを示します。また、この属性で区切り文字を指定します。たとえば、+ が区切り文字の場合、このドメインのメールボックス名は、uid の右端の + を @ で置き換えて取得されます。内部のメールボックス名を UID に対応付ける場合は、メールボックス名内の右端の @ が + で置き換えられます。

UID 区切り文字の @ の置換はメールボックス名を生成するには十分ですが、これはユーザの実際の電子メールアドレスと同じでない場合があります。



注

内部メールボックス名のフォーマットは uid@domain で、この「domain」は、ネームスペースへの DNS ドメインのマッピングです。この規則に対する唯一の例外は、デフォルトドメイン内のユーザ用のメールボックス名です。ここでは、内部メールボックス名を作成するために uid だけが使用されます。使用されるドメイン名のデフォルト値が特定のケースでどのようにしてオーバライドされるかについては、「inetCanonicalDomainName」を参照してください。




例
domainUIDSeparator=#


OID
2.16.840.1.113730.3.1.702



domOrgMaxUsers


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomainOrg


定義
ドメイン組織内のユーザエントリの最大数


例
domOrgMaxUser=500


OID
2.16.840.1.113730.3.1.697



domOrgNumUsers


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomainOrg


定義
ドメイン組織内の現在のユーザエントリ数


例
domOrgNumUsers=345


OID
2.16.840.1.113730.3.1.698



facsimileTelephoneNumber


初出
iPlanet Calendar Server 5.1


構文
tel、single-valued


オブジェクトクラス
icsCalendarResource, inetResource


定義
リソースのファックス番号


例
1-800-555-1212


OID
2.5.4.23



givenName


初出
LDAP


構文
cis


オブジェクトクラス
icsCalendarUser


定義
このエントリの名 (given name) を指定します。通常は人のファーストネームになります。


例
givenName = John


OID
2.5.4.42



icsAlias


初出
iPlanet Calendar Server 5.1


構文
cis、UTF8 エンコード


オブジェクトクラス
icsCalendarResource


定義
リソースに関連付けられたエイリアス。エイリアスによりエンドユーザが簡単にリソース名を扱うことができます。


例
「halleyscomet」という名前のリソースは、「Halley's Comet」というエイリアスを作ることができます。

icsAlias = Halley's Comet


OID
2.16.840.1.113730.3.1.725



icsCalendar


初出
iPlanet Calendar Server 5.1


構文
ces、single-valued


オブジェクトクラス
icsCalendarResource, icsCalendarUser


定義
ユーザまたはリソースのためのデフォルトのカレンダー


例
icsCalendar = jdoe


OID
2.16.840.1.113730.3.1.731



icsCapacity


初出
iPlanet Calendar Server 5.1


構文
int、single-valued


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.800



icsContact


初出
iPlanet Calendar Server 5.1


構文
cis、UTF8 エンコード


オブジェクトクラス
icsCalendarResource


定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.733



icsDefaultAccess


初出
iPlanet Calendar Server 5.1


構文
cis


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.734



icsDefaultSet


初出
iPlanet Calendar Server 5.1


構文
ces、single-valued


オブジェクトクラス
icsCalendarUser


定義
ログイン時にどのカレンダーを表示するかについてのユーザ設定。ユーザは、ログイン時に表示されるカレンダーを、単一のカレンダーでなく任意のカレンダーセット (作成したカレンダーのグループ) で指定することができます。


例
icsDefaultSet=MyCalendarGroup


OID
2.16.840.1.113730.3.1.735



icsExtended


初出
iPlanet Calendar Server 5,0


構文
cis


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.738



icsExtendedResourcePrefs


初出
iPlanet Calendar Server 5.1


構文
cis


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.741



icsExtendedUserPrefs


初出
iPlanet Calendar Server 5.1


構文
cis、multi-valued


オブジェクトクラス
icsCalendarUser


定義
カレンダーのユーザ設定についての拡張。次に示すのは、属性とその値です。

属性

値

定義

ceAllCalendarTZIDS

ceClock

12, 24

12 時間形式または 24 時間形式のどちらを使用するかを定義します。

ceColorSet

pref_group1
pref_group2
pref_group3
pref_group4
pref_group7

5 つの UI カラースキーマのどれを使用するかを定義します。

ceDateOrder

M/D/Y
D
/M/Y
Y
/M/D

日付の 3 つの要素 (月 (M)、日 (D)、年 (Y)) が表示される順序を指定します。

ceDateSeparator

印刷可能な単一の文字。たとえば、/ または -

表示される日付の要素 (M、D、Y) を区切るために使用される単一の文字です。

たとえば、日付は「12/22/2002」のように表示できます。

ceDayHead

0 - 23

カレンダー情報の表示の開始時刻 (1 日 24 時間のうちの 1 つで表示)

ceDayTail

0 - 23

カレンダー情報の表示の終了時刻 (1 日 24 時間のうちの 1 つで表示)

cdDefaultAgenda

cdDefaultAlarmEmail

空白スペースで区切られた電子メールアドレス

イベントアラームの送信先の電子メールアドレス

ceDefaultAlarmStart

P[unit count][unit type]

イベントアラームが送信されるまでの時間。unit count は任意の数値で、unit type は「M (分)」、「H (時)」、または「D (日)」のどれかにします。

例 : P10M

ceDefaultTZID

ISO 8601 のタイムゾーンの 1 つ

タイムゾーンの一覧は、「ISO 8601 タイムゾーン」を参照

カレンダーにタイムゾーンが割り当てられない場合に使用するタイムゾーン

ceDefaultView

dayview
weekview
monthview
yearview
groupview

ログイン時に表示されるビュー

このパラメータが存在しないと、デフォルトとして overview が使用されます。

(「groupview」は、ユーザインタフェースの「比較ビュー」です)

ceFontFace

次の値のうちの 1 つ
1) Times New Roman、Times、serif
2) Courier New、Courier、noon
3) PrimaSans BT、Verdana、sans-serif

ユーザインタフェースで使用するフォントの種類を 3 つの中から選択できます。

ceFontSizeDelta

pref_font_size_group_2 (標準)
pref_font_size_group_1 (大)
pref_font_size_group_3 (小)

ユーザインタフェースに 3 つのフォントサイズを定義します。インタフェース内では次のように定義されます。
normal、larger、smaller

ceInterval

PT0H15M
PT0H30M
PT1H0M
PT2H0M
PT4H0M

カレンダー情報の表示に使用される時間間隔を定義します。
時間間隔は、15 分、30 分、1 時間、2 時間、4 時間です。

ceNotifyEmail

RFC 822 の有効な電子メールアドレス

カレンダーがイベントへの出席依頼を受信したときに通知がメールされる電子メースアドレス。

ceNotifyEnable

0, 1

カレンダーがイベントへの出席依頼を受信したときに、電子メールで通知を送信します、または送信しません。
0 = 通知を送信しない
1 = 通知を送信する

ceSingleCalendarTZID

ISO 8601 の有効なタイムゾーン
ISO 8601 タイムゾーンの一覧は、「ISO 8601 タイムゾーン」を参照

このカレンダーに割り当てるタイムゾーンのリスト
このパラメータが指定されないと、デフォルトのタイムゾーンが使用されます。

例 : America/Los_Angeles

ceToolImage

0, 1

ユーザインタフェースで、ツールバー上にアイコンを表示するかどうかを切り替えます。
0 = アイコンを表示しない
1 = アイコンを表示する (デフォルト)

ceToolText

0, 1

ユーザインタフェースで、ツールバー上にアイコンテキストを表示するかどうかを切り替えます。
0 = アイコンにテキストを表示しない
1 = アイコンにテキストを表示する (デフォルト)



注

ceToolImage および ceToolText に関して、ユーザインタフェースでは、ツールバーに対する選択肢は 3 つしかありません。アイコンとテキストの両方を表示するか (属性値は 1、1)、アイコンだけを表示するか (属性値は 1、0)、またはテキストだけを表示するか (属性値は 0、1) です。アイコンとテキストの両方を表示しないようにする (属性値が 0、0) ことは、ユーザに許可されていません。




例
icsextendeduserprefs= ceClock=12

icsextendeduserprefs= ceColorSet=pref_group_1

icsextendeduserprefs= ceDateOrder=D/M/Y

icsextendeduserprefs= cdDateSeparator=/

icsextendeduserprefs= ceDayHead=10

icsextendeduserprefs= ceDayTail=17

icsextendeduserprefs= ceDefaultAlarmEmail=jdoe@sesta.com

icsextendeduserprefs= ceDefaultAlarmStart=P30H

icsextendeduserprefs= cdDefaultTZID=America/New_York

icsextendeduserprefs= ceDefaultView=groupview

icsextendeduserprefs= ceFontFace=PrimaSans BT,Verdana,sans-serif

icsextendeduserprefs= ceFontSizeDelta=pref_font_size_group_3

icsextendeduserprefs= ceInterval=PT2H0M

icsextendeduserprefs= ceNotifyEmail=jdoe@sesta.com

icsextendeduserprefs= ceNotifyEnable=0

icsextendeduserprefs= ceSingleCalendarTZID=America/Los_Angeles

icsextendeduserprefs= ceToolText=1

icsextendeduserprefs= ceToolImage=1


OID
2.16.840.1.113730.3.1.742



icsFirstDay


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued


オブジェクトクラス
icsCalendarUser


定義
ユーザのカレンダーに表示される週の最初の日

値の範囲 : 1-7、1 = 日、2 = 月、3= 火、4 = 水、 5 = 木、6 = 金、7 = 土


例
icsFirstDay = 1


OID
2.16.840.1.113730.3.1.743



icsFreeBusy


初出
iPlanet Calendar Server 5.1


構文
ces、single-valued


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.744



icsGeo


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued

緯度、経度


オブジェクトクラス

定義
予約済、実装されていません。


例
このクラスは RFC 仕様に準拠するためにだけ存在し、使用されていません。


OID
2.16.840.1.113730.3.1.745



icsPartition


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued


オブジェクトクラス

定義
予約済、実装されていません。


例

OID


icsPreferredHost


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.749



icsQuota


初出
iPlanet Calendar Server 5.1


構文
int、single-valued


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.748



icsSet


初出
iPlanet Calendar Server 5.1


構文
cis、multi-valued


オブジェクトクラス
icsAnonymousSet, icsCalendarUser, icsDefaultAnonymousSet


定義
カレンダーの 1 グループを定義します。さまざまな作業用にエンドユーザがこのようなグループを作成します。各グループは 1 つの icsSet 属性で表されます。つまり、ユーザが作成するグループごとに、1 つの icsSet 属性があります。たとえば、ユーザが 3 つのグループを定義すると、3 つの icsSet 属性ができます。

この属性の値は 6 つの部分に分かれた文字列で、各部分はドル記号 ($) で区切ります。

この属性の 6 つの各部の値は次のとおりです。

name

必須

このグループの表示名

calendars

必須

このグループを形成するカレンダーのカレンダー ID (calid) をセミコロンで区切ったリスト

tzmode

必須

「default」、「inherit」、「specify」の 3 つの値が可能です。この値で、このグループのタイムゾーンが何に由来しているかを示します。

default = ユーザのデフォルトのタイムゾーンから
inherit = グループ内の最初のカレンダーから
specify = 次の「tz」の値から

tz

「tzmode = specify」以外は不要

このグループ用の ISO 8601 タイムゾーン。受入可能な値の一覧は、「ISO 8601 タイムゾーン」を参照してください。「tzmode = specify」が指定されていれば必須ですが、それ以外のときはオプションです。

mergeInDayView

必須

論理値 (TRUE/FALSE)。この値で、このグループを「日別」に表示するか (TRUE)、「比較ビュー」に表示するか (FALSE) を示します。

description

オプション

文字列。カレンダーの説明で、オプションです。


例
この属性の値は 1 行に収まるはずですが、複数行にわたる場合は、1 個のスペースまたはタブで次の行を始めます。

icsSet = name = GroupName$ calendars = calid1;
calid2; calid3$tzmode = specify$tz = America/
Los_Angeles$mergeInDayView = FALSE$description
= Example group of calendars.


OID
2.16.840.1.113730.3.1.753



icsStatus


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued


オブジェクトクラス

定義
予約済、実装されていません。


例

OID
2.16.840.1.113730.3.1.755



icsSubscribed


初出
iPlanet Calendar Server 5.1


構文
ces、multi-valued


オブジェクトクラス
icsCalendarUser


定義
このユーザが購読しているカレンダー ID のリスト

この属性の値はカレンダー ID であり、オプションで、ドル記号 ($) で区切られてカレンダー名が続きます。


例
icsSubscribed=jdoe$MyHomeCalendar
icsSubscribed=jsmith


OID
2.16.840.1.113730.3.1.756



icsTimezone


初出
iPlanet Calendar Server 5.1


構文
cis


オブジェクトクラス
icsCalendarResource, icsCalendarUser


定義
このユーザ、リソース、またはドメインのデフォルトのタイムゾーン。詳細は、「オブジェクトの識別子」にあるリストの ISO 8601 タイムゾーンを参照してください。


例
icsTimezone = America/Chicago


OID
2.16.840.1.113730.3.1.757



inetCanonicalDomainName


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomainAuthInfo


定義
この属性は完全指定ドメイン名であり、複数の DC ノードが同じ組織サブツリーを参照する場合に使用されます。この属性が指定されない場合、標準ドメイン名は、DC ノードで表される名前と同じです。たとえば、dc=france,dc=sesta,dc=com,o=internet ノードエントリに inetCanonicalDomainName がない場合、標準ドメイン名は france.sesta.com であるとみなされます。ただし、inetDomainBaseDN 属性を使用して前述の DC ノードとして同じ組織ノードを指し示す DC ノードが複数ある場合は、inetCanonicalDomainName を同じ値に設定する必要があります。


例
inetCanonicalDomainName= france.sesta.com


OID
2.16.840.1.113730.3.1.701



inetCOS


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
ipUser


定義
(組織ツリードメイン) ユーザエントリ内の属性に値を与える COS (サービスクラス) テンプレートの名前を指定します。COS テンプレートの RDN が、この属性の値です。テンプレートから与えられる属性値とそれらをオーバライドする規則は、COS 定義内に指定されています。COS 定義は、オブジェクトクラスの cosDefinition を使用して作成されます。COS 定義のエントリ内にある cosSpecifier 属性の値が inetCOS に設定されます。そのドメインのサブツリー内にある ou=COS コンテナに、COS 定義とテンプレートを作成します。詳細は、『iPlanet Messaging Server プロビジョニングガイド』を参照してください。


例
inetCos=HallofFame


OID
2.16.840.1.113730.3.1.706



inetDomainBaseDN


初出
iPlanet Messaging Server 5.0


構文
dn、single-valued


オブジェクトクラス
inetDomain


定義
すべてのユーザおよびグループのエントリが格納される、カスタマの組織サブツリーの DN (DC ツリー)。この属性は必須であり、有効な組織サブツリーの DN を示す必要があります。Messaging Server のコンポーネントは、ホスト組織に対応するユーザエントリおよびグループエントリを検索するために、この DN を解決する必要があります。


例
inetDomainBaseDN=o=sesta.com,o=siroe-isp.com


OID
2.16.840.1.113730.3.1.690



inetDomainCertMap


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetDomainAuthInfo


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.700



inetDomainSearchFilter


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomainAuthInfo


定義
inetDomainBaseDN に指定されたサブツリー内でユーザを検索するときに使用する LDAP 検索フィルタ。ドメイン内のログイン名を LDAP エントリにマップするために、認証中に使用されます。フィルタの作成に次の変数を使用することができます。

  • %U - ログイン名の名前の部分 (サーバの構成上で格納されている、ログイン区切り文字より前の全ての部分)

  • %V - ログイン文字列のドメイン部分

この属性を指定しない場合は、uid=%U と等価になります。uid=john_siroe.com などの複合 uid でユーザが規定されるネームスペースでは、uid=%U_%V の検索フィルタが使用されます。ここで、john はユーザ ID、siroe.com はドメインです。これによって、ログイン文字列の john@siroe.com (@ はサービスのログイン区切り文字) が、siroe.com のエントリのネームスペースのサービスによって、検索要求にマップされます。ここでは、uid=john_siroe.com となります。この属性を使用する別の例として、社員を社員ID に基づいてログインするサイトが挙げられます。ユーザエントリ内の empID 属性に社員 ID が格納されていると想定すると、検索フィルタは empID=%U になります。

この属性によって、inetDomainBaseDN サブツリー内で完全に一致した有効ユーザが返されます。この属性が設定されていない場合は、uid 属性が inetDomainBaseDN サブツリー内で一意である必要があります。


例
inetDomainSearchFilter=uid=%U


OID
2.16.840.1.113730.3.1.699



inetDomainStatus


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetDomain


定義
ドメインのグローバルステータスを指定します。この属性の目的は、管理者が、ドメインとドメインで有効なすべてのサービスに、ドメイン内のすべてのユーザが一時的にアクセスできないようにして、後に再びアクセスできるようにすることです。または、アクセスを永久に削除することです。この属性は、3 つの値のうちの 1 つをとります。サポートされる値は、次のとおりです。

active

ドメインはアクティブであり、ドメイン内のユーザは、サービス特有のオブジェクトクラスのオーバーレイ、およびそのサービス特有のステータス属性に示されたサービス状態によって、有効にされたサービスを使用することができます。

inactive

ドメインはアクティブでありません。アカウントは、サービス特有のオブジェクトクラスにより許可されたいずれのサービスも使用できない場合があります。この状態は、サービスのステータス属性を使用して設定された個々のサービスステータスをオーバライドします。

deleted

ドメインは削除済みとマークされます。アカウントは、ディレクトリ内でこの状態にしばらくとどまります (削除されたユーザのパージは保留されます)。削除済みとマークが付けられたドメイン内のすべてのユーザが要求するサービスに対して、永続的な失敗が返されます。

値がないと、ステータスは active とみなされます。不正な値はすべて、inactive とみなされます。

メールサービスが確認する 4 つのステータス属性があり、inetDomainStatus、mailDomainStatus、inetUserStatus、mailUserStatus の順に評価されます。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。

同様に、この属性はステータスを評価するときのカレンダーサービスにも使用されます。使用されるステータス属性は、inetDomainStatus、(icsCalendarDomain の) icsStatus、および inetResourceStatus または inetUserStatus のどちらか、さらに (icsCalendarResource または icsCalendarUser の) icsStatus となります。


例
inetDomainStatus=active


OID
2.16.840.1.113730.3.1.691



inetMailGroupStatus


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroup


定義
メールグループの現在のステータスであり、active、inactive、または deleted です。ステータスが active の場合、メーリングリストのメンバーにメッセージが配信されます。ステータスが inactive では、メーリングリストへ送信されたメッセージが一時的に失敗になります。deleted ステータスは、メーリングリストがディレクトリからパージされる可能性があることを意味します。このグループにメッセージが送信されると、永続的に失敗のメッセージが返されます。値がないと、ステータスは active とみなされます。不正な値はすべて、inactive とみなされます。

3 つのステータス属性 inetDomainStatus、mailDomainStatus、および inetMailGroupStatus は、相互に作用します。これらの属性は、ここに挙げた順に評価されます。最初に active であるステータスが、ほかのステータスの設定に優先します。


例
inetMailGroupStatus=active


OID
2.16.840.1.113730.3.1.786



inetResourceStatus


初出
iPlanet Calendar Server 5.1


構文
cis、single-valued


オブジェクトクラス
inetResource


定義
「active」、「Inactive」、または「deleted」のどれかの値の、現在のリソースステータス

ステータスを決定するために評価されるいくつかのステータス属性があります。これらの属性は、inetDomainStatus、icsStatus (icsCalendarDomain の場合)、inetResourceStatus、icsStatus (icsCalendarResource の場合) の順に評価されます。これらの属性は、ここに挙げた順に評価されます。最初に active であるステータスが、ほかのステータスの設定に優先します。


例
inetResourceStatus = active


OID
2.16.840.1.113730.3.1.758



inetSubscriberAccountId


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetSubscriber


定義
課金の目的で使用される一意のアカウント ID


例
inetSubscriberAccountId=A3560B0


OID
2.16.840.1.113730.3.1.694



inetSubscriberChallenge


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetSubscriber


定義
サブスクライバを識別するために使用されるチャレンジフレーズを格納するための属性。inetSubscriberResponse とともに使用されます。


例
inetSubscriberChallenge=Mother's Maiden Name


OID
2.16.840.1.113730.3.1.695



inetSubscriberResponse


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetSubscriber


定義
チャレンジフレーズへの応答を格納するための属性。


例
inetSubscriberResponse=Mamasita


OID
2.16.840.1.113730.3.1.696



inetUserHttpURL


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetUser


定義
Web コンテンツを公開するための、ユーザのプライマリ URL。これは情報を示す属性であり、電話帳タイプのアプリケーションで使用することができます。操作に影響を与えるものではありません。


例
inetUserHttpURL=http://www.siroe.com/theotis


OID
2.16.840.1.113730.3.1.693



inetUserStatus


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetUser


定義
ユーザアカウントのステータスをグローバルサーバのアクセスに関連して指定します。管理者は、この属性で指定したユーザアカウントによって、指定したユーザのすべてのサービスへのアクセスを一時的に中断、再起動したり、または永続的に削除したりすることができます。この属性は、次の 3 つの値のうちの 1 つをとります。

active

ユーザアカウントはアクティブであり、ユーザは、サービス特有のオブジェクトクラスのオーバーレイ、およびそのサービスのための特定のステータス属性に示されたサービス状態によって、有効にされたサービスをすべて使用することができます。たとえば、mailUserStatus と inetDomainStatus の両方が active に設定されていると、ユーザは電子メールシステムを使用することができます。

inactive

ユーザのアカウントはアクティブではありません。アカウントは、サービス特有のオブジェクトクラスに保証されたどのサービスも使用することができません。この状態は、サービスのステータス属性を使用して設定された個々のサービスステータスに優先します。

deleted

アカウントは削除済みとマークされます。アカウントは、ディレクトリ内でこの状態のまましばらくとどまります (削除されたユーザのパージは保留されます)。削除済みとマークが付けられたユーザが要求するサービスに対して、永続的な失敗が返されます。

値がないと、ステータスは active とみなされます。不正な値はすべて、inactive とみなされます。

メールサービスが確認する 4 つのステータス属性があり、inetDomainStatus、mailDomainStatus、inetUserStatus、mailUserStatus の順に評価されます。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。

カレンダーサービスの場合、評価される属性は、inetDomainStatus、icsStatus (icsCalendarDomain の場合)、inetUserStatus、icsStatus (icsCalendarUser の場合) です。


例
inetUserStatus=inactive


OID
2.16.840.1.113730.3.1.692



mail


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetLocalMailRecipient, icsCalendarResource, icsCalendarUser


定義
ユーザのプライマリ電子メールアドレスを識別します (ホワイトページ (個人別電話帳) 検索アプリケーションによって取り出され、表示される電子メールアドレス)。


例
mail=jdoe@sesta.com


OID
0.9.2342.19200300.100.1.3



mailAccessProxyPreAuth


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
このドメイン内のユーザを事前に認証しなければならない場合、この属性によってMMP に伝えます。指定できる値は、yes または no です。


例
mailAccessProxyPreAuth=yes


OID
2.16.840.1.113730.3.1.769



mailAccessProxyReplay


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
この属性によって、バックエンドのメールサーバを使用してログインシーケンスに応答する際の、ログイン文字列の再構成方法を Messaging Multiplexor (MMP) に伝えます。この属性を指定しないと、メッセージアクセスプロキシは、クライアントに使用されるログイン名、クライアントのドメイン、およびこのサービスで使用されるログイン区切り文字に基づいて、応答文字列を構成します。メッセージアクセスプロキシが iPlanet Messaging and Collaboration 以外の異なるバックエンドサーバを使用している場合は、このデフォルトの動作を、mailAccessProxyReplay 属性でオーバライドします。

構文はログイン文字列の構文であり、次のように置き換えられます。

  • %U: ログイン名。つまり、{name,domain} を複合している場合のログイン文字列の名前部分

  • %V: ログイン文字列のドメイン部分

  • %[attr]: LDAP ユーザ属性の値


例
  1. クライアントが hugo としてログインし、使用されるサーバの IP アドレスに関連するドメインが yoyo.com で、しかも mailAccessProxyReplay=%U@%V が指定されている場合、応答されるログイン文字列は hugo@yoyo.com になります。

  2. クライアントが hugo としてログインし、使用されるサーバの IP アドレスに関連するドメインが yoyo.com で、さらに mailAccessProxyReplay=%[surname]@%V が指定されている場合、応答されるログイン文字列は、クライアントの surname 属性の値になります。

  3. クライアントが hugo+yoyo.com としてログインし、使用されるサービス用のログイン区切り文字が + で、さらに mailAccessProxyReplay=%U@%V が指定されている場合、応答されるログイン文字列は hugo@yoyo.com になります。

  4. クライアントが hugo としてログインし、使用されるサーバの IP アドレスに関連するドメインが yoyo.com のときに mailAccessProxyReplay が指定されておらず、しかも使用されるサービス用のログイン区切り文字が + の場合、応答されるログイン文字列は hugo+yoyo.com になります。


OID
2.16.840.1.113730.3.1.763



mailAdminRole


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailAdministrator


定義
グループのメンバーに割り当てられる管理ロールを指定します。この属性のための唯一の有効な値は、storeAdmin です。この属性 (inetMailAdministrator) を含むオブジェクトクラスは、グループのメンバーにメールサーバ部分への管理権限を与えるために、グループエントリでオーバーレイされます。現在のところ、グループのメンバーが継承する唯一の権限は、ドメイン内のどのユーザに対してもプロキシ認証を実行する権限です。このような権限は、グループが定義されているドメインと同じドメイン内のユーザに拡張されます。このような権限の許可には、mailAdminRole を storeAdmin の値に設定する必要があります。


例
mailAdminRole=storeAdmin


OID
2.16.840.1.113730.3.1.780



mailAllowedServiceAccess


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
アクセスフィルタを格納します。フィルタを指定しないと、ユーザはすべてのクライアントからすべてのサービスにアクセスできます。フィルタ規則は $ で区切られ、ユーザが要求したサービスへのアクセス権を与えられる許可フィルタ、またはサービスへのアクセスが拒否される拒否フィルタのどちらかが検出されなければ、順番に評価されます。フィルタのフォーマットは、次のとおりです。

"+|-" <daemon_list>":"<client_list>.

daemon_list は、アクセスが許可または拒否されるサービスを、カンマで区切りで列挙します。

有効なサービス名は、imap、imaps、pop、pops、smtp、smtps、 および http です。

アクセスフィルタの構文およびその例については、『iPlanet Messaging Server 管理者ガイド』の「POP、IMAP、および HTTP サービスへのクライアントアクセスを設定する」を参照してください。http://docs.iplanet.com/docs/manuals/messaging/ims50/ag/security.htm#13295


例
mailAllowedServiceAccess=+imap, pop, http:*


OID
2.16.840.1.113730.3.1.777



mailAlternateAddress


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetLocalMailRecipient, pabPerson


定義
この受取人のその他の RFC 822 電子メールアドレス。キャッチオールアドレスとしてユーザおよびグループを示すため、アドレスのローカル部分を省略することができます。キャッチオールドメインアドレスは、MTA が指定されたドメインで正確に一致するユーザアドレスを検出できない場合に、そのドメインに対してメールを受信するアドレスです。あらゆるユーザについてバニティドメイン (「ライトウェイトドメイン」ともいう) を示すために、msgVanityDomainUser を使用することによってユーザのプライマリドメインをオーバライドする方法の詳細を参照してください。


例
mailAlternateAddress=thief@florizel.com


OID
2.16.840.1.113730.3.1.13



mailAutoReplyMode


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
ユーザのメールアカウントに自動返信モードを指定します。有効な値は、次のとおりです。

  • echo - mailAutoReplyText または mailAutoReplyTextInternal を追加して、元のメッセージを送信者に返します (エコーします)。

  • reply - mailAutoReplyText または mailAutoReplyTextInternal 属性に入っている固定応答を送信者に送ります。


例
mailAutoReplyMode=echo


OID
2.16.840.1.113730.3.1.14



mailAutoReplySubject


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
自動返信の件名のテキスト。$SUBJECT を使用して、元のメッセージの件名を応答に挿入することができます。


例
mailAutoreplySubject=I am on vacation


OID
2.16.840.1.113730.3.1.772



mailAutoReplyText


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
受取人のドメイン内のユーザを除くすべての送信者に送信する自動返信のテキスト。指定しないと、外部ユーザは自動応答を受信しません。


例
mailAutoreplyText=Please contact me later.


OID
2.16.840.1.113730.3.1.15



mailAutoReplyTextInternal


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
受取人のドメインから送信者に送られる自動返信のテキスト。指定しなければ、内部ユーザがメールの自動返信テキストのメッセージを受け取ります。


例
mailAutoreplyTextInternal=Please contact me later.


OID
2.16.840.1.113730.3.1.773



mailAutoReplyTimeOut


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
inetMailUser


定義
任意の差出人への自動返信の応答に成功するまでの時間間隔 (時間単位)。mailAutoReplyMode=reply の場合にだけ、使用します。値が 0 の場合は、メッセージ受信のたびに応答が送り返されます。元のメッセージの「to」または「Cc:」に受取人がリストされた場合のみ、自動返信の応答が送信されます。


例
mailAutoreplyTimeout=48


OID
2.16.840.1.113730.3.1.771



mailClientAttachmentQuota


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
mailDomain


定義
このドメイン内で Messenger Express ユーザが 1 メッセージにつき送信できる添付ファイルの数を示す、正の整数値。値が -1 の場合、添付ファイルの数に制限はありません。


例
mailClientAttachmentQuota=12


OID
2.16.840.1.113730.3.1.768



mailConversionTag


初出
iPlanet Messaging Server 5,2


構文
cis、multi-valued (ASCII 文字列)


オブジェクトクラス
inetMailGroup, inetMailUser


定義
このユーザまたはグループへのメッセージに添付される変換タグ。タグ特有の変換動作は、MTA 構成内で指定されます。この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例

OID


mailDeferProcessing


初出
iPlanet Messaging Server 5,2


構文
cis、single-valued (ASCII 文字列)


オブジェクトクラス
inetMailGroup, inetMailUser


定義
現在のユーザエントリまたはグループエントリのアドレス拡張がただちに実行されるか (値は「No」)、またはあとで実行するか (値は「Yes」) を制御します。値が「Yes」で、しかも現在のソースチャネルが再処理チャネルでない場合は、延期されます。延期は、ユーザまたはグループのアドレスを再処理チャネルに指定することで実行されます。つまり、エイリアスの拡張は中止され、元のアドレス (user@domain) が再処理チャネルのキューに入れられます。

ユーザのデフォルトは、即時に処理することです (値は「No」)。メーリングリストなどのグループのデフォルトは、1 (yes) です。DEFER_GROUP_PROCESSING MTA オプションによって制御されています。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例
mailDeferProcessing=No


OID
TBD



mailDeliveryFileURL


初出
iPlanet Messaging Server 5.0


構文
ces、single-valued


オブジェクトクラス
inetMailGroup


定義
メーリングリストに送信されたすべてのメッセージに付加される、ファイルの完全指定ローカルパス。mailDeliveryOption=file とともに使用されます。


例
mailDeliveryFileURL=/home/dreamteam/mail_archive


OID
2.16.840.1.113730.3.1.787



mailDeliveryOption


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroup, inetMailUser


定義
メール受取人の配信オプションを指定します。インバウンドメッセージの複数の配信経路をサポートするために、ユーザエントリ、およびグループエントリに、複数の値を指定できます。この属性が使用されるオブジェクトクラスが inetMailGroup か、または inetMailUser かによって、値の適用のされ方が異なります。有効な値は、次のとおりです。

inetMailUser:

  • autoreply - autoreply の指定は、ユーザにより定まります。受取人がメッセージの「To:」または「Cc:」ヘッダーフィールドにリストされているメッセージは、自動返信チャネルに送られ、そこで、自動返信メッセージが生成され、元の送信者へ返信されます。

  • forward - メッセージが転送されるように指定します。転送先のアドレスは、mailForwardingAddress 属性に指定されています。

  • hold - 受取人は、メッセージの受信を一時的に中止します。

  • mailbox - ユーザの IMA/POP ストアにメッセージを配信します。

  • native - ユーザの /var/mail ストアである INBOX にメッセージを配信します。このストアは、バークレー版のメールボックスのフォーマットになっています。

inetMailGroup:

  • file - mailDeliveryFileURL 属性で指定されたファイルにメッセージが付加されます。

  • members - メッセージがメーリングリストのメンバーに送信されます。指定がない場合、デフォルトである members とみなされます。

inetMailUser と inetMailGroup に共通 :

  • program - MTA の構成で指定されたプログラム承認リストにあるプログラムへ、メッセージが配信されます。プログラムの名前は、mailProgramdeliveryInfo 属性に指定されます。


例
mailDeliveryOption=mailbox


OID
2.16.840.1.113730.3.1.16



mailDomainAllowedServiceAccess


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
アクセスフィルタを格納します。フィルタが指定されないと、ドメイン内のユーザは、すべてのクライアントからすべてのサービスにアクセスすることできます。フィルタ規則は $ で区切られ、ユーザが要求したサービスへのアクセス権を与えられる許可フィルタ、またはサービスへのアクセスが拒否される拒否フィルタのどちらかがなければ、順番に評価されます。フィルタのフォーマットは、次のとおりです。

"+|-" <daemon_list>":"<client_list>.

daemon_list は、アクセスが許可または拒否されるサービスを、カンマで区切りで列挙します。有効なサービス名は、imap、imaps、pop、pops、smtp、smtps、および http です。


例
mailDomainAllowedServiceAccess=+imap, pop, http:*


OID
2.16.840.1.113730.3.1.764



mailDomainCatchallAddress


初出
iPlanet Messaging Server 5,2


構文
cis、single-valued (RFC 822 メールボックス)


オブジェクトクラス
mailDomain


定義
ドメイン内のどのユーザまたはグループとも一致しないアドレスを置き換えるアドレスを指定します。


例

OID
TBD



mailDomainConversionTag


初出
iPlanet Messaging Server 5,2


構文
cis、multi-valued (ASCII 文字列)


オブジェクトクラス
mailDomain


定義
ドメイン内の任意のユーザへのメッセージに添付する 1 つ以上の変換タグ。タグ特有の変換動作は、MTA 構成内で指定されます。この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例

OID
TBD



mailDomainMsgMaxBlocks


初出
iPlanet Messaging Server 5,2


構文
int、single-valued


オブジェクトクラス
mailDomain


定義
このドメイン内のアドレスに送信されるすべてのメッセージのサイズを、MTA ブロック単位で制限します。この制限は、このドメインからユーザが送信するメッセージには適用されません。

この属性の値は、mailMsgMaxBlocks の値が設定されている場合はその値でオーバライドされます。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例

OID
TBD



mailDomainMsgQuota


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
mailDomain


定義
このドメイン内のすべてのユーザに許可されるメッセージの割り当て数。これは割り当て容量レポートツールで使用されるもので、ドメイン全体の割り当ての制限を強制するものではありません。


例
mailDomainMsgQuota=2000000


OID
2.16.840.1.113730.3.1.767



mailDomainReportAddress


初出
iPlanet Messaging Server 5,2


構文
cis、single-valued (RFC 822 メールボックス)


オブジェクトクラス
mailDomain


定義
この値は、ドメイン内の受取人アドレスに関連する問題を報告するために、DSN 内の「From:」アドレスヘッダーとして使用されます。また、ローカル以外のアドレスに関連するエラーについて、ドメイン内のユーザに問題を報告するときにも使用されます。

この属性が設定されない場合、報告アドレスは、デフォルトの「postmaster@domain」になります。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例

OID
TBD



mailDomainSieveRuleSource


初出
iPlanet Messaging Server 5,2


構文
cis、single-valued (RFC 3028 sieve フィルタ)


オブジェクトクラス
mailDomain


定義
ドメイン内のすべてのユーザの sieve フィルタ。


例

OID
TBD



mailDomainStatus


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
メールドメインの現在のステータス。active、inactive、deleted、または hold の、どれかの値をとります。この属性は、メールサービスドメインのステータスです。値がないと、ステータスは active とみなされます。不正な値は、inactive とみなされます。

active

このドメイン内のすべてのユーザと、「active」とマークされたドメイン内のすべてのユーザに対し、メールサービスが「active」とマークされます (詳細は、「inetUserStatus」および「mailUserStatus」を参照)。ただし、「mailAllowedServiceAccess」および「mailDomainAllowedServiceAccess」に指定された制限は引き続き適用されます。

inactive

ドメイン内のすべてのユーザに対し、メールサービスが「inactive」とマークされます。ログインしようとしたすべてのユーザは拒否され、ユーザに送信されたメッセージは、一時的な失敗になります。

deleted

メイルドメインが「deleted」とマークされ、猶予期間が経過した後のパージユーティリティによるクリーンアップ中に削除されます。メールボックスとユーザのメールサービスのオブジェクトクラスは、クリーンアップに含まれます。

hold

ドメイン内のすべてのユーザに送信されたメッセージは、ホールドチャネルへリダイレクトされます。移動中に送信者へメッセージを戻す必要がないようにして、ドメイン内のユーザがあるサーバから別のサーバへ移動する際に、通常この値が使用されます。このステータスでは、すべての受信メッセージがホールドチャネルに送られるので、メッセージを失うおそれがなく、メールボックスを移動することができます。移動が終了するとステータスは「hold」から「active」に変更され、メッセージは、ホールドチャネルから取り除かれ、ユーザのメールボックスが新しく存在する MTA に送信されます。

メールサービスが確認する 4 つのステータス属性があり、inetDomainStatus、mailDomainStatus、inetUserStatus、mailUserStatus の順に評価されます。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。


例
mailDomainStatus=active


OID
2.16.840.1.113730.3.1.770



mailDomainWelcomeMessage


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
このドメインに追加された新規ユーザに送信されるようこそメッセージ。「$」は、キャリッジリターンを示す記号です。この属性の BNF 構文は、次のとおりです。

value:: <subjectline>ユ$ユ[<opt_headers>]ユ$$ユ<body>
subjectline:: ユSubject:ユ[<TEXT>]
opt_headers::<header_line>ユ$ユ[<opt_headers>]
header_line:: <header_name>ユ:ユ<TEXT>
header_name:: <TEXT>
body:: [<lines>]
lines:: <line>ユ$ユ[<lines>]
line:: <TEXT>


例
mailDomainWelcomeMessage=Subject: Welcome!!$X-Endorsement: We're good. $$Welcome to the mail system.


OID
2.16.840.1.113730.3.1.765



mailEquivalentAddress


初出
iPlanet Messaging Server 5,2


構文
cis、multi-valued (RFC 822 アドレス仕様)


オブジェクトクラス
inetMailGroup, inetMailUser


定義
メールのルーティングに関しては mailAlternateAddress と同じですが、この属性では、アドレスがヘッダーでプライマリメールアドレスに書き直されません。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例

OID
TBD



mailForwardingAddress


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailUser


定義
この属性には、インバウンドメッセージのための 1 つ以上の転送アドレスが格納されます。アドレスは、RFC-822 のフォーマットで指定します。mailDeliveryOption=forward が設定されていると、メッセージはリストに載っているアドレスに転送されます。


例
mailForwardingAddress=kokomo@sesta.com


OID
2.16.840.1.113730.3.1.17



mailHost


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetLocalMailRecipient


定義
この受取人に送信されたメッセージの最終的な宛先を示す、MTA の完全指定ホスト名。


例
mailHost=mail.siroe.com


OID
2.16.840.1.113730.3.1.18



mailMessageStore


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
ユーザのメッセージストアパーティション名を指定します。パーティション名と、ストアのファイルシステムの位置とのマッピングは、メッセージストア構成に保存されます。指定しないと、サーバ構成に指定されたデフォルトのストアパーティションが使用されます。


例
mailMessageStore=secondary


OID
2.16.840.1.113730.3.1.19



mailMsgMaxBlocks


初出
iPlanet Messaging Server 5,2


構文
int、single-valued


オブジェクトクラス
inetMailGroup, inetMailUser


定義
このユーザまたはグループに送信可能なメッセージの最大サイズを MTA ブロック単位で示します。この制限は、ユーザが送信するメッセージには適用されません。

この属性が設定されている場合、mailDomainMsgMaxBlocks の値はオーバライドされます。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例

OID
TBD



mailMsgQuota


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
inetMailUser


定義
ユーザに許可される最大メッセージ数は、mailMsgQuota で設定されます。この属性は、ストア内にあるすべてのフォルダの累積値です。0 の値、または何も指定しなかった場合は、システムのデフォルトの割り当てが適用され、-1 を指定した場合は、メッセージ数に制限を受けません。mailMsgQuota を有効にするには、サーバを構成する際に割り当ての制限を設ける必要があります。ソフトとハード両方の割り当てを設定することができます。詳細は、『iPlanet Message Server 管理ガイド』を参照してください。


例
mailMsgQuota=2000


OID
2.16.840.1.113730.3.1.774



mailProgramDeliveryInfo


初出
iPlanet Messaging Server 5.0


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup, inetMailUser


定義
プログラムの配信に使用される 1 つ以上のプログラムを指定します。指定されるプログラムは、メッセージングサーバが該当ドメインで実行することを許可した承認リストに入っている必要があります。属性の値で、プログラムへの参照を指定します。その参照は、プログラムの承認リストから解釈されます。解釈された参照から、プログラムのパラメータと実行権も提供されます。mailDeliveryOption=program とともに使用されます。プログラムの承認プロセスについては、http://docs.iplanet.com/docs/manuals/messaging/ims50/ag/users.htm#13443 に説明があります。


例
mailProgramDeliveryInfo=procmail


OID
2.16.840.1.113730.3.1.20



mailQuota


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
inetMailUser, mailDomain


定義
ユーザのメールボックスに割り当てるディスク容量をバイト数で指定します。0 の値、または何も指定しなかった場合は、システムのデフォルトの割当が適用され、-1 を指定した場合は、使用容量に制限を受けません。システムのデフォルトは、サーバ構成パラメータの store.defaultmailboxquota に指定されています。この構成パラメータに割当を設定し、store.quotaenforcement をオンに設定すると、メッセージストアに割り当ての制限が適用されます。


例
mailQuota=5000000


OID
2.16.840.1.113730.3.1.21



mailRejectText


初出


構文
ces、multi-valued


オブジェクトクラス


定義
この属性の最初の値に格納された最初の行が保存されます。任意の認証属性が原因でメッセージが拒否された場合、このテキストが返されます。このテキストは SMTP の応答に現われる可能性があるので、メッセージング標準に準拠するために、指定する値は US-ASCII 文字に限定されます。


例

OID
TBD



mailRoutingAddress


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetLocalMailRecipient


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.24



mailRoutingHosts


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
mailDomain


定義
このドメイン内のユーザ、および他のドメイン内に含まれているすべてのユーザのルーティングを決定する MTA の、完全指定ホスト名。この属性を指定しないと、すべての MTA がこのドメイン内や他のドメイン内に含まれるユーザ、およびグループのメッセージのルーティングを決定するものとみなされます。


例
mailRoutingHosts=mail.siroe.com


OID
2.16.840.1.113730.3.1.759



mailRoutingSmartHost


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
ローカルディレクトリ内で検出されないユーザのメール処理を実行するメールサーバの、完全指定ホスト名。メッセージングサーバのディレクトリ内にないユーザへ送信されたメッセージは、この属性で指定されたメールサーバへ転送されます。この属性は、あるメールシステムから別のメールシステムへの移行処理が行われ、すべてのユーザがまだメッセージングサーバのディレクトリに移動していないときに便利です。属性が指定されていない場合や値が空だった場合は、ドメイン内のユーザへのすべてのメッセージのルーティングと配信を、ローカルの MTA が実行します。


例
mailRoutingSmartHost=mail.siroe.com


OID
2.16.840.1.113730.3.1.760



mailSieveRuleSource


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailUser


定義
iPlanet Delegated Administrator for Messaging には、この属性を変更するためのインタフェースが用意されています。ただし、iPlanet Delegated Administrator for Messaging を使用しないで SIEVE 規則を追加した場合は、そのユーザ用の SIEVE 規則を作成 / 変更するために続けて使用すると、不安定な SIEVE 規則ができる可能性があります。

この属性の値には、2 つの可能な形式があります。1 つは、RFC 3028 に準拠した完全な sieve スクリプトを含んだ単一の値であり、もう 1 つは、それぞれが sieve スクリプトの断片を含んだ (RFC 3028 に準拠していない) 複数の値です。後者の形式は、Web フィルタ作成インタフェースによって作成されます。それぞれの値を順番に並べて適切につなげるための特別なコードが使用されます。

SIEVE スクリプトの構文は、http://docs.iplanet.com/docs/sieve にあるインターネットドラフトの『Sieve: A Mail filtering Language』に指定されています。

スクリプトの形式は、次のとおりです。

require ["fileinto", "reject"];
# $Rule Info: Order=(1-infinity, or 0 for disabled) Template=(template-name) Name=(rule name)
if header :is "Sender" "owner-ietf-mta-filters@imc.org"
{ fileinto "filter"; # move to "filter" folder }
if header :is "Subject" "SPAM!"
{ delete }


複数の値 (multi-valued) がある形式

ユーザごとに複数の Sieve スクリプトを LDAP に格納することができます。ユーザのすべての規則を含む 1 つの大きなスクリプトでなく、いくつかのより小さな規則スクリプトをユーザインタフェースが取り扱えるようにするために、この属性は複数の値 (つまり、複数の規則) をとります 。サーバは、mailSieveRuleSource 内のすべての規則を調べます。

順序の指定と情報の編集が可能なユーザインタフェースを提供するために、各規則内にオプションの Sieve コメント行があります。この行の形式は、次のとおりです。

# $Rule Info: Order=(1-infinity, or 0 for disabled) Template=(template-name) Name=(rule name)

Order フィールドだけがメッセージングサーバに使用されます。その他のフィールドが、ユーザインタフェースに役立つ可能性のあるフィールドのマーカーとして追加されます。Rule Info 行のあるすべての規則は、メッセージングサーバに最初に処理されます。Order=0 の場合、Sieve の評価にこの規則は使用されません。それ以外の場合、規則は提供された順に処理されます (1 が最優先)。Rule Info の拡張機能を使用して入力されなかった可能性のある Sieve 規則を適用するために、対応する順序の値ですべての規則が処理された後に、検出されたほかの規則が LDAP から受け取った順にサーバによって実行されます。


例
mailSieveRuleSource:
require ["fileinto", "reject", "redirect", "discard]
if header :contains "Subject" "New Rules Suggestion
    {redirect "rules@sesta.com" # Forward message }
if header :contains "Sender" "porn.com"
    {discard text:
Your message has been rejected.Please remove this address from your mailing list. # Reject message, send reply message.}
if size :over 1M
    { reject text:
Please do not send me large attachments.
Put your file on a server and send me the URL.
Thank you. # Discard message, send reply message.}
if header :contains "Sender" "barkley@sesta.com
    { fileinto complaints.refs # File message}


OID
2.16.840.1.113730.3.1.775



mailSMTPSubmitChannel


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
通常、この属性は、保証付きメッセージ配信の設定、またはその他の特別なサービスクラスの設定に関連する要因となります。定義する際に、SMTP の AUTH が成功した場合、この属性によって名前が付けられたチャネルを有効な送信チャネルとみなすように MTA に知らせることです。


例
mailSMTPSubmitChannel=tcp_tas

OID

2.16.840.1.113730.3.1.776



mailUserStatus


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailUser


定義
次のメールユーザステータスのいずれか 1 つを格納します。値がないと、ステータスは inactive とみなされます。

active

正常な状態。inetUserStatus もアクティブな場合、メールは、mailDeliveryOption や mailSieveRuleSource などのほかのユーザ属性に格納された値どおりに処理されます。active に設定されていない場合は、inetUserStatus のステータスが優先します。考慮すべきほかのステータス属性は、inetDomainStatus および mailDomainStatus です。inetDomainStatus と mailDomainStatus の組み合わせでメール配信とドメインへのアクセスが許可されている場合は、inetUserStatus および mailUserStatus からユーザのステータスが決定されます。

inactive

ユーザのメールアカウントはアクティブでありません。送信側の MTA へ一時的な失敗が返されます。

deleted

ユーザのメールアカウントが「deleted」とマークされます。送信側の MTA へ永続的な失敗が返され、ユーザメールアカウントがパージユーティリティによるクリーンアップの候補になります。メールボックスへのユーザのアクセスは拒否されます。

hold

ユーザのメールは保留キューに送信され、IMAP、POP、および HTTP 経由のメールボックスへのアクセスが許可されなくなります。ストアサーバ上の MTA と Message Access Server は、この要件に従う必要があります。

値がないと、ステータスは active として扱われます。不正な値はすべて、inactive として扱われます。

メールサービスが確認する 4 つのステータス属性があり、inetDomainStatus、mailDomainStatus、inetUserStatus、mailUserStatus の順に評価されます。これらの属性のうちで active 以外に設定された最初の属性が、ほかのすべての属性に優先します。


例
mailUserStatus=active


OID
2.16.840.1.113730.3.1.778



maxPabEntries


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
ipUser


定義
ユーザが個人アドレスブックのストア内に入れることのできるエントリの最大数を指定します。値が -1 の場合は、エントリ数に制限はありません。この属性が存在しない場合は、個人アドレスブックの構成で指定されたシステムのデフォルトが使用されます。


例
maxPabEntries=1000


OID
2.16.840.1.113730.3.1.705



memberOf


初出
iPlanet Messaging Server 5.0


構文
DN、multi-valued


オブジェクトクラス
inetAdmin, inetUser


定義
ユーザが所属するメーリングリストの DN を指定します。バックポインタとしてグループのメンバーシップを示します。


例
memberOf=cn=Administrators,ou=groups o=sesta.com,o=siroe-isp.com


OID
1.2.840.113556.1.2.102



memberOfManagedGroup


初出
iPlanet Messaging Server 5.0


構文
DN、single-valued


オブジェクトクラス
ipUser


定義
このユーザがメンバーであるファミリーアカウントの DN を指定します。


例
memberOfManagedGroup=cn=Addams Family, ou=groups,o=sesta.com,o=isp


OID
2.16.840.1.113730.3.1.704



memberOfPAB


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
pabPerson, pabGroup


定義
このエントリが属する個人アドレスブックの一意名 (un)。


例
abab=addressbook122FA7


OID
2.16.840.1.113730.3.1.718



memberOfPABGroup


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
pabPerson


定義
このユーザが属する個人グループの一意名。


例
memberOfPabGroup=testgroup15577F2D


OID
2.16.840.1.113730.3.1.719



memberURL


初出
NMS


構文
ces、multi-valued


オブジェクトクラス


定義
URL のリストであり、エクスパンドすると、メーリングリストのメンバーのアドレスが一覧表示されます。


例
memberURL=ldap://cn=jdoes, o=sesta.com


OID
2.16.840.1.113730.3.1.198



mgmanAllowSubscribe


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroupManagement


定義
このメーリングリストへの加入を許可されたユーザのドメイン名または電子メールアドレス。


例
mgmanAllowSubscribe=sestsa.com (sesta.com のすべてのユーザがリストに加入できる)


OID
2.16.840.1.113730.3.1.790



mgmanDenySubscribe


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroupManagement


定義
このメーリングリストへの加入を拒否されたユーザのドメイン名または電子メールアドレス。mgmanDenySubscribe 属性は、mgmanAllowSubscribe 属性に優先します。


例
mgmanDenySubscribe=siroe.com


OID
2.16.840.1.113730.3.1.791



mgmanGoodbyeText


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.797



mgmanHidden


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義
グループの所有者以外の人々から要求されたリスト内にグループを表示する必要があるかないかを指定する、論理型のフラグ。値が true の場合は、グループは隠されます。つまり、リストは表示されません。値が false の場合は、リストが表示されます。値がない場合は、false の値と同じです。


例
mgmanHidden=true


OID
2.16.840.1.113730.3.1.792



mgmanIntroText


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.796



mgmanJoinability


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義
グループに加入できるユーザを指定します。指定できる値は、ANYONE、ALL、および NONE です。この属性が指定されない場合のデフォルトは、NONE です。

  • ANYONE - 誰でも加入できます。

  • ALL - ディレクトリまたは iPlanet Delegated Administrator for Messaging に認証された任意のユーザが加入できます。

  • NONE - 所有者だけが非公開の配布リストにメンバーを追加できます。


例
mgmanJoinability=All


OID
2.16.840.1.113730.3.1.793



mgmanMemberVisibility


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義
グループのメンバーシップリストを表示する (グループをエクスパンドする) 権利を持つユーザを定義します。mgmanJoinability 属性と同様に、この属性も、none、all、true、anyone というキーワード値があります。この属性にどのような値を設定しても、グループの所有者は常に、メンバーシップを表示および変更する権利を保持しています。

この属性は、SMTP の EXPN コマンドの一部として、グループをエクスパンドする際にチェックされます。

anyone

誰でもグループをエクスパンドして、メーリングリスト内のメンバーを表示することができます。また、EXPN コマンドが実行されると、MTA がメンバーのアドレスを返します。

all または true

エクスパンションが許可される前に、ディレクトリまたは iPlanet Delegated Aministrator for Messaging へのアクセスが認証される必要があります。

none

グループの所有者だけがグループをエクスパンドできます。

認識不能な値は、none と解釈されます。


例
mgmanMemberVisibility=all


OID
2.16.840.1.113730.3.1.795



mgmanVisibility


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義

例

OID
2.16.840.1.113730.3.1.794



mgrpAddHeader


初出
NMS


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup


定義
各属性値で、メッセージヘッダーが存在する場合にヘッダーに追加するヘッダーフィールドを指定します。

MTA の場合、この属性の値はヘッダーの値です。この属性のこの値は、ヘッダートリミングの ADD オプションを設定するために使用されます。


例
mgrpAddHeader=Reply-To: thisgroup@sesta.com


OID
2.16.840.1.113730.3.1.781



mgrpAllowedBroadcaster


初出
iPlanet Messaging Server 5.0


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup


定義
メッセージをメールグループに送信することを許可されたメールユーザを識別します。Messaging Server では、この属性に識別名、あるいは LDAP URI または mailto アドレスを使用する RFC822address のどちらかが入っていることを想定しています (例を参照)。識別名が使用される場合は、group または groupOfUniqueNames タイプのメール可能なエントリ (複数も可) を表している必要があります。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedDomain および mgrpDisallowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザの制限はありません。

複数の値を使用する場合は、各 URL がアドレスのリストにエクスパンドされ、各アドレスは、現在のエンベロープの送信元のアドレスに対照してチェックされます。一致した場合は、そのメッセージが許可されます。


例
Example 1=mgrpAllowedBroadcaster: ldap://uid=bjensen, o=siroe.com Example 2=mgrpAllowedBroadcaster: mailto:sys50@siroe.com


OID
2.16.840.1.113730.3.1.22



mgrpAllowedDomain


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroup


定義
ユーザがそこからメッセージをメールグループに送信することを許可されるドメイン (サブドメインも含む) を識別します。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedBroadcaster、mgrpDisallowedBroadcaster、および mgrpDisallowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザの制限はありません。


例
mgrpAllowedDomain=siroe.com

この例では、*.siroe.com から送信するすべてのユーザに一致します。


OID
2.16.840.1.113730.3.1.23



mgrpAuthPassword


初出
iPlanet Messaging Server 5.0


構文
ces、single-valued


オブジェクトクラス
inetMailGroup


定義
(メーリング) リストに投稿するために必要なパスワードを指定します。mgrpBroadcasterPolicy 属性がパスワードを要求するように設定されている場合は、この属性の値が保存されます。ヘッダーが利用可能になると、「承認済み :」フィールドに対照してこの値がチェックされます。チェックが終了すると、ヘッダーから「承認済み :」フィールドが削除されます。


例


OID
2.16.840.1.113730.3.1.783



mgrpBroadcasterPolicy


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroup


定義
許可されるブロードキャスタを決定するためのポリシー。ブロードキャスタのアドレスのリストにアクセスするために必要な、認証のレベルを指定します。指定できる値は、次のとおりです。

  • AUTH_REQ, SMTP_AUTH_REQUIRED

    リストに投稿するために、送信者は SMTP の AUTH コマンドを使用して認証される必要があります。

  • PASSWORD_REQUIRED, PASSWD_REQUIRED, PASSWD_REQ

    すべての値は、mgrpAuthPassword 属性によって指定されたブロードキャスタリストへのパスワードが、メッセージ内の「承認済み :」ヘッダーフィールドになければならないことを示しています。

  • NO_REQUIREMENTS

    この値は、特殊な要件が適用されないことを示しています。


例
mgrpBroadcasterPolicy=AUTH_REQ


OID
2.16.840.1.113730.3.1.3



mgrpDeliverTo


初出
iPlanet Messaging Server 5.0


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup


定義
メールグループのメンバーシップを指定する代替方法として使用されます。この属性の値は URL のリストであり、エクスパンドすると、メーリングリストのメンバーのアドレスが一覧表示されます。

Messaging Server は、この属性に RFC 1959 に説明されているフォーマットを使用した LDAP URL が入っていることを想定します。LDAP 検索の結果返されるエントリは、メーリンググループのメンバーです。これは、動的なメーリングリストを作成するために使用されます。


例
mgrpDeliverTo=ldap:/// ou=Accounting,o=iPlanet,c=US??sub?(& (objectClass=inetMailUser)(objectClass=inetOrgPerson))


OID
2.16.840.1.113730.3.1.25



mgrpDisallowedBroadcaster


初出
iPlanet Messaging Server 5.0


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup


定義
メッセージをメールグループに送信することを許可されていないメールユーザを識別します。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedDomain および mgrpDisallowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザの制限はありません。

Messaging Server は、この属性に識別名または RFC822address のどちらかが入っていることを想定します。識別名が使用される場合は、グループタイプまたは groupOfUniqueNames のメール可能なエントリ (複数も可) を表している必要があります。識別名は、RFC 1959 に説明されているとおりの、LDAP URL の形式で表されている必要があります。

複数の値を使用する場合は、各 URL がアドレスのリストにエクスパンドされ、各アドレスは、現在のエンベロープの送信元のアドレスに対照してチェックされます。一致した場合、そのメッセージは許可されません。


例
Example 1=mgrpDisallowedBroadcaster=ldap://uid=bjensen, o=sesta.com

Example 2=mgrpDisallowedBroadcaster=mailto:sys50@sesta.com


OID
2.16.840.1.113730.3.1.785



mgrpDisallowedDomain


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroup


定義
ユーザがそこからメッセージをメールグループに送信することを許可されないドメインを識別します。この属性は、メーリングリストを管理するために Messaging Server に使用される、非公開のエクステンション (拡張) です。この属性が存在する場合、リストされたドメインからのメッセージは拒否されます。この属性のインスタンスが inetMailGroup エントリに存在しない場合は、mgrpAllowedBroadcaster、mgrpDisallowedBroadcaster、および mgrpAllowedDomain 属性が使用されないかぎり、メッセージをメールグループに送信できるユーザの制限はありません。


例
mgrpDisallowedDomain=florizel.com


OID
2.16.840.1.113730.3.1.784



mgrpErrorsTo


初出
iPlanet Messaging Server 5.0


構文
ces、single-valued


オブジェクトクラス
inetMailGroup


定義
メッセージがこの (メーリング) リストに送信されたときに生成されるエラーメッセージの受取人。受取人のアドレスは、mailto 構文を使用して指定できます。この構文には、キーワード「mailto:」を前置する RFC 822 の電子メールアドレス、または単純な RFC 822 の電子メールアドレスが含まれます。また、LDAP URL の構文もサポートします。ただし、LDAP URL を使用する場合は、単一のアドレスを作成する URL であることが必要です。

エンベロープオリジネータのアドレスは、この属性の値に設定されます。


例
Example 1: mgrpErrorsTo=mailto:jordan@siroe.com
Example 2: mgrpErrorsTo=ldap:///uid=ofanning,ou=people,o=siroe.com,o=isp


OID
2.16.840.1.113730.3.1.26



mgrpModerator


初出
iPlanet Messaging Server 5.0


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup


定義
この (メーリング) リストにメッセージを送信することを許可されたモデレータを識別するための LDAP URI または mailto URL。モデレータによって送信されたメッセージだけが、このリストのメンバーに送信されます。モデレータ以外によって送信されたメッセージは、承認および再送信のためにモデレータに転送されます。

この属性の値として指定された URL が一連のアドレスにエクスパンドされ、エンベロープの「送信元」のアドレスと比較されます。アドレスが一致した場合は、グループ処理が続行されます。一致しなかった場合はこの属性の値がグループの URL となり、RFC 822 アドレスの任意のリスト、またはグループに関連付けられた DN がクリアされ、グループの配信オプションが「members」に設定されて、一致しなかった URL に対してそれ以上のグループ処理は行われません。


例
mgrpModerator=jordan@sesta.com


OID
2.16.840.1.113730.3.1.33



mgrpMsgMaxSize


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroup


定義
グループへ送信できる最大のメッセージサイズ (バイト数)。Messaging Server は、この属性のゼロまたは 1 つのインスタンスが、すべての mailGroup エントリに存在することを想定します。エントリがないと、グループへのメールに対し、サイズは制限されません。

この属性は廃止されましたが、後方互換性のため、引き続きサポートされます。この属性の代わりに、mailMsgMaxBlocks を使用してください。


例
mgrpMsgMaxSize=8000


OID
2.16.840.1.113730.3.1.3



mgrpMsgPrefixText


初出
実装されていません。


構文
UTF-8 テキスト、single-valued


オブジェクトクラス
inetMailGroup


定義
メッセージテキストの先頭に追加されるテキストを指定します。書式を指定する必要があります。つまり、テキスト内で書式を指定する場所に CRLF を挿入する必要があります。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例


OID
TBD



mgrpMsgRejectAction


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroup


定義
予約済


例


OID
2.16.840.1.113730.3.1.28



mgrpMsgRejectText


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroup


定義
グループアクセスの失敗時に int を使用するためのエラーテキストを指定します。このテキストは SMTP の応答に現われる可能性があるので、US-ASCII の単一行のテキストに制限されます。この属性内の最初のテキスト行だけを読み取り、その中に 8 ビット文字が含まれていない場合にだけ、この属性が実装されます。これは、SMTP プロトコルの制限です。


例


OID
2.16.840.1.113730.3.1.29



mgrpMsgSuffixText


初出
実装されていません。


構文
UTF-8 テキスト、single-valued


オブジェクトクラス
inetMailGroup


定義
テキストメッセージに付加されるテキストを指定します。書式を指定する必要があります。つまり、テキスト内に CRLF (キャリッジリターン、ラインフィーダ) を挿入する必要があります。

この属性は、imsimta dirsync オプションではなく、直接 LDAP モードにだけ作用します。


例


OID
TBD



mgrpNoDuplicateChecks


初出
iPlanet Messaging Server 5.0。iPlanet Messaging Server 5.2 に移行できるように実装されていない。


構文
cis、single-valued


オブジェクトクラス
inetMailGroup


定義
この属性は、これ以上サポートされません。重複しているかどうかのチェックは、リスト自体の特徴によって制御されます。結合されるリストもあれば、されないリストもあります。

従来の定義 : Messaging Server に、メールグループのメンバーに重複して配信したかどうかのチェックをさせないようにします。ユーザが複数のリストに登録されている場合は、重複した配信を防ぎます。No を指定すると、システムによって重複配信のチェックが行われます。Yes を指定すると、システムによる重複配信のチェックは行われません。


例
mgrpNoDuplicateChecks=yes


OID
2.16.840.1.113730.3.1.789



mgrpRemoveHeader


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroup


定義
各属性値で、メッセージヘッダーが存在する場合にメッセージヘッダーから削除するヘッダーフィールドを指定します。

MTA の場合、この属性の値は、ヘッダートリミングの MAXLINES=-1 オプションを設定するために使用されます。


例


OID
2.16.840.1.113730.3.1.801



mgrpRequestTo


初出
iPlanet Messaging Server 5.0


構文
ces、multi-valued


オブジェクトクラス
inetMailGroup


定義
追加要求のメッセージの受取人を識別する LDAP URL または mailto。この属性で、配布リスト用に新しいエイリアスが生成されます。このエイリアスは、distribution_list_name-request@domain の形式であり、このエイリアスに送信されたメッセージは、mgrpRequestsTo 内にリストされた受取人へ転送されます。


例
mgrpRequestsTo=jordan@sesta.com


OID
2.16.840.1.113730.3.1.782



mgrpRFC822MailMember


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailGroup


定義
メールグループへ送信されるメールの受取人を識別します。この属性と uniqueMember 属性の両方で指定されたメールの受取人は、混合される groupOfUniqueNames のメンバーではありません。この属性は、識別名で表すことのできないメールの受取人、または、このグループからメールを送信されることがあっても一意のグループメンバーの特権を持っていないメールの受取人を表します。Messaging Server では、この属性に RFC 822 のメールアドレスが入ることを想定します。通常は、ローカルディレクトリにないグループメンバーのために使用されます。

後方互換性のために rfc822MailMember もサポートされますが、任意の指定グループ内ではこれらの属性のうちの 1 つだけが使用できます。


例
mgrpRFC822MailMember=bjensen@siroe.com


OID
2.16.840.1.113730.3.1.30



mnggrpAdditionPolicy


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetManagedGroup


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.710



mnggrpBillableUser


初出
iPlanet Messaging Server 5.0


構文
DN、single-valued


オブジェクトクラス
inetManagedGroup


定義
このファミリーアカウントまたはユーザのグループの料金を支払う義務があるユーザの DN。


例
mnggrpBillableUser:uid=John,ou=people,o=sesta.com,o=isp


OID
2.16.840.1.113730.3.1.711



mnggrpCurrentUsers


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
inetManagedGroup


定義
管理グループ内に許可されている現在のユーザ数。この属性は、報告のみを目的としています。操作には何の影響もありません。


例
mnggrpCurrentUsers=20


OID
2.16.840.1.113730.3.1.714



mnggrpDeletionPolicy


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetManagedGroup


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.709



mnggrpMailQuota


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
inetManagedGroup


定義
管理グループ内のすべてのユーザに許可された累積ディスク割当。値が -1 の場合は、管理グループ内のユーザが使用するディスク容量に制限はありません。この属性は、報告のみを目的としています。操作には何の影響もありません。


例
mnggrpMailQuota=-1


OID
2.16.840.1.113730.3.1.715



mnggrpMaxUsers


初出
iPlanet Messaging Server 5.0


構文
int、single-valued


オブジェクトクラス
inetManagedGroup


定義
管理グループ内で許可されているユーザの最大数。


例
30


OID
2.16.840.1.113730.3.1.713



mnggrpStatus


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetManagedGroup


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.712



mnggrpUserClassOfServices


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetManagedGroup


定義
予約済


例
TBD


OID
2.16.840.1.113730.3.1.716



msgVanityDomain


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
msgVanityDomainUser


定義
ユーザに関連するバニティドメイン名。MTA によるルーティングのためにだけ使用されます。ユーザには引き続きアカウントに関連するプライマリドメインがあり、ユーザは、メッセージアクセスサービスにログインするためにそのプライマリドメインを使用します。ただし、この属性によって、ユーザはバニティドメイン名で表されるネームスペースに、電子メールアドレスを持つことができます。バニティドメインの作成方法についての詳細は、『iPlanet Messaging Server プロビジョニングガイド』(http://docs.iplanet.com/docs/manuals/messaging/ims50/pg/domains.htm#28035) のバニティドメインの節を参照してください。


例
msgVanityDomain=foo.com の場合、ユーザは、ドメイン部分が @foo.com のアドレスを持つことができます。


OID
2.16.840.1.113730.3.1.799



multiLineDescription


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
inetMailGroupManagement


定義
配布リストの詳細な説明。ドル記号 ($) を入れると、改行されます。


例
multiLineDescription=People who like cats.$And are ambivalent about people.


OID
1.3.6.1.4.1.250.1.2



nickName


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson, pabGroup


定義
pabPerson または pabGroup エントリを検索するために使用する短い名前を識別します。


例
nickname=Nick


OID
2.16.840.1.113730.3.1.720



nsDefaultMaxDeptSize


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDomain


定義
委任管理者に管理される、新しく作成された部署のデフォルトのサイズを、ユーザ数で指定します。


例
nsDefaultMaxDeptSize=20


OID
2.16.840.1.113730.3.1.562



nsMaxDepts


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDept, nsManagedDomain


定義
このオブジェクトに作成できる、グループエントリの最大数を指定します。


例
nsMaxDepts=200


OID
2.16.840.1.113730.3.1.557



nsMaxDomains


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDomain


定義
このオブジェクトに作成することが許可される、下位組織の最大数を指定します。


例
nsMaxDomains=50


OID
2.16.840.1.113730.3.1.561



nsMaxMailingLists


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDomain


定義
このエントリに作成できる、メーリングリストの最大数を指定します。


例
nsMaxMailingLists=200


OID
2.16.840.1.113730.3.1.559



nsMaxUsers


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDept


定義
このエントリに作成できる、ユーザの最大数を指定します。


例
nsMaxUsers=750


OID
2.16.840.1.113730.3.1.555



nsNumDepts


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDept, nsManagedDomain


定義
このオブジェクト下に存在する入れ子になっている部署数を追跡します。


例
nsNumDepts=35


OID
2.16.840.1.113730.3.1.556



nsNumDomains


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDomain


定義
このオブジェクト下に存在する下位組織の数を追跡します。


例
nsNumDomains=5


OID
2.16.840.1.113730.3.1.560



nsNumMailLists


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDomain


定義
このオブジェクト下に存在するメールリストの数を追跡します。


例
nsNumMailLists=200


OID
2.16.840.1.113730.3.1.558



nsNumUsers


初出
iPlanet Messaging Server 5.0


構文
int


オブジェクトクラス
nsManagedDept, nsManagedDomain


定義
このオブジェクトに作成できるユーザの数を追跡します。


例
nsNumUsers=2000


OID
2.16.840.1.113730.3.1.554



nsdaCapability


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
nsManagedPerson


定義
ユーザがメールリストを作成できるかどうかを指定します。


例


OID
2.16.840.1.113730.3.1.563



nsdaDomain


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
nsManagedPerson


定義
ユーザの組織を指定します。


例


OID
2.16.840.113730.3.1.600



nsdaModifiableBy


初出
iPlanet Messaging Server 5.0


構文
DN、single-valued


オブジェクトクラス
inetManagedGroup, nsManagedDept, nsManagedDomain


定義
この属性が現われているオブジェクトの変更アクセス権を持つユーザを指定します。ほかのグループを管理する権限を与えるために ACI とともに使用される管理者グループの DN です。


例
nsdaModifiableBy=cn=service administrators, ou=group, o=isp


OID
2.16.840.1.113730.3.1.565



nswmExtendedUserPrefs


初出
iPlanet Messaging Server 5.0


構文
cis、multi-valued


オブジェクトクラス
inetMailUser


定義
この属性は、「送信元」アドレスの並び順など Messenger Express の設定を定義するペアを保持します。この属性の各インスタンスは、pref_name=pref_value のタプルです。これは独自の構文であり、次の例は、この属性の説明のみを目的とします。


例
例 1: nswmExtendedUserPrefs=meColorSet=4
例 2: nswmExtendedUserPrefs=meSort=r
例 3: nswmExtendedUserPrefs=meAutoSign=True
例 4: nswmExtendedUserPrefs=meSignature=Otis
Fanning$ofanning@sesta.com
例 5: nswmExtendedUserPrefs=meDraftFolder=Drafts


OID
2.16.840.1.113730.3.1.520



o


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson


定義
ユーザが所属する会社または組織の名前。これは、「organizationName」の省略形です。


例
organizationName=Company22 Incorporated

または

o = Company22 Incorporated


OID
2.5.4.10



objectClass

初出

iPlanet Messaging Server 5.0


構文
cis


オブジェクトクラス
inetAdmin, nsManagedDept


定義
このオブジェクトクラスのオブジェクトを指定します。


例
objectClass = person


OID
2.5.4.0



organizationName


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson


定義
ユーザが所属する会社または組織の名前。


例
organizationName = Company22 Incorporated


OID
2.5.4.10



organizationUnitName (「ou」を参照)



ou


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson


定義
ユーザが所属する組織単位の名前。organizationalUnitName の省略形。


例
organizationUnitName=ou=docs


OID
2.16.840.1.113730.3.1.722



owner


初出
iPlanet Messaging Server 5.0


構文
DN、single-valued


オブジェクトクラス
inetManagedGroup


定義
エントリに対して管理権限を持つユーザまたはグループの識別名 (DN) を識別します。


例
owner= cn=John Smith, o=iPlanet, c=US


OID
2.5.4.32



pabURI


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
ipUser


定義
このユーザ用の個人アドレスブックのエントリのコンテナを指定する LDAP URI。「ldap://server:port/container_dn」の形式をとり、次のように定義されます。

  • server - 個人アドレスブックの LDAP サーバのホスト名。

  • port - 個人アドレスブックの LDAP サーバのポート。

  • container_dn - ユーザ用のすべての PAB エントリが作成されるサブツリーの DN。


例
pabURI=ldap://ldap.siroe.com:389/ou=ed,ou=people,o=sesta.com,o=isp, o=pab


OID
2.16.840.1.113730.3.1.703



postalAddress


初出
LDAP


構文
cis


オブジェクトクラス
icsCalendarResource


定義
エントリのメーリングアドレスを識別します。このフィールドには複数行を含めることができます。LDIF フォーマットで表す場合、各行はドル記号 ($) で区切る必要があります。

テキスト内で実際のドル記号 ($) や円記号 (\) を表す場合は、それぞれ \24 と \5c の 16 進数値でエスケープしてください。たとえば、次の文字列を表すとします。

The dollar ($) value can be found
in the c:\cost file.

実際に指定する文字列は、次のようになります。

The dollar(\24) value can be found$in the c:\5ccost file.


例
postalAddress = 123 Oak Street$Anytown, CA$90101


OID
2.5.4.16



preferredLanguage


初出
iPlanet Messaging Server 5.0, iPlanet Calendar Server 5.1


構文
RFC 2798、cis、single-valued


オブジェクトクラス
icsCalendarUser, mailDomain, inetMailGroup


定義
優先されるユーザの書き言葉または話し言葉。この属性の値は、HTTP Accetpt-Language ヘッダー値の構文に準拠していなければなりません。


例
preferredLanguage = fr, en-gb;q=0.8, en;q=0.7


OID
2.16.840.1.113730.3.1.39



preferredMailHost


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
このメールドメイン内に新しく作成されたユーザとグループの mailHost 属性を設定するために、Delegated Administrator によって使用されます。


例
preferredMailHost=mail.siroe.com


OID
2.16.840.1.113730.3.1.761



preferredMailMessageStore


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
mailDomain


定義
新しく作成されたユーザの mailMessageStore 属性を設定するために、Delegated Administrator for Messaging によって使用されます。値がない場合、Delegate Administrator は mailMessageStore 属性を空のまま残し、アクセスサーバは、ユーザのメールボックスがサーバインスタンスのデフォルトのパーティションにあるとみなします。


例
primary


OID
2.16.840.1.113730.3.1.762



seeAlso


初出
LDAP


構文
dn


オブジェクトクラス
groupOfUniqueNames


定義
このエントリに関連する情報を含んでいる可能性のある別の LDAP エントリを識別します。


例
seeAlso=cn=Quality Control Inspectors, ou=manufacturing, o=Company22, c=US


OID
2.5.4.34



sn


初出
LDAP


構文
cis


オブジェクトクラス
icsCalendarUser


定義
姓または家族名とも言われる、エントリの苗字を識別します。


例
surname:jones


OID
2.5.4.4



telephoneNumber


初出
LDAP


構文
tel


オブジェクトクラス
domain


定義
エントリの電話番号を識別します。


例
telephoneNumber = 800-555-1212


OID
2.5.4.20



uid


初出
LDAP


構文
cis、single-valued


オブジェクトクラス
icsCalendarResource, icsCalendarUser


定義
エントリのユーザ ID を識別します。これは、「userid」の省略形です。


例
userid = jdoe

または

uid = jdoe


OID
0.9.2342.19200300.100.1.1



un


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
pabPerson, pabGroup, pab


定義
PAB エントリに割り当てられた一意の名前。これもこのオブジェクトクラスによって作成されるエントリのために名前をつける属性であり、エントリのタイプ (pab、pabPerson、または pabGroup) に関係なく、すべての PAB エントリの DN を形成するために使用されます。


例
un=Nick


OID
2.16.840.1.113730.3.1.717



uniqueMember


初出
iPlanet Messaging Server 5.0


構文
dn


オブジェクトクラス
groupOfUniqueNames


定義
名前の一意性を確実にするために、各名前に uniqueIdentifier が指定された名前のグループのメンバーを識別します。uniqueMember 属性の値は、uniqueIdentifer が続く DN です。(uniqueIdentifers は、DN が再使用されたときにサーバによって割り当てられます。削除済み DN への参照インスタンスを検出することが目的です。


例
次の例で、uniqueIdentifier は AAAAA です。

uniqueMember=cn=Jane Doe, ou=Quality Control, o=Company22, AAAAA


OID
2.5.4.50



userid (「uid」を参照)



userPassword


初出
LDAP


構文
bin、single-valued


オブジェクトクラス
domain


定義
この属性で、エントリのパスワードと次の形式の暗号化方法を識別します。

{encryption method}encrypted password

基盤とするトランスポートサービスが機密性を保証できないならば、クリアテキストのパスワードを送信することはお勧めできません。クリアテキストを送信すると、承認されていないパーティーにパスワードが公開されてしまう可能性があります。


例
userPassword={sha}FTSLQhxXpA05


OID
2.5.4.35



vacationEndDate


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
userPresenceProfile


定義
休暇終了日時。日付の形式は、YYYYMMDDHHMMSSZ です。YYYY は 4 桁の西暦年、MM は 2 桁の月、DD は 2 桁の日、HH は 2 桁の時間、SS は 2 桁の秒です。時間は GMT を標準にしています。Z は、文字 Z です。


例
vacationEndDate=20000220000000Z


OID
2.16.840.1.113730.3.1.708



vacationStartDate


初出
iPlanet Messaging Server 5.0


構文
cis、single-valued


オブジェクトクラス
userPresenceProfile


定義
休暇開始日時。日付の形式は、YYYYMMDDHHMMSSZ です。YYYY は 4 桁の西暦年、MM は 2 桁の月、DD は 2 桁の日、HH は 2 桁の時間、SS は 2 桁の秒です。時間は GMT を標準にしています。Z は、文字 Z です。


例
vacationStartDate=20000215000000Z


OID
2.16.840.1.113730.3.1.707


前へ     目次     索引     DocHome     次へ     
Copyright © 2002 Sun Microsystems, Inc. All rights reserved.

最終更新日 2002 年 1 月 30 日