|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 10 8/11 Information Library|
- structure that specifies a driver's message-freeing routine
Architecture independent level 1 (DDI/DKI).
The free_rtn structure is referenced by the datab structure. When freeb(9F) is called to free the message, the driver's message-freeing routine (referenced through the free_rtn structure) is called, with arguments, to free the data buffer.
void (*free_func)() /* user's freeing routine */ char *free_arg /* arguments to free_func() */
The free_rtn structure is defined as type frtn_t.