|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 10 8/11 Information Library|
- USB device qualifier descriptor
Solaris DDI specific (Solaris DDI)
The device qualifier descriptor usb_dev_qlf_descr_t defines how fields of a high speed device's device descriptor would look if that device is run at a different speed. If a high-speed device is running currently at full/high speed, fields of this descriptor reflect how device descriptor fields would look if speed was changed to high/full. Please refer to section 9.6.2 of the USB 2.0 specification. The USB 2.0 specification is available at www.usb.org.
A device descriptor contains the following fields:
uint8_t bLength Size of this descriptor. uint8_t bDescriptorType Set to USB_DESCR_TYPE_DEV_QLF. uint16_t bcdUSB USB specification release number in binary coded decimal. uint8_t bDeviceClass Device class code. (See usb_dev_descr(9s).) uint8_t bDeviceSubClass Device subclass code.(See USB 2.0 specification of applicable device class for information.) uint8_t bDeviceProtocol Protocol code.(See USB 2.0 specification of applicable device class for information.) uint8_t bMaxPacketSize0 Maximum packet size of endpoint 0. uint8_t bNumConfigurations Number of available configurations. uint8_t bReserved Reserved.
See attributes(5) for descriptions of the following attributes:
attributes(5), usb_get_alt_if(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_get_string_descr(9F). usb_parse_data(9F), usb_ctrl_request(9S), usb_cfg_descr(9S), usb_dev_descr(9S), usb_ep_descr(9S), usb_if_descr(9S), usb_other_speed_cfg_descr(9S), usb_string_descr(9S)