|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library|
- return the sample rate of an audio engine
#include <sys/audio/audio_driver.h> int prefix_rate(void *state);
pointer to driver supplied soft state
Solaris DDI specific (Solaris DDI)
The audio_engine_rate() function is called by the framework to determine the sample rate of the engine, represented in Hz.
The audio_engine_rate() function returns the sample rate of the engine expressed in Hz.
This function may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes: