|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 11.1 Information Library|
- abort a SCSI command
#include <sys/scsi/scsi.h> int prefixtran_abort(struct scsi_address *ap, struct scsi_pkt *pkt);
Solaris architecture specific (Solaris DDI).
The tran_abort() vector in the scsi_hba_tran(9S) structure must be initialized during the HBA driver's attach(9E) to point to an HBA entry point to be called when a target driver calls scsi_abort(9F).
tran_abort() should attempt to abort the command pkt that has been transported to the HBA. If pkt is NULL, the HBA driver should attempt to abort all outstanding packets for the target/logical unit addressed by ap.
Depending on the state of a particular command in the transport layer, the HBA driver may not be able to abort the command.
While the abort is taking place, packets issued to the transported layer may or may not be aborted.
For each packet successfully aborted, tran_abort() must set the pkt_reason to CMD_ABORTED, and pkt_statistics must be OR'ed with STAT_ABORTED .
tran_abort() must return:
upon success or partial success.
The tran_abort() function can be called from user or interrupt context. This requirement comes from scsi_abort().
If pkt_reason already indicates that an earlier error had occurred, tran_abort() should not overwrite pkt_reason with CMD_ABORTED.