- get processor type truth value
The following commands will return a true value (exit code of 0) if you are using an instruction set that the command name indicates.
True if you are on a Sun system.
True if you are on a computer using an iAPX386 processor.
True if you are on a computer using a SPARC-family processor.
See attributes(5) for descriptions of the following attributes:
The machid family of commands is obsolete. Use uname -p and uname -m instead.