#include <sys/audio/audio_driver.h> uint64_t prefix_count(void *state);
pointer to driver supplied soft state
Solaris DDI specific (Solaris DDI)
The audio_engine_count() function returns the frame count of the engine, which is the number of frames transferred by the engine since it was last opened with audio_engine_open(9E).
For recording, this frame count will be the total number of frames that the engine has written into the buffer. For playback, it will be the number of frames that the engine has read from the buffer. This value is monotonically increasing and does not wrap.
The audio_engine_open() function, however, will reset the frame count to 0.
The frame count for the engine is related to the offset of the data in the buffer. Both normally increase as the engine makes progress, but the engine index wraps when it reaches the end of the buffer or when the device is stopped and restarted with audio_engine_stop(9E) and audio_engine_start(9E).
The audio_engine_count() function returns the number of frames transferred by the engine since audio_engine_open() was called.
This function may be called from user or interrupt context.
See attributes(5) for descriptions of the following attributes: