Go to main content

Oracle Solaris Cluster 4.3 Data Services Reference Manual

Exit Print View

Updated: September 2015
 
 

SUNW.ldom(5)

Name

SUNW.ldom, ldom - resource type implementation for failover logical domains.

Description

The Oracle Solaris Cluster data service for Oracle VM Server for SPARC is configured as a resource managed by the Oracle Solaris Cluster Resource Group Manager (RGM).

You must set the following properties on an LDoms resource by using clresource(1CL) man page.

Standard Properties

The standard resource property Failover is set for all failover resource types.

Resource_dependencies (string array)

Specifies a list of resources upon which a resource depends. This list includes any HAStoragePlus resources that are used by a resource. The default value for this property is null.

You can specify an alternate kind of dependency by using the Resource_dependencies_weak, Resource_dependencies_restart, or Resource_dependencies_offline_restart property instead of the Resource_dependencies property. For more information, see the r_properties(5) man page.

Category

Optional

Default

The empty list

Tunable

Any time

Failover_mode (enum)
Default

SOFT

Tunable

Any time

Pre_evict (boolean)

Allows the cluster framework to move excess workload off of the target node before the switchover begins. This allows the live migration to succeed more often and hence makes the process of switchover seamless.

For more information, see Pre_evict Resource Property in Oracle Solaris Cluster Data Services Developer’s Guide and SCHA_TARGET_NODES Query in Oracle Solaris Cluster Data Services Developer’s Guide .

Category

Optional

Default

True

Tunable

When disabled

Retry_count (integer)
Default

2

Tunable

When disabled

Retry_interval (integer)
Default

370

Tunable

When disabled

Thorough_probe_interval (integer)
Default

60

Tunable

Any time

Extension Properties

Domain_name (string)

Indicates the name of the logical domain.

Category

Required

Default

No default

Tunable

When disabled

Migration_type (enum)

This property specifies the type of migration when the resource is being switched over or a failover is triggered. Possible values are MIGRATE and NORMAL.

Even if the Migration_type property is set to MIGRATE, there may be cases where the cluster cannot determine the target node to which the resource group is migrating. In such cases, the cluster reverts to an ordinary resource group switchover in which it shuts down the logical domain on its current node before booting it on the new node. To achieve live migration, relocate the HA-LDOM resource group by using the clresourcegroup switch command explicitly on the resource group, rather than depending on node evacuation or strong resource group affinities to move the resource group.

Category

Optional

Default

MIGRATE

Tunable

Any time

Plugin_probe (string)

This property specifies the command that checks the status of the logical domain. This should return with an exit status of 0 if the logical domain is running properly. The probe status is used within the HA-xVM probing algorithm to determine whether to restart the logical domain locally or to failover the logical domain to another node.

Category

Optional

Default

Null

Tunable

Any time

password_file (string)

This property specifies the complete path to the file containing the target host password required for logical domain migration.

This property is obsolete as of version 6 of the SUNW.ldom resource type. Instead, use the rg-name_rs-name_ldompasswd private string, to store the password needed for live migration. For more information, see the clpstring(1CL) man page.

Category

Required if the Migration_type property is set to MIGRATE.

Default

No default

Tunable

Any time

Log_level (enum)

Specifies the level, or type of diagnostic messages that are logged by the LDoms data service. You can specify None, Info, or Err for this property. When you specify None, diagnostic messages are not logged by the LDoms data service. When you specify Info, both information and error messages are logged. When you specify Err, only error messages are logged.

Category

Optional

Default

Info

Tunable

Any time

Debug_level (string)

Specifies the command that sets up trace and debug messages. Increasing the debug_level allows more messages to be written to the system-log. You can set debug_level as a per-node extension property by setting it for one node or different values for each node.

Category

Optional

Per Node

True

Data Type

Integer

Minimum

0

Maximum

3

Default

0

Tunable

Any time

  • Setting Debug_level=0 does not produce any trace output or debug messages.

  • Setting Debug_level=1 does not produce any trace output; however, reduced debug messages are written to the system-log.

  • Setting Debug_level=2 produces trace output and all debug messages are written to the system-log.

  • Setting Debug_level=3 produces all debug messages that are written to the DEBUG_LOGFILE,/var/cluster/logs/DS/SUNW.ldom/message_log.${RESOURCE}.

Monitor_retry_count (integer)

This property controls the restarts of the fault monitor. It indicates the number of times the fault monitor is restarted by the process monitor facility and corresponds to the –n option passed to the pmfadm (1M) command. The number of restarts is counted in a specified time window (see the property Monitor_retry_interval). Note that this property refers to the restarts of the fault monitor itself, not logical domains. The restarts of the logical domain resources are controlled by the system-defined properties Thorough_Probe_Interval, Retry_Interval, and Retry_Count, as specified in their descriptions. See clresource (1CL) . You can modify the value for this property at any time.

Default

4

Tunable

Any time

Monitor_retry_interval (integer)

Indicates the time (in minutes) over which the failures of the fault monitor are counted and corresponds to the –t option passed to the pmfadm(1M) command. If the number of times the fault monitor fails exceeds the value of Monitor_retry_count, the fault monitor is not restarted by the process monitor facility. You can modify the value for this property at any time.

Default

2

Tunable

Any time

Probe_timeout (integer)

Indicates the time-out value (in seconds) used by the fault monitor to probe a logical domain instance. You can modify the value for this property at any time.

Default

30

Tunable

Any time

Examples

Example 1 Registering a SUNW.ldom Resource Type

The following example registers version 7 of the SUNW.ldom resource type, which represents the HA for Oracle VM for SPARC in an Oracle Solaris Cluster configuration.

# clresourcetype register SUNW.ldom:7
# clresourcetype show SUNW.ldom:7


=== Registered Resource Types ===

Resource Type:                SUNW.ldom:7
RT_description:               Oracle Solaris Cluster Data Service for Oracle VM Server for SPARC
RT_version:                   7
API_version:                  13
RT_basedir:                   /opt/SUNWscgds/bin
Single_instance:              False
Proxy:                        False
Init_nodes:                   All potential masters
Installed_nodes:              <All>
Failover:                     False
Pkglist:                      <NULL>
RT_system:                    False
Global_zone:                  False
Example 2 Creating a Failover Logical Domain Resource

The following example creates a failover logical domain resource named ldom-rs in an existing resource group named ldom-rg. In this example, ldg1 is the domain name of the ldom-rs resource. The fault monitor of the logical domain resource uses the plugin_probe script to check the status of the logical domain.

# clresourcetype register SUNW.ldom
# clpstring create -t resource -b ldom-rs ldom-rg_ldom-rs_passwd
Enter string value:
Enter string value again:
# clresource create -g ldom-rg -t SUNW.ldom:7 \
-p Domain_name=ldg1 \
-p Plugin_probe="/opt/SUNWscxvm/bin/ppkssh -P \
fmuser:/export/fmuser/.ssh/id_dsa:ldg1:multi-user-server:online" \
-p resource_dependencies_offline_restart=ldg1-hasp-rs \
ldom-rs 

Note -  You should install the logical domain data service before performing the steps in the example.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
ha-cluster/data-service/ha-ldom

See Also

pmfadm (1M) , scha_resource_open(3HA), clresourcetype (1CL) , clresourcegroup (1CL) , attributes (5) , r_properties (5)

Oracle Solaris Cluster 4.3 Data Services Planning and Administration Guide