Oracle® Fusion Middleware Oracle Access Management管理者ガイド 11g リリース2 (11.1.2.3) for All Platforms E61950-08 |
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この項では、起動の問題とその解決策を示します。
問題
AdminServerの起動が、次のメッセージを表示して失敗します。
"java.net.SocketException: No buffer space available".
オペレーティング・システムに設定されたAIXファイル記述子の数の構成が著しく高い場合(ファイル記述子ulimit
)、バッファ・オーバーフローが発生して、リモート登録は次のメッセージを表示して失敗します。
ulimit値はアプリケーションに依存しており、アプリケーション・プログラム・データおよびアプリケーション・スタックに排他的に適用されます。オープン・ファイルのデフォルト数設定(2000)は、通常はほとんどのアプリケーションで十分です。この値が低すぎると、ファイルを開く際や接続を確立する際にエラーが発生します。この値はサーバー・プロセスが開けるファイル記述子数を制限するため、値が低すぎると最適なパフォーマンスが損なわれます。AIXオペレーティング・システムでは、デフォルト設定は2000です。
解決策
ulimit
ファイル記述子限度を大きくすると、パフォーマンスが向上する場合があります。アプリケーションによっては、他の限度を大きくすることが必要になる場合もあります。
rootユーザーでログインします。
オープン・ファイル限度を10,000ファイルに変更するには、次のステップを実行します。
コマンド・ウィンドウを開きます。
/etc/security/limitsファイルを探して、AdminServerプロセスを実行するユーザー・アカウントに次の行を追加して編集します。
nofiles = 10000 nofiles_hard = 10000
ファイルを保存してAIXを再起動します。
コマンド・ウィンドウでTCP_TIMEWAIT間隔を、次のコマンドで状態を15秒に設定して減らします(これによりTCPはクローズした接続を速く解放でき、オープン接続が使用できるリソース数が増えます)。
/usr/sbin/no –o tcp_timewait =1
次のパラメータを、次に示すように256kにチューニングします。
no -a |grep space tcp_recvspace = 262144 tcp_sendspace = 262144 udp_recvspace = 262144 udp_sendspace = 262144
次のパラメータを、次に示すようにチューニングします。
no -o rfc1323=1 no -o sb_max=4194304
原因:
IAMSuiteAgentエージェントはOAMサーバーの前に開始しているため、これはOAMサーバーが実行している管理対象サーバーの正常な予想される動作です。
IAMSuiteAgentはすべてのWebLogicコンテナにデプロイされます。WebLogicコンテナが開始されると、エージェントはOAMサーバーに接続しようとします。接続が失敗すると、このメッセージがログに記録され、エージェントは後続のリクエストで接続を確立しようとします。エージェントが接続に成功すると、このメッセージは表示されなくなります。
解決策
OAMサーバーへの接続が正常に行われないと、構成されている場合は、IAMSuiteAgentはフォールバックし、WebLogicコンテナは保護を処理(ログインを含む)します。