Oracle® Fusion Middleware Oracle Access Management管理者ガイド 11g リリース2 (11.1.2.3) for All Platforms E61950-08 |
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一部のコンポーネントの自動生成された「説明」は翻訳されません。これは異常ではなく、管理者が「説明」を必要にあわせて変更できるようにします。このような変更に従うため、Oracleによる翻訳が可能になっていません。
リモート登録用の入力構成ファイルがUTF-8形式でない場合や、OAMサーバーがUTF-8ロケール(たとえばen_US.utf8)で起動していない場合、Oracle Access Managementコンソールでポリシーおよびリソースが正しく表示されません。
認証ポリシーおよび保護リソースを生成するためにリモート登録ツール用の構成ファイルoamregを作成する場合は、UTF-8エンコーディングを必ず使用してください。また、OAMサーバーをUTF-8ロケールのマシンで起動することも必要です。それ以外の場合、インバンド登録が成功した後にOracle Access Managementコンソールでポリシーとリソースがきれいに表示されない可能性があります。
WNAチャレンジ・メソッドが含まれるKerberos認証スキームを使用するようにAccess Managerを構成し、Microsoft Active Directoryに非ASCIIユーザーを作成します。
問題
ユーザー詳細を取得してサブジェクトにユーザーDNおよびGUID属性を移入しようとすると、例外が発生します。Active Directoryの非ASCIIユーザーがAccess Managerによって保護されたリソースにアクセスしようとすると、認証に失敗し、OAMサーバー・ログに次のエラーが記録されます。
... Failure getting users by attribute : cn, value ....
原因
属性のユーザー名はJava文字列としてそのまま渡されます。
解決策
ASCII以外のユーザーは、次のJVMシステム・プロパティ(組込みのWebLogic SPNEGOサポート用)を適用することで、Kerberos WNAスキームで保護されたリソースにアクセスできるようになりました。
-Dsun.security.krb5.msinterop.kstring=true
ASCIIではない名前を使用して、WebゲートをAccess Managerに登録します。アクセス・テスターで、有効なIPアドレス、ポートおよびエージェントID(非ASCII名)を入力し、「接続」をクリックします。
接続テストが失敗します。
ブラウザのロケールがサポートされていない場合、Oracle Access Managementコンソールのログイン・ページはサーバー・ロケールで表示されます。つまり、元の英語で表示されます。これは正常な動作です。
クライアントのロケールがサポートされていない場合、Oracle Access Managementはサーバー・ロケールに戻ります。
サーバー・ロケールがサポートされていない場合、Oracle Access Managementは英語に戻ります。
ユーザーがサポートされない言語を選択して「Access Manager SSO」ページに進むと、サーバー・ロケールで表示されます(たとえばドイツ語)。しかし、ログイン後は、すべてのページが英語で表示されます。
英語に戻る手順
「Access Manager SSO」ページを無効にすると、元のAccess Managerログイン・ページも英語に戻ります。