Logging Errors
The following tables highlight some common logging errors that users might encounter, including how to debug the errors. You can use the Log button on the application banner to review the log messages and debug information for disconnected applications, provided that logging has been enabled for the application. For more information, see Siebel Mobile Application Logging.
Logging Error 1
Item |
Description |
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Problem |
Data created in offline mode is not visible in online mode after triggering a data upload. The log event setting is set to UpSync (to debug issues with uploading data in offline mode). Messages similar to the following examples appear in the log console:
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Cause |
The cause of this problem can be one or more of the following:
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Solution |
The steps to debug using the logs are:
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Logging Error 2
Item |
Description |
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Problem |
After tapping Go Offline on the application banner, data extraction and the transition to offline mode is taking too long to complete. The log event setting is set to Data Extraction. Messages similar to the following examples appear in the log console:
The syntax for these error messages is as follows:
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Cause |
The cause of this problem can be one or more of the following:
|
Solution |
The steps to debug using the logs are:
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Logging Error 3
Item |
Description |
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Problem |
In offline mode when trying to save a newly created record, the following error message appears:
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Cause |
The field specified in the error message was not downloaded in offline mode. |
Solution |
The steps to debug are as follows:
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Logging Error 4
Item |
Description |
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Problem |
In offline mode when saving a newly created record, some default fields are populated with incorrect values and some fields are given validation error messages. The log event setting is set to Client System. A message similar to the following example appears in the log console:
The syntax for this error message is as follows:
A messages similar to the following example appears in the log console:
The syntax for this error message is as follows:
|
Cause |
There are issues in the Siebel Repository with the expressions configured for the PreDefault, PostDefault or ValidationSpec property of the BusComp field. |
Solution |
The steps to debug using the logs are:
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Logging Error 5
Item |
Description |
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Problem |
In offline mode when trying to save a newly created record, the following error message appears:
The log event setting is set to Client System (to debug error messages displayed in offline mode). A message similar to the following example appears in the log console:
The syntax for this error message is as follows:
A message similar to the following example appears in the log console:
The syntax for this error message is as follows:
|
Cause |
The suspected causes of this problem are:
|
Solution |
The steps to debug this error using the logs are:
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Logging Error 6
Item |
Description |
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Problem |
In offline mode, the applet shows an incorrect set of records or no records at all. The log event setting is set to Client System (to debug error messages displayed in offline mode). Messages similar to the following example appear in the log console:
The syntax for this error message is as
follows:
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Cause |
The cause of this problem can be one or more of the following:
|
Solution |
The steps to debug using the logs are:
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