Présentation des meilleures pratiques de Smart View

Il est recommandé de respecter les meilleures pratiques suivantes lors de l'utilisation de journaux Enterprise/ad hoc à partir de Smart View :

  • Vous devez mettre à niveau ou réinstaller les extensions pour toutes les mises à jour mensuelles. Reportez-vous aux sections Désinstallation des extensions et Mise à jour des extensions du guide Utilisation d'Oracle Smart View for Office (Mac et navigateur).
  • Ne saisissez pas de données en dehors de la grille mise en surbrillance pour la collecte de données. Des erreurs de non-validité risqueraient de survenir lors de l'enregistrement du journal.
  • Les utilisateurs peuvent se servir d'autres feuilles pour copier des données dans leur feuille Journaux Enterprise. Toutes les autres feuilles sont conservées lors de l'actualisation de la grille.
  • Après avoir actualisé/rechargé la feuille Journaux Enterprise, les calculs de référence des feuilles locales sont effacés mais les données sont conservées.
  • Si vous voulez enregistrer une feuille Journaux Enterprise pour l'utiliser ultérieurement, nous vous conseillons de la copier plutôt que de la renommer.
  • N'insérez ni colonnes ni lignes avec la fonctionnalité native d'Excel.
  • Il est préférable d'utiliser un import CSV lorsque les journaux comportent plus de 2 000 lignes.
  • L'option de langue dans Smart View doit correspondre aux préférences utilisateur du système d'exploitation, Microsoft Excel, et Web.
  • Dans les environnements locaux autres qu'anglais, l'option de langue par défaut n'est pas prise en charge dans l'extension Oracle Smart View for Office pour les journaux Enterprise.
  • Dans le cas d'un changement de connexions, déconnectez tout d'abord la connexion en cours, puis établissez la nouvelle connexion. Vous pouvez également utiliser Déconnecter tout (Connexions privées → Connexions privées → Déconnecter tout). Le mot de passe vous est demandé lors de la connexion suivante.

    Changement de connexions

  • Lorsque vous enregistrez la feuille :
    • Les valeurs de clé valides entrées manuellement pour les membres de référence de dimension remplissent automatiquement les membres de référence de dimension autre que de clé restants.
    • Les valeurs non valides entrées manuellement pour les membres de référence de dimension autre que de clé sont remplacées et validées avec les membres corrects.
  • Le complément fonctionne mieux avec un certain mode d'émulation de navigateur et WebView2 Runtime. Assurez-vous que les paramètres suivants sont corrects :

    1. Accédez à Smart View → Aide → Vérification de l'état.
    2. Définissez le mode Emulation de navigateur et WebView2 Runtime en fonction de la mise à jour que vous utilisez.

      L'image suivante présente les paramètres Mode Emulation de navigateur et WebView2 Runtime pour la mise à jour 25.01 et la mise à jour 24.100 de Smart View.

      Paramètres Mode Emulation de navigateur et WebView2 Runtime pour la mise à jour 25.01 et la mise à jour 24.100 de Smart View

      L'image suivante présente les paramètres Mode Emulation de navigateur et WebView2 Runtime pour les versions à partir de la mise à jour 25.02 et de la mise à jour 24.200 de Smart View.

      Paramètres Mode Emulation de navigateur et WebView2 Runtime pour les versions à partir de la mise à jour 25.02 et de la mise à jour 24.200 de Smart View

    3. Redémarrez Excel.
  • Dans certains cas, Excel peut s'arrêter brutalement. Pour résoudre ce problème, réinstallez Excel.
  • Pour vérifier que les extensions fonctionnent correctement, désactivez les extensions non requises. Pour ce faire, accédez à Fichier → Options → Compléments et procédez comme suit :
    • Désactivez tous les compléments COM à l'exception d'Oracle Smart View for Office.
    • Désactivez tous les compléments Excel à l'exception de Hstbar.