Failure Connecting to Oracle Analytics Cloud

Issue

In some cases, in an Oracle Analytics Cloud production environment, users may have issues connecting to Oracle Analytics Cloud from their Oracle Smart View for Office installation.

This is the type of scenario where this situation can occur:

  • Users connect to Oracle Analytics Cloud via VPN

  • Oracle Analytics Cloud is protected by Oracle Identity Cloud Service, which is requested through an Internet Proxy

  • Oracle Identity Cloud Service is integrated with a federated single-signon system, such as Ping Identity

  • Users on two different domains install Smart View via a package, delivered using Microsoft Application Virtualization (Microsoft App-V)

When trying to connect, an empty login screen pops up repeatedly, and then the login finally fails. This can happen when pasting a connection URL in the Private Connection Panel.

Cause

The root cause for this issue is that the Smart View packaged version, prior to login, opened a browser process named ielowutil.exe. The non-packaged local install of Smart View, or packaged install with Micorosoft Internet Explorer already running, both launched iexplore.exe instead.

The ielowutil.exe file is a special protected version of Internet Explorer named "Low MIC [Medium Integrity Cookie] Utility." It prevents the sharing of cookie data between processes of differing integrity.

This can explain why login to Oracle Analytics Cloud likely fails – since it requires cookie information that is set by both Oracle Identity Cloud Service and Ping Identity, and continues to assume the user is not logged in – redirecting back to Oracle Identity Cloud Service in a loop that escapes only after 12 times.

Note:

Microsoft discontinued support for Internet Explorer on June 15, 2022. However, you should not uninstall Internet Explorer. For more information, see Internet Explorer 11 End of Support and Smart View.

Solution

Using Process Monitor (Windows Sysinternals), the registry key used to read the browser was different in each case and was identified as followed:

  • Working Key:

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\(Default)

    Presents the value:

    Internet Explorer(Ver 1.0)

  • Non-working Key:

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)

    Presents the value:

    "%ProgramFiles(x86)%\Internet Explorer\ielowutil.exe" -CLSID:{0002DF01-0000-0000-C000-000000000046}

The registry key:

HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)

is a pointer to:

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)

Changing this key to a new value of:

"%ProgramFiles(x86)%\Internet Explorer\iexplore.exe"

results in the Smart View package calling iexplore.exe instead, and the login succeeding.

All registry checks and changes must be done in the same App-V Package/Version ID environment as the Smart View package, ensuring that the local system is left intact; that is:

regedit /appvve:307790F2-DE31-4EBE-B3BC-4C9337032E73_0BE1C6E6-85CC-48C3-A0FF-3BBB789681C3

Since users generally do not have admin access, you may roll out the fix to HKEY_CURRENT_USER by adding the key to the same path:

HKEY_CURRENT_USER\Software\Classes\Wow6432Node\CLSID\{0002DF01-0000-0000-C000-000000000046}\LocalServer32\(Default)

In the case of different Smart View packaged versions (some in an App-V connection group) across different domains, a PowerShell script can been written to identify the Smart View packages and make the correct registry changes.

Testing, this key change should result in Smart View users being able to successfully and consistently log in to Oracle Analytics Cloud.