Go to main content

Data Services Reference for Oracle® Solaris Cluster 4.4

Exit Print View

Updated: November 2019
 
 

SUNW.wls(7)

Name

SUNW.wls, wls - resource type implementation for failover WebLogic Server

Description

The Resource Group Manager (RGM) manages Oracle Solaris Cluster HA for WebLogic Server for Oracle Solaris Cluster. Use the clresource(8CL) command or a resource configuration GUI to set the following properties on WebLogic Server resources.

Standard Properties

See r_properties(7) for a complete description of the following resource properties.

Failover_mode
Default

SOFT

Tunable

Any time

Probe_timeout
Minimum

60

Default

180

Tunable

Any time

Retry_count
Maximum

10

Default

2

Tunable

Any time

Retry_interval
Maximum

3600

Default

1220

Tunable

Any time

Thorough_probe_interval
Maximum

3600

Default

120

Tunable

Any time

Extension Properties

Confdir_list

Type string array. No default value exists. Use this property to set the complete path to the WebLogic Server home directory, $WL_HOME .

You can modify this property only when you create the resource.

DB_Probe_Script

Type string. Default is null. This extension property can be used to set the complete path to a database probe script. The HA-WLS probe method probes only the WLS instances. The database probe script can be provided by using this extension property if the administrators want the HA_WLS to probe the database also. This probe script must return 0 for success. The WebLogic Servers are started only if this database probe returns success. If an HA-WLS probe detects a failure in a WebLogic Server instance and if this extension property is set, the HA-WLS probe takes action only if the database probe succeeds.

You can modify this property at any time.

Environment_File

Type string. Default is null. Use this property to set the absolute path to the WebLogic Server environment file. This file is typically installed in the $WEBLOGIC_HOME/server/bin directory when WebLogic Server is configured by using the installation wizard.

You can modify this property when the resource is disabled.

Monitor_Uri_List

Type string. Default is null. This property indicates the URI or list of URIs, separated by a comma, that can be used by the fault monitor to test the functionality of the WebLogic Server by running an HTTP GET command on the URI. The Server_Url extension property is for simple probes on the hostname and port. This extension property can be used to probe the WebLogic Server functionality by retrieving a Java servlet or making the WebLogic Server run an application and return an HTTP server code. If the HTTP server return code is 500 (Internal Server Error) or if the connection fails, the probe takes action. See the probe method for more details.

Make sure that the hostnames used in the server_url and monitor_uri_list are resolvable. If you use Fully Qualified Domain Names (FQDNs), then DNS must be enabled and /etc/nsswitch.conf must have the correct entries to resolve the hostnames by using DNS.

You can modify this property at any time.

Server_name

Type string. Default is null. A single start script can be used to start all the Managed Servers by passing the Managed Server name as an argument to the START script. If Agent START methods have to pass the server name as an argument to the START script, configure the Managed Server name in this extension property.

You can modify this property at any time.

Server_Url

Type string. No default value exists. This property indicates the URL of the WebLogic Server. The URL includes the protocol that is used to connect to the server, that this resource is configured to start. The probe method uses this URL to check the health of the server by running an HTTP GET command on the URL. The protocol in the URL must be set to http. The complete URL should be in the following form.

http://host:port

Make sure that the hostnames used in the server_url and monitor_uri_list are resolvable. If you use Fully Qualified Domain Names (FQDNs), then DNS must be enabled and /etc/nsswitch.conf must have the correct entries to resolve the hostnames by using DNS.

You can modify this property only when you create the resource.

Smooth_shutdown

Type Boolean. Default is False. This extension property can be used to enable smooth shutdown by using the WebLogic.Admin class. This extension property must be set to TRUE if a smooth shutdown is desired before trying to kill the WebLogic Server process. If this extension property is TRUE, the WLS_USER and WLS_PW must be set in the start_script and not in boot.properties.

Set this extension property to TRUE if all of the following apply.

  • Setting the username and password in the start_script is not a concern.

  • A smooth shutdown is desirable instead of the default, killing the process.

  • You are not concerned if the agent STOP method reads the user name and password from the START script and passes it to the java weblogic.Admin command.

You can modify this property at any time.

Start_Script

Type string. No default value exists. Use this property to set the complete path to the script that should be used to start the WebLogic Server instance (either Administration or Managed). This script is typically present under the domain name directory along with the config.xml file. A separate script or a single script can be configured for starting each WebLogic Server.

You can modify this property only when you create the resource.

Examples

Example 1 Creating a Simple WebLogic Server Resource

This example assumes that the START script, startWebLogic.sh, can start the WebLogic Server without any arguments to the script. The username and password needed to start the WebLogic Server can be configured within this START script or in the boot.properties file.

clresource create -g bea-rg -t SUNW.wls \
-p Confdir_list=/global/bea/beahome/weblogic700 \
-p Server_url=http://logical-host-1:7001 \
-p Start_script=/global/bea/beahome/user_projects/ha-wls/startWebLogic.sh bea-rs
Example 2 Creating a Managed Server Resource Whose Start Script Takes a Managed Server Name as an Input

For this example to work, the Admin_URL must be set within the Start_script startManagedWebLogic.sh.

clresource create -g bea-rg -t SUNW.wls \
-p Confdir_list=/global/bea/beahome/weblogic700 \
-p Server_url=http://logical-host-1:7004 \ 
-p Start_script=/global/bea/beahome/user_projects/ha-wls/startManagedWebLogic.sh \
-p Server_name=test1 bea-rs1
Example 3 Creating a WebLogic Server Managed Server Resource Which Should Be Shut Down Smoothly

This example creates a resource that has the extension property Smooth_shutdown set to TRUE. Setting this extension property to TRUE specifies that WebLogic Server will shut down the resource smoothly. If this extension property is not set to TRUE, the STOP method sends sigkill to the WebLogic Server. For the resource created in this example, the WebLogic Server first tries a smooth shutdown by using the Weblogic.Admin class. If this attempt is not successful, WebLogic Server uses sigkill. The WLS_PW and WLS_USER must be set in the START script startManagedWeblogic.sh. If these two parameters are not set in the START script, the resource creation fails.

clresource create -g bea-rg -t SUNW.wls \
-p Confdir_list=/global/bea/beahome/weblogic700 \
-p Server_url=http://logical-host-1:7008 \
-p Start_script=/global/bea/beahome/user_projects/ha-wls/startManagedWebLogic.sh \
-p Server_name=text2 -p smooth_shutdown=true bea-rs2
Example 4 Creating a WebLogic Server Resource that Should Probe the Database Before Taking Any Action on the WebLogic Server

This example creates a WebLogic Server resource that should probe the database before taking any action on the WebLogic Server. If the db_probe script is set, the WebLogic Server will not be started if the script returns a failure. When the WebLogic Server probe fails, action is taken only if the db_probe_script returns 0. This user-supplied database probe script must return 0 for success and non zero for failure.

clresource create -g bea-rg -t SUNW.wls \
-p Confdir_list=/global/bea/beahome/weblogic700 \
-p Server_url=http://logical-host-1:710 \
-p Start_script=/global/bea/beahome/user_projects/ha-wls/startManagedWebLogic.sh \
-p Server_name=test3 \
-p db_probe_script=/global/phys-pale-1/bea-db_probe_script bea-rs3
Example 5 Creating a WebLogic Server Resource that Should Also Monitor Some URIs Along With the Server_url Monitoring

This example creates a WebLogic Server resource that monitors URIs by using the Monitor_uri_list extension property. Action is taken only if the URI returns an http error 500 or if the connection to the WebLogic Server fails.

clresource create -g bea-rg -t SUNW.wls \
-p Confdir_list=/global/bea/beahome/weblogic700 \
-p Server_url=http://logical-host-1:7012 \
-p Start_script=/global/bea/beahome/user_projects/ha-wls/startManagedWebLogic.sh \
-p Server_name=test5 \
-p db_probe_script=/global/bea/db_probe_script \
-p monitor_uri_list=http://logical-host-1:7001/sctest bea-rs5

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
ha-cluster/data-service/weblogic

See Also

scha_resource_open(3HA), attributes(7), r_properties(7), clresource(8CL)

Oracle Solaris Cluster Data Service for Oracle WebLogic Server Guide

Previous
Next