Configuring Network High Availability for SR-IOV-Enabled Kernel Zones

You can achieve network high availability for SR-IOV devices within a kernel zone if the global zone is using datalink multipathing (DLMP) with SR-IOV.

To enable high availability, you must create a DLMP link aggregation of links with SR-IOV enabled in the global zone, then add an anet resource in the kernel zone that uses the DLMP aggregation as its lower link. Set the anet resource's iov property to auto and boot the zone.

For more information, see Datalink Multipathing Aggregations in Managing Network Datalinks in Oracle Solaris 11.4.

Example 2-12 Configure a DLMP Link Aggregation for Network High Availability in a Kernel Zone

global$ pfbash dladm set-linkprop -p iov=on net3
global$ dladm set-linkprop -p iov=on net4
global$ dladm create-aggr -l net3 -l net4 -m dlmp dlmp0
global$ zonecfg -z kz1
zonecfg:kz1> create -t SYSsolaris-kz
zonecfg:kz1> add anet
zonecfg:kz1:anet> set lower-link=dlmp0
zonecfg:kz1:anet> set iov=auto
zonecfg:kz1:anet> set id=0
zonecfg:kz1:anet> end

global$ zoneadm -z kz1 boot
global$ dladm show-aggr -C dlmp0
LINK       PORT           SPEED DUPLEX   STATE     CLIENTS
dlmp0      --             10000Mb full   up        --
           net3           10000Mb full   up        kz1/net0
           net4           10000Mb full   up        dlmp0

global$ zlogin kz1 dladm show-phys -i
LINK              MEDIA          ID       DEVICE      ACTIVE     STANDBY
net0              Ethernet       anet:0   vnic1000    ixgbevf0   zvnet0