Siebel Reports Administration Guide > Creating a Simple List Report > Example—Creating a Simple List Report >

Creating a New Report Object Definition in Siebel Tools

Each report design, whether custom or standard, normally has its own report object definition in Siebel Tools and a corresponding data supply library file. Report (and child) object definitions and exported datastream libraries are explained in About Data Definition for Reports.

In this example, you create a report object definition and children from scratch. An alternative approach is discussed in Copying a Report Object Definition.

To create a new report object definition (and children) in Siebel Tools

  1. Open Siebel Tools and navigate to the Report object type in the Object Explorer.
  2. Lock the Report project before proceeding to the next step. See Project in Step 4 for more information.
  3. Click any record in the Object List Editor. Add a report record by choosing
    Edit > New Record.
  4. In the new report record in the Object List Editor, enter properties as follows:
    • Name. Test Report

      This is the name used to refer to the report structure in Siebel Tools, for instance when you add the report to the Reports menu for a view.

    • Project. Report

      The Report project is standard for Siebel Sales. Report (SSV) is typically used for Siebel Service. Report projects are usually tied to specific Siebel applications.

    • Access Base DB Name. TESTREPT

      This specifies that Testrept.rox will be the name of the report executable invoked when this report object definition is invoked from the Reports menu in a view.

      NOTE:  Capitalization is not required, although this value for standard reports is capitalized.

    • Business Component. Opportunity

      The business component specified here is one that provides the records for the main report. Subreports (in more advanced reports) have their own business components.

    • Class. CSSActuateReportViewer

      This specifies that the report is an Actuate report.

    • Menu Text - String Override. Test Report

      This is the text that will appear in the Menu Text property field and in the Reports menu for a view when this report is included in the view through the use of a view report object definition.

    • Template Name. TESTREPT

      Specifies the name to be used for the generated data supply library file when the Generate Actuate Report option is invoked for this report object definition.

      NOTE:  Capitalization is not required, although the values of this property for standard reports are capitalized.

  5. Expand the Report object type in the Object Explorer tree and click the Report Field child object type to select it.

    Add a report field object definition by choosing Edit > New Record. Click the Field property. In the Field pick applet, choose Name.

    The Business Component property setting in the parent report object definition determines which fields can be included as report fields—namely, fields in that business component. Each report field object definition that you add as a child of the report defines a field that will be exported in the data supply library.

    NOTE:  A business component must be active before you can query a field in that business component. If the business component is not active, the field will not appear in the Reports Field dialog box.

    Repeat this step for the Account, Revenue, and Close Date fields.

    You can type in the name rather than looking it up in the pick applet. Match the spelling exactly.

  6. Click the parent object definition (Test Report) in the upper Object List Editor window. Choose Tools > Utilities > Generate Actuate Report.

    NOTE:  If you receive the message, '\ActuateX\eRDPro\AFC\afc.rol' file not found..., click OK. Search for the file in the Actuate release folder in the Program Files directory (or the equivalent on your system).

    This generates a data supply ROL file, named according to the value in the Template Name property, in the \Siebdev\RPTSRC\ENU\LIB folder (or the equivalent on your system).

    If your installation uses a non-English version of Siebel eBusiness Applications, you do not have an \ENU folder. Instead, you have a folder in the appropriate language code for your installation, such as \DEU for Germany.

    See Global Deployment Guide for a list of three-letter International Standards Organization (ISO) language extensions.

  7. Navigate to the View object type in the Object Explorer.
  8. In the Object List Editor, locate the Opportunity List View object definition and lock (Tools > Lock Project) the project associated with this view.

    In this example, the locked project is Oppty (SSE).

  9. In the Object Explorer, expand View and click View Report.

    This is the My Opportunities view in the Opportunities screen. You will add the new report to the Reports menu for this view.

  10. Add a view report object definition in the Object List Editor. Enter the name "Test Report" (match spelling and spacing exactly) and a sequence number that is greater by 1 than any other sequence number in the list.

    The name that you specify identifies the report object definition that defines the report, including the menu text to display and the report executable to invoke. The sequence number specifies the report's position in the menu relative to other reports.

  11. Choose Tools > Compile Project and recompile the repository. Move the resulting SRF file to the \OBJECTS directory of your Siebel Dedicated or Mobile Web Client; for example \Siebdev\OBJECTS.

    This last step is necessary for your Test Report to appear as a selection on the Reports button on the Opportunity List view. Repository compilation is not necessary for generating the data supply ROL file.

  12. From the Opportunity List View, unlock the project (Tools > Unlock Project) associated with this view.
  13. Unlock the Report project.
Siebel Reports Administration Guide