Siebel Reports Administration Guide > Creating a Simple List Report > Example—Creating a Simple List Report >

Creating a Report Design in Actuate e.Report Designer Professional

A report design file defines the layout and behavior for one report. In this exercise, a new report design is created from scratch, using library components.

To create a report design file in Actuate e.Report Designer Professional

  1. Open Actuate e.Report Designer Professional.
  2. Choose File > New. In the Create New Report window, select Blank Report and click OK.

    A blank design report appears.

  3. Delete the components Report and SimplePageList in the Content and PageList sections of the blank report.

    For removal of Report and SimplePageList components, it is recommended that the components be deleted using the Project Browser:

    1. Navigate to View > Project Browser > Symbols.
    2. Delete the following components under the class NewReportApp Subclass Of AcReport:
      • Class Report Subclass of AcReportSection.
      • Class SimplePageList Subclass of AcSimplePageList.

        Deleting from the Project Browser makes sure that these components are completely deleted from the report.

    3. Close the Project Browser.
  4. Choose Tools > Library Organizer.

    The Include Library window appears.

    1. Before adding the libraries remove the two existing sample libraries (erd_sample_library.rol and sample_sfdata_library.rol) and click More.
    2. Click Browse and navigate to \Siebdev\RPTSRC\LIB (or equivalent), choose sssiebel.rol, and click Open.
    3. Repeat this step for the files sscustom.rol, Testrept.rol, and sssiebel.bas.

      NOTE:  If the Testrept.rol library file is not in the folder named in Step b, navigate to \Siebdev\RPTSRC\ENU\LIB (or the equivalent on your system).

    4. Click OK to close the Include Library window when all the files are added.
    5. Click OK to close the Library Organizer.

      The files sssiebel.rol and sscustom.rol are required libraries for all Siebel standard and custom reports. Testrept.rol is the data supply ROL file that you generated from Siebel Tools; it will define the way data is transferred to the new report.

      Components from afc.rol (and or components from the Actuate e.Report Designer Professional toolbar) and sssiebel.rol should not be used by report developers for designing Siebel-Actuate reports. When developing Siebel application reports, only use the sscustom.rol library.

  5. Right-click on the top-level object (default name NewReportApp) and select Rename.

    The Rename window appears.

    • For the new name, input Testrept.

      It is recommended that the you use the same name you used for the ROD file saved previously (without the ROD extension).

  6. Double-click the Testrept (top level) icon in the structure tree.
    1. In the Component Editor window, click Class.
    2. Change the Super Class value from AcReport to ssReport.

      This is an important step. Siebel reports must inherit from ssReport (the Siebel standard report) instead of directly from AcReportSection (Actuate report). ssReport is provided in sscustom.rol and inherits from baseReport from sssiebel.rol.

      NOTE:  You cannot perform this step until you have included the sssiebel.rol library.

      Two components are automatically added to the report when you change the report's class: a report section (ssRpt) and a pagelist section (ssPageList).

  7. While still in the Component Editor for the Testrept (top level) icon, click Properties.
    • Scroll to the ssReportTitle property and enter the value Test Opportunity Report.

      This value is used in the window title for the report table of contents in the report viewer.

  8. Save the report design by choosing File > Save. Name the report Testrept.rod and specify a location where you want the report to be saved; for example:


    Remember to save the design file periodically as you work.

  9. Make sure that the Show Empty Slots option in View > Options is checked.

    You may want to deselect this option at a later time if you find the display of empty slots in the structure tree and layout pane distracting. For now, the empty slots must be visible because components will be dragged onto them from the sscustom library.

  10. Expand the top-level report component.
    1. Right-click the report section child component in the structure tree (ssRpt) and select Slot Information. The Single Structure Reference window appears.
    2. Verify name is set to ssRpt.
    3. Click Subclass and click Close. The report section child component will now be named ssRpt1. You must subclass each component you introduce into the report if you plan on modifying the component. Otherwise, the system will not allow your changes.
  11. Right-click the report section component (ssRpt1) and click Rename. Change the name to ssReportOpportunity.

    It is good design practice to employ naming conventions for components in your reports and to give them meaningful names. The ssReport prefix indicates that this is a report section based on the ssReport library component. The Opportunity suffix identifies this as the master report section in which opportunity records are displayed.

  12. Click the Library Browser button and choose Testrept.rol in the dialog box.

    The Library Browser window opens, displaying the contents of Testrept.rol, which is the data supply library you generated in Siebel Tools.

  13. Click the Library Browser button and open the sscustom.rol library. From the Library Browser window, drag and drop the ssFrm component onto the Content slot.

    NOTE:  When developing Siebel application reports, only use the sscustom.rol library. The use of Actuate components is not supported when modifying or developing reports.

    This creates a frame that defines what appears in each report row. The frame is a child of the report section component.

    1. Right-click the new frame (ssFrm) and select Slot Information. On the Single Structure Reference window, click Subclass. Click Close.
    2. Right-click the same frame and select Rename. Rename it ssFrmOpportunityContent. Close the Library Browser window.
  14. Drag and drop the datastream component (ssOpportunityQuery) from the Library Browser window onto the DataStream slot in the Design Editor. Close the Library Browser window.

    The datastream component is now a child of the report section component. The datastream defines the way data is supplied to generate report rows. Each data record generates one report row in the parent report section.

When making changes in Siebel Tools for a report originally designed in Actuate e.Report Designer Professional and regenerating an ROL file, be aware of the following:

  • Make sure that the ROD file that uses the ROL file is not open in Actuate e.Report Designer Professional.
  • If any report fields are deleted, make sure to remove the fields from your Actuate report as well.
  • Changes made to the ROL file are valid only for that instance of the ROL file. The changes will need to be entered again. However, if the changes are locally subclassed, they are safely stored in the ROD file.
Siebel Reports Administration Guide