| products | dev2dev | support | askBEA
 Download Docs   Site Map   Glossary 

JRockit for Windows and Linux User Guide

 Previous Next Contents View as PDF  

Using the JRockit Management Console

The JRockit Management Console can be used to supervise and monitor running instances of JRockit. It provides real-time information about the running application's characteristics, which can be used both during development—for example, to find where in an application's life cycle it consumes more memory—and in a deployed environment—for example, to monitor the system health of a running application server.

This section includes information on the following subjects:


Console Overhead

The extra cost of running the JRockit Management Console against a running JRockit is very small and can almost be disregarded. This provides for a very low cost monitoring and profiling of your application.


Starting the Console

Starting the JRockit Management Console is a two-step process:

  1. Enable the Management Server
  2. Start the JRockit Management Console

Additionally, you might want to also complete these tasks as part of the start-up process:

Enable the Management Server

Before the Management Console can connect to JRockit, the management server in the virtual machine needs to be started. The server is disabled by default. To enable the management server, start JRockit set the -Xmanagement option:


Start the JRockit Management Console

Start the JRockit Management Console from the command prompt by typing:

java -jar ManagementConsole.jar

Note: Before starting the Management Console, you must specify the JRE and the path to the .jar file.

Set the Port

When JRockit is started with the -Xmanagement option set—and provided JRockit is not running in "quiet" mode—it should print out a short message following the command line indicating that the management server is running and which port it is using. You can optionally choose which port to use by setting the port in the port property:


The default port the management server uses to connect is 7090. It is strongly recommended that you block this port in your firewall, otherwise unauthorized users might access the management server.

Change the Number of Connections

You can change the number of connections allowed to the server by setting the maxconnect property:

-Djrockit.managementserver.maxconnect=<maximum number of connections>

The default limit is four concurrent connections. While this should be enough for most users, you can change it, if necessary. The connection limit protects against Denial of Service (DoS) attacks by intruders.


Parts of the Console

When the JRockit Management Console window appears, the console has started, as shown in Figure 8-1:


Figure 8-1 JRockit Management Console


The JRockit Management Console window is divided into two panes: a connection browser tree in the left pane (Figure 8-2) and a tabbed interface in the right pane (Figure 8-3).

Figure 8-2 Connection Browser


Figure 8-3 Information Tabs (Administrator Mode)


The first tab shows an Overview of information for the selected JRockit connection(s) (as highlighted in the connection browser pane). The other tabs contain detailed information about different areas of JRockit, as will be described in Information Tabs" on page 8-16.

Figure 8-3 shows the information tabs available in the console's Administrator operation mode. When the console is in the Developer mode, additional tabs appear, as shown in Figure 8-4. These two operation modes are described in Setting the Operation Mode" on page 8-10.

Figure 8-4 Information Tabs (Developer Mode)


The console includes a toolbar that contains command buttons for some of the menu options (Figure 8-5). To toggle the Toolbar on or off, on the View menu select Tool Bar.

Figure 8-5 Management Console Toolbar


The status bar (Figure 8-6) at the bottom of the window displays information messages and tool tips when you hover over a toolbar button or select something in a menu. It also indicates whether the JRockit Management Console is connected to one or several JRockit implementations or not. To toggle the Status Bar on or off, on the View menu, select Status Bar.

Figure 8-6 Status Bar



Setting Up the Console

Once the console is running, you will need to configure it to suit your needs. Configuring—or "setting up"—the console includes these tasks:

Making Connections

The connection browser displays a collection of saved connections to JRockit organized in folders. If necessary, you can add your own folders and connection nodes to the tree structure. Active connections currently connected to a running JRockit are indicated by a green icon; those disconnected are indicated by a red icon.

Creating a New Folder

To create your own folder in the connection browser, do the following:

  1. Select an existing folder (for example, Connections) for which you want to create a subfolder.
  2. Open the New Folder dialog box by doing one of the following:

    The Add new folder dialog box (Figure 8-7) appears:

    Figure 8-7 Add New Folder Dialog Box


  3. Enter the name of the new folder in the text field and click OK.

    The new folder will appear in the connection browser.

Creating a New Connection

To create a new connection to JRockit in the connection browser, do the following:

  1. Select the folder in which the connection should be placed
  2. Open the New Connection dialog box by doing one of the following:

    The Add new connection dialog box (Figure 8-8) appears:

    Figure 8-8 Add New Connection Dialog Box


  3. Enter the name of the server, the port and the new connection in the appropriate text fields or retain the default values. Then, select or deselect Connect now and click Add Connection.

Connecting a Connection to JRockit

To connect to JRockit, do the following:

  1. Select the JRockit connection to connect, a subfolder of connections to connect, or the folder Connections to connect all existing connections.
  2. Do one of the following to connect the selected connection(s):

    When the connection is made, the status bar will read "Connected" and activity on the console will commence.

Disconnecting a Connection from JRockit

To disconnect a connection from JRockit, do the following:

  1. Select the JRockit connection to connect, a subfolder of connections to connect, or the folder Connections to disconnect all existing connections.
  2. Do one of the following to disconnect the selected connection(s):

    The connection will be lost and the status bar will indicate that you've been disconnected. All activity on the console will cease.

Renaming a Connection or Folder

To rename a connection or a folder of connection, do the following:

  1. Select the JRockit connection or folder to rename.
  2. Do one of the following to rename the selected connection or folder:

    The Folder properties dialog box (Figure 8-9) appears:

    Figure 8-9 Folder Properties Dialog Box


  3. Enter a new name into the text field and click OK

Note: If you select the last option (click the item label), the Folder properties dialog box will not appear. Instead, the label itself will be enabled for direct editing. Simply type the new name over the old and click away from the label.

Removing a Connection or Folder

To remove a connection or folder, do the following:

  1. Select a connection or a subfolder to remove.
  2. Do one of the following to remove the selected item:
  3. Click Yes on the confirmation dialog box that appears.

    The selected item disappears from the connection browser.

Hiding Disconnected Connections

Sometimes you might want to show just information about active JRockit connections. To hide information about disconnected connections, do one of the following:

To show the information about disconnected connections again, simply deselect Hide Disconnected in same way that you made the selection.

Enabling Console Settings

This section describes how to enable various JRockit Management Console settings.

Setting the Operation Mode

The Management Console can be run in two different operating modes:

To set the operation mode, do the following:

  1. From the Tools menu, select Preferences...

    The Preferences dialog box (Figure 8-10) appears:

    Figure 8-10 Preferences Menu (General Tab)


  2. Click the Mode of operation drop-down control to display the list of operation modes (Figure 8-11).

    Figure 8-11 List of Operation Modes


  3. Select the mode you want to use and click OK.

    Depending upon the mode to which you are toggling, the tabs on the console will change. See Figure 8-3 and Figure 8-4 for examples.

Setting Other Preferences

In addition to setting the operation mode, you can use the Preferences dialog box to change these settings:

To change either of these values, open the Preferences dialog box from the Tools menu and proceed are described in the following sections:

Setting E-mail Preferences

To change e-mail preferences, do the following:

  1. Display the General tab on the Preferences dialog box
  2. In the appropriate text fields, enter the new e-mail information (SMTP server and E-mail address), as shown in Figure 8-12.
  3. Click OK

    Figure 8-12 E-mail Preferences Panel




Enabling Persistence

Enabling the persistence means that aspect values are saved to a file and can be reviewed in charts by opening the View menu and selecting View Historical Data (View Historical Data" on page 8-29).

Selecting Aspects to Persist To set persistence preferences, do the following:

  1. Disconnect any JRockit connections.

    Note: If you have not disconnected the connections and attempt to use this dialog box, you will be prompted to disconnect.

    The checkboxes in the Aspects to persist panel become enabled (Figure 8-13):

    Figure 8-13 Aspects to Persist Panel


  2. Select the aspects you want to persist.
  3. Click OK.

    The selected aspect values are saved to a file that you can review in charts as described in View Historical Data" on page 8-29.

Specifying the Persistence Directory In addition to setting preferences for the aspects to persist, you can also specify where to save the file that contains the aspect value (the "Persistence directory"). To do so:

  1. Click Choose (next to the Persistence directory field).

    If you are still connected to JRockit, you will be prompted to disconnect; click Yes to proceed. A standard Open dialog box appears.

  2. Locate the directory where you want to save the file and click Open.

    The Open dialog box closes, returning you to the Preferences dialog box.

  3. Click OK.

    The new Persistence directory will appear in that field.

Erasing Persistence Value Logs Finally, you can erase all persistence value logs by clicking Clear all aspect logs. You will see a confirmation message to which you should respond Yes.

Customizing the Display

You can customize the console and change the way some of the monitoring data is displayed, as described in this section.

Customizing Gauges and Bars

The gauges and bars are graphical devices showing memory and processor usage (Figure 8-14).

Figure 8-14 Gauges and Bars


Customizing Charts

Charts appear on the JRockit Management Console to show specified information about JRockit.

Using the Settings File

When you exit the JRockit Management Console, your settings are automatically saved in a file called consolesettings.xml. This file is located in the folder:

<user home directory>\ManagementConsole

The exact path to the user home directory will vary on different platforms. On Windows it is usually something like \Documents and Settings\<username>; for example:

C:\Documents and Settings\jsmith\ManagementConsole

If no settings file exists in this directory it will be automatically created the next time the Management Console is closed.

Warning: Do not edit this file by hand! Doing so can make it unusable and may cause the Management Console to crash on startup.

If you are experiencing problems with the settings file, you can always delete it and let the Management Console create a new one for you.


Using the Console

The JRockit Management Console monitors different "aspects" of JRockit. An aspect is data that can be measured; for example, used heap size or JRockit uptime.

Information Tabs

Information tabs are pages containing details about different areas of the monitored JRockit. You can change tab by clicking on it or by accessing the View menu. This section describes the tabs available on the JRockit Management Console.

Overview Tab

The Overview tab (Figure 8-19) shows an overview of selected connections. To select more than one connection, select the folder containing the connections you want to view. They will appear simultaneously. The page is divided into a "dash board" with gauges in the upper part and charts in the lower part.

Figure 8-19 Overview Tab


Memory Tab

The Memory tab (Figure 8-20) shows information about the memory status of the system, as shown.

Figure 8-20 Memory Tab


At the bottom of the page the following text information is displayed (in kilobytes):

Processor Tab

The Processor tab (Figure 8-21) shows information about the processor status of the system.

Figure 8-21 Processor Tab


At the bottom of the page the following text information is displayed:

System Tab

The System tab (Figure 8-22) shows various information about the system status.

Figure 8-22 System Tab


Notification Tab

Use the Notification tab (Figure 8-23) to define alerts that notify users when certain events occur. You can create your own notification rules based on different triggers, with optional constraints, that alert you with a prescribed notification.

Figure 8-23 Notification Tab (No Rules Defined)


A notification trigger can be a certain event, for example, that the connection to JRockit was lost, or that an aspect reaches a certain value, for example, the used memory reaches 95%. A notification constraint can limit when a rule is triggered for example by not sending alerts at night or on certain dates.

The notification action is how the alert is communicated to the user. It can be one of the following:

Creating a New Rule

Rules determine when and how to issue a notification. To create a new rule, do the following:

  1. Click New Rule.

    The Name rule dialog box appears (Figure 8-24):

    Figure 8-24 Name Rule Dialog Box


  2. Enter the name of the new rule in Rule name: and click Next.

    The Select trigger dialog box appears (Figure 8-25):

    Figure 8-25 Select Trigger Dialog Box


  3. Select a trigger (the individual triggers are described in the right panel).
  4. Enter a threshold in the text box below the trigger list, if required (Figure 8-26; this box will be marked either Min value or Max value, depending on the type of trigger selected), and select further options under the Option tab.

    Figure 8-26 Trigger Threshold and Options Text Boxes


  5. Click Next.

    The Select Action dialog box appears (Figure 8-27):

    Figure 8-27 Select Action Dialog Box


  6. Select an action and enter settings data, if required.
  7. If necessary, add a constraint to the rule (this step is optional; if you don't want to add a constraint, go to step 8):
    1. Click Next.
    2. The Add Constraint dialog box appears (Figure 8-28):

      Figure 8-28 Add Constraint Dialog Box


    3. Select a constraint and click Add.
    4. The constraint name will appear in the add list, as shown in Figure 8-29.

      Figure 8-29 Constraint Added


    5. Enter constraint settings in the text fields under the list of constraints (Figure 8-29).
  8. Click Finish.

    The new rule appears in the All available rules list on the Notification tab, as shown in Figure 8-30.

    Figure 8-30 New Rule in List


  9. Add the rule to your connection as described in Add a Rule to JRockit" on page 8-28

Editing a Rule

To edit a rule, do the following:

  1. In the Available rules list, select the rule to be edited and click Edit Rule.
  2. Check the name of the rule, edit it, if necessary, and click Next.
  3. Check the trigger and trigger settings, edit them, if necessary, and click Next.
  4. Check the action and the action settings and edit them if necessary.
  5. To continue editing the rule, the do the following (optional; if you don't want to add a constraint, go to step 6):
    1. Click Next.
    2. Check the constraints and the constraint settings. Edit them, if necessary.
  6. To finish the editing a rule, click Finish.

Add a Rule to JRockit

To add a rule to JRockit, do the following:

  1. Select the rule to be added in the Available rules list.
  2. Click Add to JRockit.

    The rule appears in the Active rules for this connection list, as shown in Figure 8-31.

    Figure 8-31 Rule Added to Active rules for This Connection List


Remove a Rule from JRockit

To remove a rule from JRockit, do the following:

  1. Select the rule to be removed in the Active rules for this connection list.
  2. Click Remove from JRockit.

    The rule will now be removed from the Active rules for this connection list.

Remove a Rule

To remove a rule from the Available rules list, do the following:

  1. Select the rule to be removed.
  2. Click Remove Rule.

    A removal confirmation dialog box appears.

  3. Click Yes
  4. The rule disappears from the Available rules list.

View Historical Data

The historical data window displays a chart where historical data for an aspect can be viewed. This is useful for observing trends over time and, for example, finding when a server running with JRockit has its peak loads.

To open this window, do the following:

  1. Select the connection for which you want to view data.
  2. Open the View menu and select View Historical Data.
  3. Select the aspect for which you want to view historical data, as shown in Figure 8-32.

    Figure 8-32 View Menu with Historical Data Submenu Open


    Historical data for the selected aspect appears (Figure 8-33).

    Figure 8-33 Historical Data (CPU Load Selected)


  4. Navigate through time either by using the arrows or changing the start time in the Chart display settings.

To be able to observe historical data, aspect data from JRockit must first have been persisted, that is, written to file. See Setting Other Preferences" on page 8-11 to enable or disable persistence. The following aspects are possible to persist, and thus display, historical data for:

As soon as data has been created by a connected connection, it is available for historical observation.

Using Advanced Features of the Console

This section describes the more advanced features of the Management Console. Some of these are only available when running in the Developer mode, described in Setting the Operation Mode" on page 8-10.

View Thread Stack Dump

The stack dump contains a list of all running threads in JRockit with a method call stack trace for each thread.

To view the thread stack dump, open the Tool menu and select View Thread Stack Dump. A dialog box containing the stack dump appears (Figure 8-34).

Figure 8-34 Thread Stack Dump


Method Profiling Tab

Note: You must be in the developer operation mode before you can perform the tasks described in this section. For more information on entering the developer operation mode, see Setting the Operation Mode" on page 8-10

The Method Profiler tab allows the developer to monitor method execution in a non-intrusive way. The Method Profiler can provide information about the average time spent in selected methods and the number of times methods are invoked.

Method Templates are collections of methods that can be re-used on different connections. There is a Default template, but the user may also create new templates.

Adding a Method to a Template

To add a method to a template, do the following:

  1. Select the template to be modified from the Select template list.
  2. Click Add Method.

    The Enter class name dialog box appears (Figure 8-35).

    Figure 8-35 Enter Class Name Dialog Box


  3. Enter a fully qualified class name, for example, java.util.Vector, in the text field and click Next.

    The Select method dialog box appears (Figure 8-36):

    Figure 8-36 Select Method Dialog Box


  4. Select the methods to be added to the template and press Finish.

    The method name will appear on the Method profiling information list, as shown in Figure 8-37.

    Figure 8-37 Method Profiling Information List with Method Added


Removing a Method from a Template

To remove a method from a template, do the following:

  1. From the Select template list, select the template you want to modify.
  2. From the Method Profiling Information list, select the method(s) to be removed from the template.
  3. Click Remove Method.

Creating a New Template

To create a new template, do the following:

  1. Click New template.

    The New template dialog box appears (Figure 8-38).

    Figure 8-38 New Template Dialog Box


  2. Enter a name for the new template in the text field.
  3. Click OK.

Removing a Template

To remove a template, do the following:

  1. From the Select template list select the template to be removed.
  2. Click Remove.

    A confirmation dialog box appears.

  3. Click Yes.

Starting and Stopping Method Profiling

To start the method profiling, do the following:

  1. From the Select template list, select the template to be started.
  2. Click Start/Stop.

    If you select Start, numbers in the Invocation count cells for each method begin to increment. If you select Stop, this activity will cease.

Method Profiling Settings

You can switch between using qualified method names or short names in the method profiling table.

Exception Counting Tab

The Exception Count Tab (Figure 8-39) shows exceptions thrown in JRockit. It counts the number of exceptions of a certain type thrown.

Figure 8-39 Exception Counting Tab


Add an Exception

To add an exception to observe, do the following:

  1. Enter the fully qualified name of the exception into the text field at the top of the page, e.g., "".
  2. Choose whether or not all subclasses of that exception should be included in the count by selecting or deselecting the Include subclasses checkbox.
  3. Click Add. You can only add subclasses of java.lang.Throwable which are loaded in JRockit and you can only add exceptions while connected.

The exception should now be displayed in the table.

Starting, Stopping, and Removing an Exception Count

To start the exception count, click Start. The results should now appear next to the name of the exception being counted. Similarly, to stop the exception count, click Stop.

To remove an exception from the count, select the exception to be removed and click Remove.

Closing the Console

To close the JRockit Management Console and disconnect all connections, open the Connection menu and select Exit. Clicking X in the top right corner of the window will also close the JRockit Management Console.


Back to Top Previous Next