Chapter 14 Keyboard Shortcuts

The following tables list keyboard shortcuts for MySQL Workbench commands. Modifier in the tables stands for the platform-specific modifier key. This is Command on Mac OS X, Control on other platforms. On Mac OS X, the Alt key is Option.

There are keyboard shortcut tables for the File, Edit, View, Arrange, Model, Query, Database, Scripting, Help, and EER Diagram Mode menus.

File Menu

Table 14.1 File menu keyboard shortcuts

FunctionKeyboard ShortcutContext
New ModelModifier+NAll
Open ModelModifier+OAll
Open SQL ScriptModifier+Shift+OSQL Editor
Close TabModifier+W, Modifier+F4 on WindowsAll
Save ModelModifier+SModel
Save ScriptModifier+SSQL Editor
Save Model AsModifier+Shift+SModel
Save Script AsModifier+Shift+SSQL Editor
Forward Engineer SQL CREATE ScriptModifier+Shift+GModel
Forward Engineer SQL ALTER ScriptModifier+Alt+YModel
Synchronize With SQL CREATE ScriptModifier+Shift+YModel
PrintModifier+PEER Diagram mode only
ExitModifier+QAll

Edit Menu

Table 14.2 Edit menu keyboard shortcuts

FunctionKeyboard ShortcutContext
UndoModifier+ZModel, EER Diagram
RedoModifier+Y, Modifier+Shift+Z (Mac OS X)Model, EER Diagram
CutModifier+XAll
CopyModifier+CAll
PasteModifier+VAll
DeleteModifier+Delete, Command+BackSpace (Mac OS X)All
Edit SelectedModifier+EModel, EER Diagram
Edit Selected in New WindowModifier+Shift+EModel, EER Diagram
Select AllModifier+AEER Diagram
FindModifier+FAll
Find AdvancedModifier+Alt+FAll
Find NextF3All
Find PreviousShift+F3All
Search and ReplaceModifier+Shift+FAll
Comment/Uncomment lines of SQLModifier+/SQL Editor
Auto-Complete SQLModifier+SpaceSQL Editor

View Menu

Table 14.3 View menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Output WindowModifier+F2, Modifier+Option+2 (Mac OS X)All
Set Marker nModifier+Shift+n (n is integer 1..9)EER Diagram
Go to Marker nModifier+n (n is integer 1..9)EER Diagram

Arrange Menu

Table 14.4 Arrange menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Bring to FrontModifier+Shift+FEER Diagram
Send to BackModifier+Shift+BEER Diagram

Model Menu

Table 14.5 Model menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Add DiagramModifier+TModel, EER Diagram
Validate AllModifier+Alt+VModel, EER Diagram
Validate All (MySQL)Modifier+Alt+BModel, EER Diagram
Model OptionsCommand+Alt+, (Shortcut available only on Mac OS X)Model, EER Diagram

Query Menu

Table 14.6 Query menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Execute statementModifier+ReturnSQL Editor
Execute statementsModifier+Shift+ReturnSQL Editor
New TabModifier+TSQL Editor

Database Menu

Table 14.7 Database menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Query DatabaseModifier+UAll
Reverse EngineerModifier+RModel, EER Diagram
Forward EngineerModifier+GModel, EER Diagram
Synchronize ModelModifier+YModel, EER Diagram

Scripting Menu

Table 14.8 Scripting menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Scripting ShellModifier+F3, Modifier+Option+3 (on Mac OS X)All
Run Workbench Script FileModifier+Shift+RAll

Help Menu

Table 14.9 Help menu keyboard shortcuts

FunctionKeyboard ShortcutContext
Help IndexF1, Command+Option+question (on Mac OS X)All

EER Diagram Mode

In the EER Diagram view, a number of other keyboard shortcuts are available.

Table 14.10 EER diagram mode keyboard shortcuts

FunctionKeyboard Shortcut
Selection toolEscape
Hand toolH
Delete toolD
Layer toolL
Note toolN
Image toolI
Table toolT
View toolV
Routine Group toolG
Non-Identifying Relationship 1:11
Non-Identifying Relationship 1:n2
Identifying Relationship 1:13
Identifying Relationship 1:n4
Identifying Relationship n:m5
Relationship Using Existing Columns6

Table 14.11 Keyboard shortcut changes

MySQL Workbench versionThe Change
5.2.45The "Modifier+/" shortcut was added to comment/uncomment SQL in the SQL editor
5.2.45On Microsoft Windows, the "Modifier+W" shortcut was changed to "Control+F4" -- this shortcut closes MySQL Workbench tabs