- display the processor type of the current host
The mach command displays the processor-type of the current host.
See attributes(5) for descriptions of the following attributes:
mach and uname -p return equivalent values; therefore, Independent Software Vendors (ISV) and others who need to ascertain processor type are encouraged to use uname with the -p option instead of the mach command. The mach command is provided for compatibility with previous releases, but generally its use is discouraged.