- Intel 10Gb PCI Express NIC Driver
The ixgbe 10 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on Intel 10–Gigabit PCI Express Ethernet controllers.
The ixgbe driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.
The ixgbe driver and hardware support auto-negotiation, a protocol specified by the IEEE 802.3ae specification.
The cloning character-special device, /dev/ixgbe, is used to access all Intel 10 –Gigabit PCI Express Ethernet devices installed within the system.
You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.
The values returned by the driver in the DL_INFO_ACK primitive in response to your DL_INFO_REQ are:
Maximum SDU is 16366.
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP (Service Access Point) length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular SAP with the stream.
By default, the ixgbe driver performs auto-negotiation to select the link speed and mode. Link speed and mode can only be 10000 Mbps full-duplex. See the IEEE802.3 standard for more information.
Special character device.
32–bit device driver (x86).
64–bit device driver (x86).
64–bit device driver (SPARC).
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide
IEEE 802.3ae Specificiation, IEEE – 2002