- Neterion Xframe 10Gigabit Ethernet Network Adapter driver
The xge 10 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on S2IO Xframe 10-Gigabit Ethernet Network Adapter.
The xge driver functions includes controller initialization, frame transmit and receive, promiscuous and multicast support, TCP and UDP checksum offload (IPv4 and IPv6), 9622-byte jumbo frame, and error recovery and reporting.
The xge driver and hardware support the 10GBase-SR/W, LR/W, and ER/W 802.3 physical layer.
The cloning, character-special device /dev/xge is used to access all Xframe devices installed within the system.
The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are as follows:
Maximum SDU is 9600.
Minimum SDU is 0.
DSLAP address length is 8 bytes.
MAC type is DL_ETHER.
SAP length value is -2 meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.
Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
By default, the xge driver works without any configuration file.
You can check the running-time status of a device instance using ndd(1M). Currently, the driver provides an interface to print all hardware statistics.
For example, to print statistics of device xge0:
#ndd /dev/xge0 stats tmac_data_octets 772 tmac_frms 15 tmac_drop_frms 0 tmac_bcst_frms 6 tmac_mcst_frms 6 ... rmac_vld_frms 13 rmac_fcs_err_frms 0 rmac_drop_frms 0 rmac_vld_bcst_frms 7 rmac_vld_mcst_frms 11 rmac_out_rng_len_err_frms 0 rmac_in_rng_len_err_frms 0 rmac_long_frms 0 ... not_traffic_intr_cnt 242673 traffic_intr_cnt 28 ...
xge special character device
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers
STREAMS Programming Guide
Network Interfaces Programmer's Guide