|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Express 11/10|
- service management facility conventions for restarters
All service instances in the service management facility must be managed by a restarter. This manual page describes configuration, functionality, and reporting characteristics that are common to all restarters in the framework. Characteristics specific to a particular restarter are described in the restarter's man page.
For each managed service, a restarter relies on retrieving properties on the service instance to determine configuration. The restarter manages a set of property groups to communicate the current disposition of a service with display tools such as svcs(1).
The common restarter configuration for all services is captured in the general property group. This group includes the following required and optional property settings.
This is a required property. If set, the restarter of an instance attempts to maintain availability of the service.
This is an optional property that allows the specification of an alternate restarter to manage the service instance. If the restarter property is empty or absent, the restarter defaults to svc.startd(1M).
This is an optional property. When set, only one instance of the service is allowed to transition to an online or degraded status at any time.
All restarters report status using the restarter property group, which includes the following properties:
The current state and next state, if currently in transition, for instances stored in these properties. See smf(5) for a description of the potential states.
An astring with no spaces that contains a precise term to describe the full restarter-specific state in combination with the restarter state property. The auxiliary state cannot always be set and is always cleared during transition out of any state. Each restarter must define the precise list of auxiliary states it uses.
The time when the current state was reached.
The primary process contract ID, if any, under which the service instance is executing.