|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Information Library|
- password hashing module using SHA–256 message hash algorithm
This module is designed to make it difficult to crack passwords that use brute force attacks based on high speed SHA–256 implementations that use code inlining, unrolled loops, and table lookup.
The maximum password length for crypt_sha256 is 255 characters.
The following options can be passed to the module by means of crypt.conf(4):
Specifies the number of rounds of SHA-256 to use in generation of the salt; the default number of rounds is 5000. Negative values have no effect and are ignored. The minimum number of rounds cannot be below 1000.
The number of additional rounds is stored in the salt string returned by crypt_gensalt(3C). For example:
When crypt_gensalt(3C) is being used to generate a new salt, if the number of additional rounds configured in crypt.conf(4) is greater than that in the old salt, the value from crypt.conf(4) is used instead. This allows for migration to stronger (but more time-consuming) salts on password change.
See attributes(5) for descriptions of the following attributes: