|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 11 Information Library|
- authentication management PAM module using ruserok()
The rhosts PAM module, /usr/lib/security/pam_rhosts_auth.so.1, authenticates a user via the rlogin authentication protocol. Only pam_sm_authenticate() is implemented within this module. pam_sm_authenticate() uses the ruserok(3SOCKET) library function to authenticate the rlogin or rsh user. pam_sm_setcred() is a null function.
/usr/lib/security/pam_rhosts_auth.so.1 is designed to be stacked on top of the /usr/lib/security/pam_unix.so.1 module for both the rlogin and rsh services. This module is normally configured as sufficient so that subsequent authentication is performed only on failure of pam_sm_authenticate(). The following option may be passed in to this service module:
syslog(3C) debugging information at LOG_DEBUG level.
See attributes(5) for descriptions of the following attributes:
The interfaces in libpam() are MT-Safe only if each thread within the multi-threaded application uses its own PAM handle.