|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 10 1/13 Information Library|
- Linux branded zone
The lx brand uses the branded zones framework described in brands(5) to enable Linux binary applications to run unmodified on a machine with a Solaris Operating System kernel.
The lx brand includes the tools necessary to install a CentOS 3.x or Red Hat Enterprise Linux 3.x distribution inside a non-global zone. The brand supports the execution of 32-bit Linux applications on x86/x64 machines running the Solaris system in either 32-bit or 64-bit mode.
The lx brand emulates the system call interfaces provided by the Linux 2.4.21 kernel, as modified by Red Hat in the RHEL 3.x distributions. This kernel provides the system call interfaces consumed by the glibc version 2.3.2 released by Red Hat.
In addition, the lx brand partially emulates the Linux /dev and /proc interfaces.
The lx brand supports the whole root non-global zone model. All of the required linux packages are installed into the private file systems of the zone.
The zonecfg(1M) utility is used to configure an lx branded zone. Once a branded zone has been installed, that zone's brand cannot be changed or removed. The zoneadm(1M) utility is used to report the zone's brand type and administer the zone. The zlogin(1) utility is used to log in to the zone.
The lx zone only supports user-level Linux applications. You cannot use Linux device drivers, Linux kernel modules, or Linux file systems from inside an lx zone.
You cannot add any non-standard Solaris devices to a Linux zone. Any attempt to do so will result in a zone that zonecfg(1M) will refuse to verify.
You cannot run Solaris applications inside an lx zone. Solaris debugging tools such as DTrace (see dtrace(1M)) and mdb (see mdb(1)) can be applied to Linux processes executing inside the zone, but the tools themselves must be running in the global zone. Any core files generated are produced in the Solaris format, and such files can only be debugged with Solaris tools.
See attributes(5) for a description of the following attributes:
This feature might be removed in a future release.