|Skip Navigation Links|
|Exit Print View|
|man pages section 5: Standards, Environments, and Macros Oracle Solaris 10 1/13 Information Library|
- OpenSSL cryptographic & Secure Sockets Layer toolkit
OpenSSL is a cryptography toolkit that implements the Secure Sockets Layer (SSLv2/v3) and Transport Layer Security (TLS v1) network protocols.
The following features are omitted from the binaries for issues including but not limited to patents, trademark, and US export restrictions: MDC2, RC3, RC5, IDEA, ECC, Dynamic Engine Loading, CSWIFT Engine, nCipher Engine, Atalla Engine, NURON Engine, UBSEC Engine, AEP Engine, Sureware Engine, and 4758_CCA Engine.
A new PKCS#11 engine has been included with ENGINE name “pkcs11”. The engine was developed in Sun and is not integrated in the OpenSSL project.
The PKCS#11 engine is configured to use the Solaris Cryptographic Framework. See cryptoadm(1M) for configuration information.
The PKCS#11 engine can support the following set of mechanisms: CKM_AES_CBC, CKM_AES_ECB, CKM_BLOWFISH_CBC, CKM_DES_CBC, CKM_DES_ECB, CKM_DES3_CBC, CKM_DES3_ECB, CKM_DSA, CKM_MD5, CKM_RC4, CKM_RSA_PKCS, CKM_RSA_X_509, CKM_SHA_1, CKM_SHA224, CKM_SHA256, CKM_SHA384, and CKM_SHA512.
The set of mechanisms available depends on installed Crypto Framework providers. To see what mechanisms can be off loaded to the Cryptographic Framework through the PKCS#11 engine on a given machine, run the following command:
/usr/sfw/bin/openssl engine -vvv -t -c
Due to requirements of the PKCS#11 standard regarding fork(2) behavior, some applications that use the OpenSSL EVP interfaces and fork() with active crypto contexts might experience unexpected behavior.
To build an OpenSSL application, use the following cc command line options:
cc [ flag... ] file... -I/usr/sfw/include -lcrypto -lssl \ -L/usr/sfw/lib -R/usr/sfw/lib [ library... ]
Extensive additional documentation for OpenSSL modules is available in the /usr/sfw/share/man directory. This documentation can be viewed with man(1) by including /usr/sfw/share/man in the MANPATH environment variable. Running catman(1M) on the OpenSSL manual pages is not supported.
To view the license terms, attribution, and copyright for OpenSSL, see /var/sadm/pkg/SUNWopensslr/install/copyright.
See attributes(5) for a description of the following attributes:
/usr/share/man/man1openssl/openssl.1openssl, /usr/sfw/man/man3/engine.3, /usr/sfw/man/man3/evp.3