man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2014
 
 

audio_engine_format(9E)

Name

audio_engine_format - return the sample format for an audio engine

Synopsis

#include <sys/audio/audio_driver.h>

int prefix_format(void *state);

Parameters

state

pointer to driver supplied soft state

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_engine_format() function is called by the framework to determine the format of the engine.

The audio framework supports the following formats for audio engines:

AUDIO_FORMAT_S16_LE

16-bit signed little endian linear PCM

AUDIO_FORMAT_S16_BE

16-bit signed big endian linear PCM

AUDIO_FORMAT_S24_LE

24-bit signed little endian linear PCM

AUDIO_FORMAT_S24_BE

24-bit signed big endian linear PCM

AUDIO_FORMAT_S32_LE

32-bit signed little endian linear PCM

AUDIO_FORMAT_S32_BE

32-bit signed big endian linear PCM

The 24-bit bit types above store each 24-bit sample in a 32-bit word.

An audio engine may not change the format it uses while it is open.

Return Values

The audio_engine_format() function returns the audio format of the engine.

Context

This function may be called from user or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See also

attributes(5), audio(7D) , audio_engine_ops(9S)