man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2014
 
 

audio_engine_qlen(9E)

Name

audio_engine_qlen - return the depth of an audio engine's queue

Synopsis

#include <sys/audio/audio_driver.h>

uint_t prefix_qlen(void *state);

Parameters

state

pointer to driver supplied soft state

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_engine_qlen() function returns the depth, in frames, of any on-device FIFO. It is used to improve the latency-related calculations in the framework. For most devices the value 0 is appropriate, since they DMA directly from the buffer into the codec.

Return Values

The audio_engine_qlen() function returns the depth of any hardware FIFO as a count in frames.

Context

This function may be called from user or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See also

attributes(5), audio(7D) , audio_engine_ops(9S)