Sun Microsystems Logo
Products and Services
 
Support and Training
 
 

A  B  C  D  E  F  G  H  I  J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z  
 
Application Server Utilityappclient(1m)


NAME

 appclient - launches the Application Client Container and invokes the client application packaged in the application JAR file

SYNOPSIS

 appclient -client client_application_jar [-mainclass client_application_main_classname|-name display_name] [-xml sun-acc.xml file] [-textauth] [app-args]

DESCRIPTION

Use the appclient command to launch the application client container and invoke a client application that is packaged in an application JAR file.

The application client container is a set of java classes, libraries and other files that are required to execute a first-tier application client program on a Java Virtual Machine (JVM). The application client container communicates with the Application Server using RMI-IIOP.

OPTIONS

-client

required; the name and location for the client application jar file.

-mainclass

optional; the full classname of the main client application main() method that will be invoked by the Application Client Container. Used for a single client application.

-name

optional; the display name for the client application. Used for multiple client applications.

-xml

optional if using the default domain and instance, otherwise it is required; identifies the name and location of the client configuration XML file. If not specified, defaults to the value of $AS_ACC_CONFIG identified in asenv.conf file.

-textauth

optional; used to specify using text format authentication when authentication is needed.

app-args

optional; represents s list of arguments, separated by spaces, passed to the clients main () method.

EXAMPLES

Example 1. Using the appclient command
appclient -client sunoneappserv/bin/myclientapp.jar 
-mainclass com.sun.test.TestAppClient -xml sun-acc.xml scott sample

Where: sunoneappserv/bin/myclientapp.jar is the full path for the client application .jar file, com.sun.text.TestAppClient is the full Java package name of the main client application, scott and sample are arguments to pass to the application, and sun-acc.xml is the name of the client configuration XML file. If sun-acc.xml is not in the current directory, you must give the absolute path location; otherwise the relative path is used. The relative path is relative to the directory where the command is being executed.

ATTRIBUTES

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPEATTRIBUTE VALUE
Interface StabilityUnstable

SEE ALSO

package-appclient(1M), asadmin(1M)


Sun Java System Application ServerGo To TopLast Changed 29 Dec 2003