|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- split a PKCS #12 file into separate certificate and key files
/usr/lib/inet/wanboot/p12split -i p12file -c out_cert -k out_key [-t out_trust -l id -v]
The p12split utility extracts a certificate and private key from the repository specified by p12file, depositing the certificate in out_cert and the key in out_key. If supplied, the -l option specifies the value for the LocalKeyId that will be used in the new certificate and key files. p12split can optionally extract a trust certificate into the out_trust file if the -t option is specified. Use the -v option to get a verbose description of the split displayed to standard output.
The following arguments and options are supported:
Specifies a repository that receives a extracted certificate.
Specifies a repository from which a certificate and private key is extracted.
Specifies a repository that receives a extracted private key.
Specifies the value for the LocalKeyId that will be used in the new certificate and key files.
Specifies a file for receiving an extracted trust certificate.
Displays a verbose description of the split to stdout.
An error occurred.
See attributes(5) for descriptions of the following attributes: