|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11.1 Information Library|
- rebuild NIS database
cd /var/yp ; make [map]
The file called Makefile in /var/yp is used by make(1S) to build the Network Information Service (NIS) database. With no arguments, make creates dbm databases for any NIS maps that are out-of-date, and then executes yppush(1M) to notify slave databases that there has been a change.
If you supply a map on the command line, make will update that map only. Typing make passwd will create and yppush the password database (assuming it is out of date). Likewise, make ipnodes and make networks will create and yppush the ipnodes and network files, $(INETDIR)/ipnodes and $(DIR)/networks.
There are four special variables used by make: DIR, which gives the directory of the source files; NOPUSH, which when non-null inhibits doing a yppush of the new database files; INETDIR, which gives the directory of the ipnodes source file; and DOM, which is used to construct a domain other than the master's default domain. The default for DIR is /etc, and the default for INETDIR is /etc/inet. The default for NOPUSH is the null string.
If a NIS to LDAP (N2L) configuration file, /var/yp/NISLDAPmapping, is present, the NIS server components run in N2L mode. In N2L mode, the server components use a new set of map files with an LDAP-prefix, based on the LDAP DIT. In N2L mode, authoritative NIS information is obtained from the DIT. The NIS source files and ypmake have no role, and they should not be used. If ypmake is accidentally run, then the server components will detect this, and will log a warning message. For additional information, see ypfiles(4).
Directory containing NIS configuration files.
System hosts file.
Default directory for source files.
See attributes(5) for descriptions of the following attributes:
The Network Information Service (NIS) was formerly known as Sun Yellow Pages (YP). The functionality of the two remains the same. Only the name has changed. The name Yellow Pages is a registered trademark in the United Kingdom of British Telecommunications plc, and may not be used without permission.