|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- convert a JavaSpaces datastore to the newer Reliable Log datastore format
A Reliable Log directory is created that contains the converted data. This directory is named /var/sadm/wbem/logr.
The convert argument is the only supported option of this command. You should only run this command after stopping WBEM (CIM Object Manager) with the init.wbem stop command. Otherwise your data may be corrupted.
This command successfully converts any proprietary custom MOFs you have created in the datastore, but not any CIM or Solaris MOFs you have modified. These will be destroyed. To recompile any modified CIM or Solaris MOFs into the new datastore, run the mofcomp command on the MOF files containing the class definitions.
Because the wbemconfig convert command invokes the JVM (Java Virtual Machine) to perform conversion of the JavaSpaces datastore, you must be running the same version of the JVM as when the original JavaSpaces storage was created. After the wbemconfig convert command is completed, you can change to any version of the JVM you want.
To see what version of the JVM you are running, issue the java -version command.
The following options are supported:
Convert a JavaSpaces datastore to the newer Reliable Log datastore format.
See attributes(5) for descriptions of the following attributes: