|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 1/13 Information Library|
- delete a user's login from the system
userdel [-r] login
The userdel utility deletes a user account from the system and makes the appropriate account-related changes to the system file and file system.
The following options are supported:
Remove the user's home directory from the system. This directory must exist. The files and directories under the home directory will no longer be accessible following successful execution of the command.
The following operands are supported:
An existing login name to be deleted.
The following exit values are returned:
Invalid command syntax. A usage message for the userdel command is displayed.
The account to be removed does not exist.
The account to be removed is in use.
Cannot update the /etc/group or /etc/user_attr file but the login is removed from the /etc/passwd file.
Cannot remove or otherwise modify the home directory.
system password file
system file contain users' encrypted passwords and related information
system file containing group definitions
system file containing additional user attributes
See attributes(5) for descriptions of the following attributes:
auths(1), passwd(1), profiles(1), roles(1), users(1B), groupadd(1M), groupdel(1M), groupmod(1M), logins(1M), roleadd(1M), rolemod(1M), useradd(1M), userdel(1M), usermod(1M), passwd(4), prof_attr(4), user_attr(4), attributes(5)
The userdel utility only deletes an account definition that is in the local /etc/group, /etc/passwd, /etc/shadow, and /etc/user_attr file. file. If a network name service such as NIS or NIS+ is being used to supplement the local /etc/passwd file with additional entries, userdel cannot change information supplied by the network name service.