|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 10 1/13 Information Library|
- request to notify SCSI target of bus reset
#include <sys/scsi/scsi.h> int prefixtran_reset_notify(struct scsi_address *ap, int flag, void (*callback, caddr_t),caddr_t arg);
Solaris architecture specific (Solaris DDI).
Pointer to the scsi_address(9S) structure.
A flag indicating registration or cancellation of a notification request.
A pointer to the target driver's reset notification function.
The callback function argument.
The tran_reset_notify() entry point is called when a target driver requests notification of a bus reset.
The tran_reset_notify() vector in the scsi_hba_tran(9S) structure may be initialized in the HBA driver's attach(9E) routine to point to the HBA entry point to be called when a target driver calls scsi_reset_notify(9F).
The argument flag is used to register or cancel the notification. The supported values for flag are as follows:
Register callback as the reset notification function for the target.
Cancel the reset notification request for the target.
The HBA driver maintains a list of reset notification requests registered by the target drivers. When a bus reset occurs, the HBA driver notifies registered target drivers by calling the callback routine, callback, with the argument, arg, for each registered target.
For SCSI_RESET_NOTIFY requests, tran_reset_notify() must return DDI_SUCCESS if the notification request has been accepted, and DDI_FAILURE otherwise.
For SCSI_RESET_CANCEL requests, tran_reset_notify() must return DDI_SUCCESS if the notification request has been canceled, and DDI_FAILURE otherwise.