|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Driver Entry Points Oracle Solaris 10 1/13 Information Library|
- request to free HBA resources allocated on behalf of a target
#include <sys/scsi/scsi.h> void prefixtran_tgt_free(dev_info_t *hba_dip, dev_info_t *tgt_dip, scsi_hba_tran_t *hba_tran, struct scsi_device *sd);
Solaris architecture specific (Solaris DDI).
Pointer to a dev_info_t structure, referring to the HBA device instance.
Pointer to a dev_info_t structure, referring to the target device instance.
Pointer to a scsi_hba_tran(9S) structure, consisting of the HBA's transport vectors.
Pointer to a scsi_device(9S) structure, describing the target.
The tran_tgt_free() vector in the scsi_hba_tran(9S) structure may be initialized during the HBA driver's attach(9E) to point to an HBA driver function to be called by the system when an instance of a target device is being detached. The tran_tgt_free() vector, if not NULL, is called after the target device instance has returned successfully from its detach(9E) entry point, but before the dev_info node structure is removed from the system. The HBA driver should release any resources allocated during its tran_tgt_init() or tran_tgt_probe() initialization performed for this target device instance.